diskstats plugin: error "Byte order is not compatible"

Bug #872217 reported by Daniel Hahler on 2011-10-11
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
munin
Fix Released
Unknown
munin (Ubuntu)
Medium
Vibhav Pant

Bug Description

The diskstats plugin fails to provide any data since a while:

    % sudo munin-run diskstats
    Byte order is not compatible at ../../lib/Storable.pm (autosplit into ../../lib/auto/Storable/thaw.al) line 415, at /etc/munin/plugins/diskstats line 120

Line 120 mentioned in the error is the second line of the following return value in the function choose_old_state:

    return $return_timestamp,
      %{ thaw decode_base64 $states{$return_timestamp} };

I assume that upgrading from Ubuntu Natty to Oneiric might have caused this?!

I am using munin 1.4.6-1ubuntu1 currently, which has not made it into Ubuntu though yet (merged from Debian by myself).

WORKAROUND:
sudo rm /var/lib/munin/plugin-state/diskstats-*

Related branches

Changed in munin:
status: Unknown → New
Changed in munin (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in munin (Ubuntu):
status: New → Confirmed
Daniel Hahler (blueyed) on 2011-10-19
Changed in munin (Ubuntu):
status: Confirmed → Triaged
Daniel Hahler (blueyed) on 2011-10-22
description: updated
Changed in munin:
status: New → Fix Released
Daniel Hahler (blueyed) wrote :

@Chuck: can you please include the patch from http://munin-monitoring.org/changeset/4608 into Ubuntu?
It appears trivial to backport.

Changed in munin (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
milestone: none → ubuntu-12.04-beta-1
Martin Pitt (pitti) on 2012-03-02
Changed in munin (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Vibhav Pant (vibhavp) wrote :

Subscribing Sponsors

Daniel Holbach (dholbach) wrote :

Thanks for your work on this. I took the liberty of making the following modifications:
 - update the changelog to base on the newest version
 - use 'edit-patch' to get the patch into a format the patch system (quilt) understands
 - add some description to patch file.

Uploading it right now. As we're in Beta Freeze, it might sit in the review queue for a bit.

Changed in munin (Ubuntu):
assignee: Chuck Short (zulcss) → Vibhav Pant (vibhavp)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package munin - 1.4.6-3ubuntu2

---------------
munin (1.4.6-3ubuntu2) precise; urgency=low

  * debian/patches/upstream_changeset_4608.patch: use nfreeze() since it gets
    stored in a file (LP: #872217)
 -- Vibhav Pant <email address hidden> Fri, 23 Mar 2012 08:36:18 +0530

Changed in munin (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.