Munin-node have a empty /etc/munin/plugins folder

Bug #374537 reported by Thomas R. N. Jansson on 2009-05-10
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
munin (Debian)
Fix Released
Unknown
munin (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: munin

Installing a munin-node on a Ubuntu 9.04 Jaunty did not make the symbolic links from /usr/share/munin/plugins/ into /etc/munin/plugins/ and the node did as a result not make any graphs on the master. This has changed from Hardy and is a regression.

root@bohr:/etc/munin/plugins# lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04
root@bohr:/etc/munin/plugins# apt-cache policy munin-node
munin-node:
  Installed: 1.2.6-8ubuntu3
  Candidate: 1.2.6-8ubuntu3
  Version table:
 *** 1.2.6-8ubuntu3 0
        500 http://mirrors.dotsrc.org jaunty/main Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: munin-node 1.2.6-8ubuntu3
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
SourcePackage: munin
Uname: Linux 2.6.28-11-generic i686

Related branches

Thomas R. N. Jansson (tjansson) wrote :
Andreas Olsson (andol) wrote :

I just installed munin-node on a fresh 9.04 system, and I received a /etc/munin/plugins/ full of symlinks towards appropriate files under /usr/share/munin/plugins/.

Is this a fresh installation of Jaunty, or is it an upgrade from previous Ubuntu verion? You didn't receive any warnings during the installation of munin-node?

Changed in munin (Ubuntu):
status: New → Incomplete
Thomas R. N. Jansson (tjansson) wrote :
Download full text (6.2 KiB)

It was a fresh install of Jaunty. I just did a clean update from hardy. I just purged the installation and reinstalled it so you can see if there is anything usefull. Installing munin-node does not put anything into the plugins folder at my system:

root@bohr:/etc/munin# aptitude purge munin-node
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  munin-plugins-extra
The following packages will be REMOVED:
  munin-node{p}
0 packages upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
Need to get 0B of archives. After unpacking 1425kB will be freed.
The following packages have unmet dependencies:
  munin-plugins-extra: Depends: munin-node but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
munin-plugins-extra

Score is 119

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  libio-multiplex-perl{u} libnet-cidr-perl{u} libnet-server-perl{u} libnet-snmp-perl{u} munin-node{p} munin-plugins-extra{a}
0 packages upgraded, 0 newly installed, 6 to remove and 1 not upgraded.
Need to get 0B of archives. After unpacking 2867kB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 139482 files and directories currently installed.)
Removing munin-plugins-extra ...
(Reading database ... 139438 files and directories currently installed.)
Removing munin-node ...
 * Stopping Munin-Node [ OK ]
Purging configuration files for munin-node ...
dpkg - warning: while removing munin-node, directory `/var/lib/munin/plugin-state' not empty so not removed.
dpkg - warning: while removing munin-node, directory `/var/lib/munin' not empty so not removed.
Processing triggers for man-db ...
(Reading database ... 139300 files and directories currently installed.)
Removing libnet-server-perl ...
Removing libio-multiplex-perl ...
Removing libnet-cidr-perl ...
Removing libnet-snmp-perl ...
Processing triggers for man-db ...
Reading package lists... Done
Building dependency tree
Reading state inf
root@bohr:/etc/munin#
ormation... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

root@bohr:/etc/munin# ls

root@bohr:/etc/munin# aptitude install munin-node
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
  libio-multiplex-perl{a} libnet-cidr-perl{a} libnet-server-perl{a} libnet-...

Read more...

Andreas Olsson (andol) wrote :

I'm wondering if this errors are related to the problem somehow...

dpkg - warning: while removing munin-node, directory `/var/lib/munin/plugin-state' not empty so not removed.
dpkg - warning: while removing munin-node, directory `/var/lib/munin' not empty so not removed.

Haven't been able to install and remove/purge munin-node in a way to reproduce that situation. Can you try and first make sure all munin packages are properly purge, and then manually remove /var/lib/munin? One way to make sure there are no trace of munin packages left is the run the following command, and receiving no respons.

andreas@pc13267v1:~$ dpkg --list | grep -i munin
andreas@pc13267v1:~$

Thomas R. N. Jansson (tjansson) wrote :

Hi Andreas

I have now tried to purge and and manually remove all directories belonging to the munin-node package. When I tried to install the munin-node package again the was no symbolic links in /etc/munin/plugins/ again.

I have attached a log file of all the steps I have taken, so you can verify for your self.

Kind regards
Thomas Jansson

Chuck Short (zulcss) wrote :

If you are going from hardy->jaunty then its not a supported configuration. If you want to upgrade your hardy machine to jaunty. Then you would have to go through all of the releases.

Regards
chuck

Changed in munin (Ubuntu):
status: Incomplete → Won't Fix
Thomas R. N. Jansson (tjansson) wrote :

As I wrote earlier: "It was a fresh install of Jaunty. I just did a clean update from hardy. I just purged the installation and reinstalled it so you can see if there is anything usefull."

I formated my root partion and installed jaunty from scratch, so the problem is quite valid.

Changed in munin (Ubuntu):
status: Won't Fix → Confirmed
ilf (ilf) wrote :

same with 1.2.6-13ubuntu1 on a fresh up-to-date karmic.

Tom Feiner (feiner-tom) wrote :

This looks exactly like debian bug: http://bugs.debian.org/539886
I have written a patch that solves the issue. Once it'll be reviewed and accepted, it'll fix the problem in debian, and ubuntu will get the fix from there.

The "Got junk from df" stuff is the trigger for the problem (you see those messages on installing munin-node).
Unmount the offending filesystems, purge+reinstall works as a workaround.

Changed in munin (Debian):
status: Unknown → New
Changed in munin (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package munin - 1.2.6-13ubuntu3

---------------
munin (1.2.6-13ubuntu3) karmic; urgency=low

  * debian/munin-node.postinst: Apply patch by Tom Feiner to not make the
    automatic plugin detection fail if one plugin has an error. (LP: #374537)

 -- Chuck Short <email address hidden> Fri, 16 Oct 2009 21:31:10 -0400

Changed in munin (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.