[SRU] munin-node not restarted after plugin installation

Bug #224428 reported by janl on 2008-04-29
6
Affects Status Importance Assigned to Milestone
munin (Ubuntu)
Medium
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Medium
Unassigned

Bug Description

When installing munin-node the node is not (re)started after installing plugins:

# apt-get install munin-node
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  libnet-irc-perl mysql-client
The following NEW packages will be installed:
  munin-node
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 616kB of archives.
After this operation, 1348kB of additional disk space will be used.
Get:1 ftp://no.archive.ubuntu.com hardy/main munin-node 1.2.5-2ubuntu3 [616kB]
Fetched 616kB in 1s (601kB/s)
Selecting previously deselected package munin-node.
(Reading database ... 205175 files and directories currently installed.)
Unpacking munin-node (from .../munin-node_1.2.5-2ubuntu3_all.deb) ...
Setting up munin-node (1.2.5-2ubuntu3) ...

Configuration file `/etc/munin/munin-node.conf'
 ==> File on system created by you or by a script.
 ==> File also in package provided by package maintainer.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : background this process to examine the situation
 The default action is to keep your current version.
*** munin-node.conf (Y/I/N/O/D/Z) [default=N] ? I
Installing new version of config file /etc/munin/munin-node.conf ...
Initializing plugins..ln: creating symbolic link `/etc/munin/plugins/ip_0.0.0.0/0': No such file or directory
done.
 * Starting Munin-Node [ OK ]

# telnet localhost 4949
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
# munin node at localhost.localdomain
list
[empty list here]
quit
Connection closed by foreign host.
root@lookfar:/var/run/munin# cd /etc/munin/plugins/
root@lookfar:/etc/munin/plugins# ls
cpu if_err_eth0 lpstat open_inodes
cpuspeed if_err_eth1 memory proc_pri
df if_eth0 netstat processes
df_inode if_eth1 ntp_europium_canonical_com smart_sda
entropy interrupts ntp_kernel_err swap
exim_mailqueue iostat ntp_kernel_pll_freq threads
exim_mailstats iostat_ios ntp_kernel_pll_off users
forks irqstats ntp_offset vmstat
http_loadtime load open_files
root@lookfar:/etc/munin/plugins# /etc/init.d/munin-node restart
 * Stopping Munin-Node [ OK ]
 * Starting Munin-Node [ OK ]
root@lookfar:/etc/munin/plugins# telnet localhost 4949
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
# munin node at localhost.localdomain
list
open_inodes http_loadtime irqstats if_eth0 df swap load ntp_offset cpu df_inode open_files ntp_kernel_err forks iostat memory exim_mailqueue vmstat lpstat ntp_europium_canonical_com if_err_eth0 entropy ntp_kernel_pll_freq processes users cpuspeed interrupts netstat iostat_ios smart_sda if_err_eth1 if_eth1 proc_pri threads ntp_kernel_pll_off exim_mailstats
quit

To fix choose one of:
- munin-node-configure runs before starting the node
- restart the node after running munin-node-configure

Thanks,
  Nicolai (also your upstream maintainer for this)

Related branches

Daniel Hahler (blueyed) on 2008-05-01
Changed in munin:
importance: Undecided → Medium
status: Confirmed → Triaged
Chuck Short (zulcss) wrote :

Statement of Impact:

Adding this functionality will make it easier for users to use munin when it is installed on the users system.

how this bug has been addressed:

I have attached the debdiff which fixes this issue.

How to reproduce this bug:

See above comment.

There should be no regressions with this patch.

Martin Pitt (pitti) wrote :

This attachment was the wrong patch (for nut), but nevermind, I debdiffed it from the queue. However, this uncovered that munin has non-LSBified init scripts. Can this please get fixed at least for intrepid?

Changed in munin:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Steve Langasek (vorlon) on 2008-05-14
Changed in munin:
milestone: none → ubuntu-8.04.1
Martin Pitt (pitti) wrote :

Anyone who can confirm that the updated package still works, and fixes this bug?

Adam Sommer (asommer) wrote :

I was able to:

 telnet localhost 4949
 list

And see the list of plugins after first installing. Also, after restarting using "/etc/init.d/munin-node restart", the telnet list worked as expected.

Steve Beattie (sbeattie) wrote :

I am unable to reproduce the initial reporters problem with a fresh install of the original version shipped with Hardy, munin-node 1.2.5-2ubuntu3. Perhaps we can get a better test case here?

I did verify the package in -proposed, munin-node 1.2.5-2ubuntu3.1, does show the list of available plugins after installation. I also fetched some information from various plugins (including a test one I wrote) and the -proposed package appears to function correctly.

Martin Pitt (pitti) wrote :

Thanks for testing. The primary purpose for this testing process is to avoid large regressions. I mark this as verified now.

Martin Pitt (pitti) wrote :

Copied to hardy-updates and intrepid.

Changed in munin:
status: Triaged → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers