revise dependencies of munin to accept either munin-node or munin-node-c

Bug #1951920 reported by Todd Taft
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
munin (Ubuntu)
Undecided
Unassigned

Bug Description

On a 20.04 system, attempting to install the packages munin and munin-node-c with aptitude fails, as munin recommends munin-node, but munin-node and munin-node-c conflict. Since both munin-node and munin-node-c provide the same function, the recommendation of the munin package should be adjusted to recommend either munin-node or munin-node-c.

Expected result:
aptitude install munin munin-node-c does show any conflicting dependencies.

Acutal result:
# aptitude install munin munin-node-c
...
The following packages have unmet dependencies:
 munin-node-c : Conflicts: munin-node but 2.0.56-1ubuntu1 is to be installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1) munin-node [Not Installed]

     Leave the following dependencies unresolved:
2) munin recommends munin-node

Accept this solution? [Y/n/q/?] q

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers