munin-async can't write to /var/lib/munin-async

Bug #1770569 reported by Stefano Rivera on 2018-05-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
munin (Debian)
New
Unknown
munin (Ubuntu)
Status tracked in Cosmic
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

[Bug]
https://bugs.debian.org/691309 is back, in the form of https://bugs.debian.org/885454

Holger did some clean-up in 2.0.33-2 to the maintainer scripts, and removed the bit that set ownership of directories to the (dynamically created) munin users.

[Impact]
munin-async is unusable. munin-node config files that are not expected to be world-readable may be.

[Regression Potential]
changing directory ownership of an existing directory, in maintainer scripts, isn't ideal. But I've restricted it to just upgrades from 2.0.37-1.
The risk should be pretty minimal

[Test Case]
# apt install munin-async
# ls -ld /var/lib/munin-async/

If it belongs to root, that's bad.

Stefano Rivera (stefanor) wrote :
description: updated

Hello Stefano, or anyone else affected,

Accepted munin into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/munin/2.0.37-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in munin (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in munin (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package munin - 2.0.37-1ubuntu1

---------------
munin (2.0.37-1ubuntu1) cosmic; urgency=medium

  * Revert more of f1f48dee so that directories are again setup correctly on
    initial installations of munin-node and munin-async. (LP: #1770569)
    - Run the setup again, if upgrading from 2.0.37-1.

 -- Stefano Rivera <email address hidden> Thu, 10 May 2018 23:49:23 -0700

Changed in munin (Ubuntu Cosmic):
status: New → Fix Released
Stefano Rivera (stefanor) wrote :

Tested upgrade and fresh install scenarios, LGTM.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Since the change is a pretty obvious packaging change I'll be accepting this verification, but please remember to be more verbose when validating packages - mention which versions you have tested and provide as much output as possible.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package munin - 2.0.37-1ubuntu0.1

---------------
munin (2.0.37-1ubuntu0.1) bionic; urgency=medium

  * Revert more of f1f48dee so that directories are again setup correctly on
    initial installations of munin-node and munin-async. (LP: #1770569)
    - Run the setup again, if upgrading from 2.0.37-1.

 -- Stefano Rivera <email address hidden> Thu, 10 May 2018 23:58:52 -0700

Changed in munin (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for munin has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.