Error in cron logrotate 'gzip: stdin: file size changed while zipping'

Bug #1381939 reported by Diego on 2014-10-16
76
This bug affects 16 people
Affects Status Importance Assigned to Milestone
munin (Ubuntu)
Medium
Unassigned

Bug Description

Hi

Sometimes, I get error messages from the logrotate cron daemon:
  /etc/cron.daily/logrotate:
  gzip: stdin: file size changed while zipping

This error can be solved adding delaycompress in the logrotate configuration file (/etc/logrotate.d/munin-node).

The same problem was corrected for server log files in version 2.0.13-1, but the patch was not applied to munin-node

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=705515

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: munin-node 2.0.19-3
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
Uname: Linux 3.13.0-37-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Oct 16 10:26:54 2014
InstallationDate: Installed on 2014-08-14 (62 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
PackageArchitecture: all
SourcePackage: munin
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.munin.plugin.conf.d.munin.node: [deleted]

Diego (diegorf) wrote :
Robie Basak (racb) on 2014-10-16
Changed in munin (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in munin (Ubuntu):
status: New → Confirmed
Sorin Sbarnea (ssbarnea) wrote :

I get the same error and I do not have munin installed and it seems that logrotate is missing to specify on which file it does encounter this.

The_Raven (originalraven) wrote :

Run this command to see what happens:
logrotate --force --debug /etc/logrotate.conf
Maybe you see what goes wrong.

Jon Ribbens (jribbens-r) wrote :

It would be nice if this bug were fixed some day. It's presumably affecting all Ubuntu users.

I've been running into the same issue. There's been no movement on the upstream Debian bug (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=702201) since 2014 so it should at least be addressed here.

Nish Aravamudan (nacc) wrote :

@Diego, has a new bug report been sent to Debian for munin-node?

@alexmalinovich: The samba bug is already fixed in Debian, and this bug report is for munin, afaict. Are you saying you are seeing the issue for samba as well?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.