Mumble install does not register mumble:// URL handler with the system/firefox

Bug #934239 reported by James Lewis on 2012-02-17
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mumble (Ubuntu)
Undecided
Unassigned
Precise
Medium
Brian Murray

Bug Description

[Original report]
Mumble can handle URL's in the form "mumble://... ", this protocol type is registered on Windows, and some sites use a web link to open mumble and connect to their servers. I have verified that Mumble on Ubuntu can accept these URL's but the browser does not know what binary to pass them to.

I have met at least one user who believed that Mumble did not work on Ubuntu becuase he was unable to click on the voice chat link on a website.

This is a trivial fix, but certainly seems worthwhile.

[Test Case]
Launch a mumble:// test URL from the shell:

 $ xdg-open mumble://your-testing-mumble-server.com

xdg-open will complain about not knowing how to handle the URL. After the patch, it will launch mumble and try to connect to the requested server.

[Regression Potential]
Affectation to Mumble desktop launcher and ability to launch mumble from menu.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mumble (Ubuntu):
status: New → Confirmed
pataquets (pataquets) wrote :

Add the following line to /usr/share/applications/mumble.desktop :

 MimeType=x-scheme-handler/mumble

Then execute on the shell:

 $ sudo update-desktop-database

After this, running "xdg-open mumble://your-server" from the command line started working.

More info at http://jarrpa.net/2011/10/28/creating-custom-url-handlers-in-ubuntu-11-04-11-10-gnome-3-0/

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mumble - 1.2.3-349-g315b5f5-2.2ubuntu1

---------------
mumble (1.2.3-349-g315b5f5-2.2ubuntu1) raring; urgency=low

  [ pataquets ]
  * Register mumble:// URL handler mimetype (LP: #934239)
 -- Luke Yelavich <email address hidden> Wed, 24 Apr 2013 12:45:45 +1000

Changed in mumble (Ubuntu):
status: Confirmed → Fix Released
pataquets (pataquets) on 2013-04-26
description: updated
description: updated
Changed in mumble (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
Changed in mumble (Ubuntu Precise):
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress

Hello James, or anyone else affected,

Accepted mumble into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mumble/1.2.3-2ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mumble (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
pataquets (pataquets) wrote :

Tested under Precise.
* Purged package
* Enabled -proposed
* Installed mumble 1.2.3-2ubuntu4.1

Works for me.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mumble - 1.2.3-2ubuntu4.1

---------------
mumble (1.2.3-2ubuntu4.1) precise; urgency=low

  * Register mumble:// URL handler mimetype (LP: #934239)
 -- pataquets <email address hidden> Wed, 15 May 2013 21:04:51 +0200

Changed in mumble (Ubuntu Precise):
status: Fix Committed → Fix Released
pataquets (pataquets) wrote :

Still happens under Trusty Gnome desktop.

$ cat /usr/share/applications/mumble.desktop
[Desktop Entry]
Name=Mumble
Name[fr]=Mumble
Name[tr]=Mumble
GenericName=Voice Chat
GenericName[fr]=Chat vocal
GenericName[tr]=Sesle Sohbet
Comment=A low-latency, high quality voice chat program for gaming
Comment[fr]=Un logiciel de chat vocal de haute qualité et de faible latence pour les jeux
Comment[tr]=Oyunlar için yüksek kaliteli ve düşük gecikmeli sesle sohbet programı
Exec=mumble
Icon=mumble
Terminal=false
Type=Application
StartupNotify=false
Categories=Network;Chat;Qt;
Version=1.0

File /usr/share/app-install/desktop/mumble:mumble.desktop has the fix applied.

Ben Klein (robobenklein) wrote :

There is indeed a proper fix for this issue that is declared on the Mumble Wiki on how to get mumble to open those kinds of links: http://wiki.mumble.info/wiki/Mumble_URL#URL_Handler_Installation

In short, it's simply two commands to create the association:

gconftool-2 -s -t string /desktop/gnome/url-handlers/mumble/command 'mumble "%s"'
gconftool-2 -s -t bool /desktop/gnome/url-handlers/mumble/enabled true

This shouldn't be very hard to implement at all.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers