Ubuntu

mumble in oneiric hangs when connecting, or using audio wizard...

Reported by Charlie Schluting ☃ on 2011-09-07
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
mumble (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to oneiric and mumble 1.2.3-2ubuntu2, it hangs when attempting to connect to a server.

When I start mumble, I get the following errors:
PulseAudio: Starting input alsa_input.usb-0d8c_C-Media_USB_Audio_Device-00-default.analog-mono
PulseAudio: Stream error: No such entity
PulseAudio: Starting output: alsa_output.usb-0d8c_C-Media_USB_Audio_Device-00-default.analog-stereo
PulseAudio: Stream error: No such entity

If I click to connect to a server, it just hangs with no further debug output.

I canceled that, and tried again.. this time entering the audio wizard first. After the first screen where you select the sound subsystem (I left PulseAudio as the default choice), I click next and mumble hangs again with no further output.

When it entered the audio wizard, mumble emitted thusly:
AudioInput: 59700 bits/s, 48000 hz, 480 sample CELT
AudioInput: 59700 bits/s, 48000 hz, 480 sample CELT

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mumble (Ubuntu):
status: New → Confirmed
James Tait (jamestait) wrote :

My experience is almost identical, except that when clicking the Connect button I do see additional output in the terminal:

OpenSSL Support: 1 (OpenSSL 1.0.0e 6 Sep 2011)
SSL: Adding recommended CA UTN-USERFirst-Client Authentication and Email

However, going into Mumble Configuration and selecting ALSA under Audio Input -> Interface -> System, and selecting my USB Audio device "[hw:CARD=Device,DEV=0] C-Media USB Audio Device, USB Audio Direct hardware device without any conversions" and the same under Audio Output, I am able to connect, but cannot hear any sound - the Mumble log says "Opening chosen ALSA Output failed: Device or resource busy."

James Tait (jamestait) wrote :

Further progress - I started Mumble, then killed PulseAudio (which doesn't seem to want to stay dead). With some trial and error I have been able to have at least a brief conversation. Some combinations of input and output ALSA device result in very choppy audio locally - including the text message notifications, so it's not network latency - but my current configuration, which seems to be working is:

Audio Input -> Interface -> System = ALSA, Device = [dsnoop:CARD=Device,DEV=0] C-Media USB Audio Device, USB Audio Direct sample snooping device
Audio Output -> Interface -> System = ALSA, Device = [front:CARD=Device,DEV=0] C-Media USB Audio Device, USB Audio Front speakers

Alex Chiang (achiang) wrote :

I am experiencing the same issue. I hopped onto the upstream irc channel and here are some snippets of the conversation:

<achiang> hello, mumble 1.2.3-2ubuntu2 is hanging for me on startup, i get stuck in the audio wizard. a quick strace shows that it's infinitely doing a sched_yield() call
<achiang> any further debugging i can do?
<pcgod> achiang: your audio device is probably in use
<pcgod> (which will cause it to hang when it tries to play the audio file in the audio wizard)

I used lsof to try and find any open files related to sound to kill them off. That didn't seem to work. After killing mumble and restarting, I tried to just skip the audio wizard completely and just connect to a server, which also hangs:

<achiang> and now mumble is hanging upon trying to connect to a server
<pcgod> achiang: which is the same problem... the default settings have an "on connect" sound and it enters the same infinite loop when it tries to play that

James Tait (jamestait) wrote :

I just filed Bug #878952 and marked it as a duplicate of this - I'm not sure if this is the best way to get apport information associated with this bug, but upon using apport-collect 844347, launchpad suggested I might not want to do that.

James Tait (jamestait) wrote :

Oddly, after getting it working with ALSA as described above, setting it back to PulseAudio again is also now working. I haven't tried any other applications that require access to the sound devices yet, though.

James Tait (jamestait) wrote :

Brief update. I just applied updates and gconf said it needed to restart my machine, so I did so and started Mumble as the first program after login, with PulseAudio still selected as the sound system for both input and output. Lo and behold, it works perfectly.

This leads me to thinking (as suggested in Alex Chiang's IRC snippet) that maybe it's something else I'm running that's causing this problem. My top candidates are Firefox Nightly, Flash Player and VIrtualBox OSE.

Dean Henrichsmeyer (dhenrich) wrote :

Based on what I've seen, I think it's a pulseaudio problem. I can sometimes boot and mumble will work perfectly. After a short amount of time, it refuses to recognize that I have a microphone and any other app trying to use the microphone (such as Skype or jitsi) is distorted - as if the input gain on the mic was too high - but it isn't. I also get random crashes all the time with Banshee. All of this brokenness all of a sudden with things sound related makes me think it's a pulseaudio issue. There are no errors to spot in the logs though.

This same hardware worked flawlessly under natty. FWIW, I use a USB Logitech Webcam Pro 9000.

Michael JasonSmith (mpj17) wrote :

I had the same problem. I would start Mumble, and it would lock (hang) when I tried to connect to the server. The terminal output was as follows
  AudioInput: 28527 bits/s, 48000 hz, 480 sample CELT
  PulseAudio: Starting input alsa_input.usb-Logitech_Logitech_USB_Headset-00-Headset.analog-mono
  PulseAudio: Starting output: alsa_output.usb-Logitech_Logitech_USB_Headset-00-Headset.analog-stereo
  PulseAudio: Stream error: No such entity

I then follwed the advice here
  <http://permalink.gmane.org/gmane.linux.debian.packages.voip.devel/15284>
I deleted the [pulseaudo] section from .config/Mumble/Mumble.conf and reran the Audio Wizard. Mumble would then connect to the server.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers