mumble stops responding when try to connect to server

Bug #567636 reported by IdleOne on 2010-04-21
This bug report is a duplicate of:  Bug #911783: Mumble hangs when trying to connect. Edit Remove
74
This bug affects 15 people
Affects Status Importance Assigned to Milestone
mumble (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by nicoduck

Bug Description

Binary package hint: mumble

Steps to reproduce:
start mumble either from menu or terminal
click on connect and mumble stops responding and just sits there.

not much more info I can give.

output from starting in terminal:
 mumble
CELT bitstream 8000000b from libcelt0.so.0.0.0
G15LCDEngineUnix: Unable to connect to G15Daemon.
Locale is en_US
*** WARNING *** The program 'mumble' uses the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=mumble>
OpenSSL Support: 1
SSL: Added CA certificates from '/etc/ssl/certs/ca-certificates.crt'
Overlay: Removing old socket on "/home/idleone/.MumbleOverlayPipe"
Overlay: Listening on "/home/idleone/.MumbleOverlayPipe"
GlobalShortcutX: Unable to open any keyboard input devices under /dev/input, falling back to XInput
GlobalShortcutX: Using XInput 2.0
GlobalShortcutX: XInput 4:Virtual core XTEST pointer
GlobalShortcutX: XInput 5:Virtual core XTEST keyboard
GlobalShortcutX: XInput 6:Power Button
GlobalShortcutX: XInput 7:Power Button
GlobalShortcutX: XInput 8:HID 413c:3010
GlobalShortcutX: XInput 9:AT Translated Set 2 keyboard
GlobalShortcutX: XInput 10:Macintosh mouse button emulation
SocketRPC: Removing old socket on "/home/idleone/.MumbleSocket"
AudioInput: 40000 bits/s, 48000 hz, 480 sample CELT
PulseAudio: Starting input alsa_input.pci-0000_00_1f.5.analog-stereo
AudioInput: Initialized mixer for 1 channel 44100 hz mic and 0 channel 48000 hz echo
warning: The VAD has been replaced by a hack pending a complete rewrite

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: mumble 1.2.2-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic-pae 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic-pae i686
Architecture: i386
Date: Tue Apr 20 21:47:33 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: mumble

IdleOne (idleone) wrote :
Coranna Howard (komiga) wrote :

I have the same issue. It will not happen if you go through the audio wizard before connecting (without even changing anything).
Interestingly, you can also get around the issue by running mumble from gdb.

Thorvald Natvig (slicer) wrote :

Can you hear yourself in the audio wizard?

Is the server you are trying to connect to reachable and using a matching version?

Changed in mumble (Ubuntu):
status: New → Incomplete
Coranna Howard (komiga) wrote :

Yes, I can hear myself in the audio wizard, and once I connect to my server (hosted locally), everything works as expected (except for application attenuation, but I believe that is a somewhat unrelated matter).
I'm using the packages from Canonical (1.2.2-1ubuntu1 for both server and client).

Thorvald Natvig (slicer) wrote :

I'm not sure I follow you, the original bug said that mumble stops responding connecting to a server, but since you say everything works when connected to a server, I don't know if this is related to the original bug?

Coranna Howard (komiga) wrote :

>I'm not sure I follow you, the original bug said that mumble stops responding connecting to a server, but since you say everything works when connected to a server, I don't know if this is related to the original bug?

It is. When I said "and once I connect", I was referring to when using the workarounds in my first comment.
If I do not run the audio wizard and do not run Mumble in gdb, it will lock up when I try to login to a server.

After using the audio wizard it will work fine, and then break again once you restart Mumble (probably something to do with the configuration).

Joshua R. Poulson (jrp) wrote :

The similar error (freeze) I see appears to be caused by removing one USB headset and trying another before starting mumble: mumble spins looking for the old device. Audio setup wizard also freezes (see 535404).

PulseAudio: Starting input alsa_input.usb-Logitech-Logitech_USB_Headset-00-Headset.analog-mono
PulseAudio: Stream error: No such entity

Could the OP also be experiencing a freeze related to remembered hardware that has now changed?

Coranna Howard (komiga) wrote :

>The similar error (freeze) I see appears to be caused by removing one USB headset and trying another before starting mumble: mumble spins looking for the old device.

In my case, this is not true. I'm using the standard stereo audio ports on a ThinkPad A31 (nothing should be changing, and nothing seems to be changing).

Paul Whittaker (launchpad-pdw) wrote :

I'm also getting this on a fresh Lucid install: Run mumble, select server, click "connect", mumble stops responding and consumes as much CPU as is available. If instead I run mumble, go through the audio wizard (I don't need to change any settings, just keep hitting Next) and then select the same server and connect, all works as it should. I had no problems running Mumble 1.2 on a fresh jaunty install (with mumble from the mumble PPA) on the precise same hardware a month or two ago. No hardware is being connected or disconnected at any point. Microphone input is on one card, speaker output is on another; previously this used the default jaunty sound system (alsa?), now it's going through pulseaudio.

I want to help get this fixed, so if anyone can tell me what information would be useful (alsa or pulseaudio settings dump, attaching to mumble with strace, etc.) and the command options to use, I'd be more than happy to post back information. I may also be able to reproduce the earlier jaunty install for comparison if needed.

nicoduck (nico-vthadden) wrote :

Same problem here. Mumble worked great from ppa and stopped working after upgrade to 10.04.
I use 64 bit, a friend with 32bit is not affected, maybe a 64-bit only problem?

running through the audio vizard didn't work for me, mumble started hanging after clicking on next after the device selection (maybe it couldn't connect properly to pulse? )

Martin Bergman (martin-devsed) wrote :

Hi,

I'm also affected by this bug on 2 laptops but not on my desktop.. I don't think it's hardware related though.

First off, what seems to be mumbles issue is that mumble is configured to use an input or output source that isn't available. When it try to play the connection sound (or the sound in the audio wizard) it can't connect to the sink and it hangs. To get around this I try using alsa or oss instead (it will still go via pulse though), it works, but the delay on the input (i think) is horrible, so it's not usable.

One thing that usually works though is to select the specific devices instead of "default" device. You can do this by enabling advanced options, and setting the correct device under "Audio Input" and "Audio Output"

Hope this helps. If not, start mumble via a terminal and paste the output when it crashes.

Pol_ (paulemile-purnelle) wrote :

Hello,

I'm affected by this bug too. I'm using mumble 1.2.2-4 inside an Ubuntu 10.10 running inside a Virtual Box 3.2.6_OSE r63112.

Workaround for me is to 'mess around' in the devices menu and randomly change from default to whatever I want. Then once I can hear myself (own mouse click) though mumble I can fall-back to the default device and it works fine.

Launchpad Janitor (janitor) wrote :

[Expired for mumble (Ubuntu) because there has been no activity for 60 days.]

Changed in mumble (Ubuntu):
status: Incomplete → Expired
Barry Warsaw (barry) wrote :

I'm reopening this, because I'm getting exactly this behavior (freeze on any connection attempt) in Oneiric.

Changed in mumble (Ubuntu):
status: Expired → New
Alex Chiang (achiang) wrote :

This is completely related to LP: #844347 ; see comment #4 for some more information.

We should move conversation to either one bug or the other, but not both. I don't really care which one stays open, perhaps the newer one should be kept and this older one can be marked as a dup?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mumble (Ubuntu):
status: New → Confirmed
Acuao (acuao) wrote :

Hi,

i still get this problem with v1.2.3,
like said on the other post (https://bugs.launchpad.net/ubuntu/+source/mumble/+bug/844347)
to resolve this problem, use ALSA drivers

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers