Multistrap is broken in 14.04

Bug #1313787 reported by Alexander Charykov on 2014-04-28
154
This bug affects 33 people
Affects Status Importance Assigned to Milestone
multistrap (Ubuntu)
Undecided
Unassigned

Bug Description

root@ubuntu:~/tmp# multistrap
Global symbol "$forceyes" requires explicit package name at /usr/sbin/multistrap line 989.
Execution of /usr/sbin/multistrap aborted due to compilation errors.
root@ubuntu:~/tmp# apt-cache showpkg multistrap
Package: multistrap
Versions:
2.2.0ubuntu1 (/var/lib/apt/lists/mirror.yandex.ru_ubuntu_dists_trusty_universe_binary-amd64_Packages) (/var/lib/dpkg/status)

Related branches

description: updated
Alexander Charykov (acharykov) wrote :

I think it is because of change in debian multistrap package http://www.emdebian.org/trac/changeset/7521.

In ubuntu $forceyes is still exists, but it is no defined anywhere.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in multistrap (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multistrap - 2.2.0ubuntu2

---------------
multistrap (2.2.0ubuntu2) utopic; urgency=medium

  [ Daniel Lipsitt ]
  * Remove use of non-existent $forceyes variable (LP: #1313787).
 -- Steve Langasek <email address hidden> Mon, 12 May 2014 22:33:34 -0700

Changed in multistrap (Ubuntu):
status: Confirmed → Fix Released
David Lechner (dlech) wrote :

Just a freindely reminder that this still needs to be reviewed to be included in trusty.

Phoenix (tos-phoenix) wrote :

I'm also affected by this bug. Would be nice to see the fix in the repos really soon!

Martin Pärtel (mpartel) wrote :

Workaround until fix is released: edit /usr/sbin/multistrap and remove $forceyes on line 989.

Jarmo Isotalo (jamo-q) wrote :

I can confirm, the workaround works .

l34k@hush.ai (l34k) wrote :

Removing $forceyes worked for me.

Paul Bußmann (paul-medwyn) wrote :

Removing $forceyes worked for me, too.
I am using newest Linux Mint (Linux Mint 17 KDE) and got affected by this bug. Please fix so it gets upstream, too.

Fix worked for me too.

Hello? 8 months further and the simple fix has not yet been deployed? Risks of breaking something: it's totally borked now, so no risk. Please deploy.

Jaromil (jaromil) wrote :

Ping. 10 months later...

moriarty (alexander-moriarty) wrote :

Still pending review in trusty...

Thanks for the work around

Mike Purvis (mikepurvis) wrote :

Almost two full years!

In the meantime, there are PPAs for this: https://launchpad.net/~keyz182/+archive/ubuntu/multistrap-forceyes-fix

Alex Murray (alexmurray) wrote :

Just hit this as well - can't believe such a simple fix needs more review - 3 full years now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers