multipathd segfault

Bug #488285 reported by montjoie on 2009-11-25
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
multipath-tools (Debian)
Fix Released
Unknown
multipath-tools (Ubuntu)
Low
Serge Hallyn
Lucid
Low
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: multipath-tools

SRU justification:
=====
Impact: stopping multipathd (i.e. to restart) can cause a segfault
How bug addressed: an upstream patch is cherrypicked which avoids dereferencing a backlog of syslog messages when it is empty.
Patch: See the debdiff in comment #8
Instructions: Start multipathd, then stop it, watch segfault.
Regression potential: If there were an error in the patch, then it should at worst fail to log backlogged syslog messages at shutdown.
=====

Sometimes multipathd segfault when i do /etc/init.d/multipath-tools restart

kernel: [ 1507.119302] multipathd[1595]: segfault at a ip 00007f1e3f106eda sp 00007fff66618440 error 4 in libc-2.10.1.so[7f1e3f091000+166000]
kernel: [ 118.628780] multipathd[1585]: segfault at a ip 00007fa347beeeda sp 00007fff2a53e0f0 error 4 in libc-2.10.1.so[7fa347b79000+166000]
kernel: [ 150.051148] multipathd[2750]: segfault at a ip 00007f61bf42feda sp 00007fff0e5027d0 error 4 in libc-2.10.1.so[7f61bf3ba000+166000]
kernel: [ 631.839777] multipathd[6280]: segfault at a ip 00007f5ca8c42eda sp 00007fffd0f7b7f0 error 4 in libc-2.10.1.so[7f5ca8bcd000+166000]
kernel: [ 798.741986] multipathd[6607]: segfault at a ip 00007f4af50fdeda sp 00007fff77cbca60 error 4 in libc-2.10.1.so[7f4af5088000+166000]
kernel: [ 911.696705] multipathd[7465]: segfault at a ip 00007fe8ca569eda sp 00007ffff715f180 error 4 in libc-2.10.1.so[7fe8ca4f4000+166000]
kernel: [ 1067.310120] multipathd[8346]: segfault at a ip 00007f9ffbba8eda sp 00007fff607f1780 error 4 in libc-2.10.1.so[7f9ffbb33000+166000]
kernel: [64755.500780] multipathd[8832]: segfault at a ip 00007fbb056beeda sp 00007fff5f3a6260 error 4 in libc-2.10.1.so[7fbb05649000+166000]
kernel: [12634.257334] multipathd[1598]: segfault at a ip 00007f45643eaeda sp 00007fffde6d9c40 error 4 in libc-2.10.1.so[7f4564375000+166000]
kernel: [12764.271327] multipathd[20491]: segfault at 10 ip 00007fed4fd756b4 sp 00007fed50187f80 error 4 in libpthread-2.10.1.so[7fed4fd6b000+17000]
kernel: [13211.173415] multipathd[21145]: segfault at a ip 00007f80c27f9eda sp 00007fffca3090a0 error 4 in libc-2.10.1.so[7f80c2784000+166000]
kernel: [13320.949129] multipathd[24947]: segfault at a ip 00007fe713bf0eda sp 00007fffb3d15910 error 4 in libc-2.10.1.so[7fe713b7b000+166000]
kernel: [407603.710900] multipathd[3048]: segfault at a ip 00007fa9c053deda sp 00007fffe3ab6330 error 4 in libc-2.10.1.so[7fa9c04c8000+166000]
kernel: [53589.949830] multipathd[5156]: segfault at a ip 00007fe124907eda sp 00007fff7922dd00 error 4 in libc-2.10.1.so[7fe124892000+166000]
kernel: [53620.587085] multipathd[3065]: segfault at a ip 00007f8768e36eda sp 00007ffff5bcdca0 error 4 in libc-2.10.1.so[7f8768dc1000+166000]
kernel: [53656.093356] multipathd[3333]: segfault at a ip 00007f90ac095eda sp 00007fffe7b497f0 error 4 in libc-2.10.1.so[7f90ac020000+166000]
kernel: [62144.892185] multipathd[3654]: segfault at a ip 00007f63a26c5eda sp 00007fff11745940 error 4 in libc-2.10.1.so[7f63a2650000+166000]
kernel: [80138.461495] multipathd[5405]: segfault at a ip 00007f790164ceda sp 00007fff56a3d840 error 4 in libc-2.10.1.so[7f79015d7000+166000]

1)
lsb_release -r
Release: 9.10

2)
multipath-tools:
  Installé : 0.4.8-14ubuntu2
  Candidat : 0.4.8-14ubuntu2
 Table de version :
 *** 0.4.8-14ubuntu2 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

3) a restart without segfault

4) multipathd segfault

Related branches

Chuck Short (zulcss) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in multipath-tools (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Chuck Short (zulcss) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in multipath-tools (Ubuntu):
status: Incomplete → Invalid
ariel (garcia) wrote :

This is
   http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=519252

Fixed in Debian as of 0.4.8-15
Please update the Lucid package :-)
Txs

Changed in multipath-tools (Ubuntu):
status: Invalid → New
Adam Guthrie (therigu) wrote :

I can confirm the fix in debian works. The minimal patch is attached.

Changed in multipath-tools (Ubuntu):
status: New → Confirmed
Serge Hallyn (serge-hallyn) wrote :

Proposed a bzr tree for merging. The lucid tree is identical to the maverick one,
so if we can get it into maverick i assume we can get a trivial SRU.

Serge Hallyn (serge-hallyn) wrote :

Adam: thanks much for the patch!

tags: added: patch
Adam Guthrie (therigu) wrote :

marking as patch-accepted-upstream as cherry-picked from debian which was itself cherry-picked from upstream.

tags: added: patch-accepted-upstream
dann frazier (dannf) wrote :

Here's a debdiff against natty.

Changed in multipath-tools (Ubuntu):
assignee: nobody → Serge Hallyn (serge-hallyn)
status: Confirmed → In Progress
Serge Hallyn (serge-hallyn) wrote :

Reminder: after being applied to natty, this fix will need to be SRU'd to lucid and maverick.

Changed in multipath-tools (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multipath-tools - 0.4.8-14ubuntu8

---------------
multipath-tools (0.4.8-14ubuntu8) natty; urgency=low

  * Fix segv on shutdown when log buffer is empty, using patch cherry-picked
    from upstream. (LP: #488285)
 -- Serge Hallyn <email address hidden> Tue, 01 Feb 2011 15:38:36 -0600

Changed in multipath-tools (Ubuntu):
status: Fix Committed → Fix Released
description: updated

Accepted multipath-tools into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in multipath-tools (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Clint Byrum (clint-fewbar) wrote :

The upload to lucid-proposed was deleted, as the version was higher than that of the dev release, oneiric. If you happened to download that version while it was briefly available, you should manually downgrade back to 0.4.8-14ubuntu4, otherwise you run the risk of not updating this package on an upgrade to maverick.

Changed in multipath-tools (Ubuntu Lucid):
importance: Undecided → Low
status: Fix Committed → Triaged
tags: removed: verification-needed
Changed in multipath-tools (Debian):
status: Unknown → Fix Released
Rolf Leggewie (r0lf) wrote :

Maverick has long since stopped to receive any updates. Marking the Maverick task for this ticket as "Won't Fix".

Changed in multipath-tools (Ubuntu Maverick):
status: New → Won't Fix
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in multipath-tools (Ubuntu Lucid):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.