multipath fails to gather device information

Bug #307032 reported by Bryan McLellan on 2008-12-11
10
Affects Status Importance Assigned to Milestone
multipath-tools (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Mathias Gug

Bug Description

The sysfs layout has changed and multipath does not look in the correct location for block device information. Upstream is patched [1].

# multipath -ll -v3
[snip]
===== paths list =====
uuid hcil dev dev_t pri dm_st chk_st vend/prod/rev
     #:#:#:# sdb 8:16 -1 [undef][undef] ,
     #:#:#:# sdc 8:32 -1 [undef][undef] ,
     #:#:#:# sdd 8:48 -1 [undef][undef] ,
     #:#:#:# sde 8:64 -1 [undef][undef] ,
[snip]

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch
Distributor ID: Ubuntu
Description: Ubuntu 8.10
Release: 8.10
Codename: intrepid

Linux file01 2.6.27-10-generic #1 SMP Fri Nov 21 12:00:22 UTC 2008 i686 GNU/Linux

multipath-tools=0.4.8-10ubuntu3~ppa1 (See LP:306723)

[1] http://git.kernel.org/gitweb.cgi?p=linux/storage/multipath-tools/.git;a=commitdiff;h=88f88d

==========
Intrepid SRU

Impact of the bug:
The sysfs layout has changed and multipath does not look in the correct location for block device information.

How the bug has been addressed:
Fix the the lookup code taking the upstream patch.

The proposed debdiff is in bug 306723.

TEST CASE: see bug 306723.

Regression:

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multipath-tools - 0.4.8-10ubuntu3

---------------
multipath-tools (0.4.8-10ubuntu3) jaunty; urgency=low

  * fix_udev_scsi_id_arguments.diff:
    Update the arguments for scsi_id. (LP: #306723)
  * fix_sysfs_layout.diff:
    Patch from upstream to use the new sysfs layout. (LP: #307032)

 -- Timo Aaltonen <email address hidden> Thu, 18 Dec 2008 15:32:20 +0200

Changed in multipath-tools:
status: New → Fix Released

For people using Intrepid, you can work around that bug by setting getuid_callout somewhere in /etc/multipath.conf. In my case, the following worked with an EMC SAN:

defaults {
        default_getuid_callout "/lib/udev/scsi_id -g -u -ppre-spc3-83 -d /dev/%n"
}

Is there any plan to do a SRU for Intrepid? I think it would worth it, as otherwise multipath-tools is DOA. I can help with testing.

Oups, comment in wrong bug, the aboove was intended for #306723. Sorry!

Mathias Gug (mathiaz) on 2009-01-22
description: updated
Changed in multipath-tools:
assignee: nobody → mathiaz
status: New → In Progress
Martin Pitt (pitti) wrote :

Accepted multipath-tools into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in multipath-tools:
status: In Progress → Fix Committed
Bryan McLellan (btm) wrote :

Tested multipath-tools=0.4.8-10ubuntu1.1 on intrepid from proposed and seems to work just fine, but I can't test heavily due to Bug #289470

Martin Pitt (pitti) on 2009-03-31
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multipath-tools - 0.4.8-10ubuntu1.1

---------------
multipath-tools (0.4.8-10ubuntu1.1) intrepid-proposed; urgency=low

  * fix_udev_scsi_id_arguments.diff:
    Update the arguments for scsi_id. (LP: #306723)
  * fix_sysfs_layout.diff:
    Patch from upstream to use the new sysfs layout. (LP: #307032)

 -- Mathias Gug <email address hidden> Thu, 22 Jan 2009 11:35:09 -0500

Changed in multipath-tools (Ubuntu Intrepid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers