Merge recent multipath-tools for zesty

Bug #1645274 reported by Christian Ehrhardt  on 2016-11-28
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
multipath-tools (Ubuntu)
High
Christian Ehrhardt 

Bug Description

Hi,
I'm working on a merge of recent multipath-tools.
This bug is here to track that and to be a place where people can test and discuss about it.

FYI
- final upload depends on bug 1644757
- bug 1621340 will be fixed by this merge (fix in upstream >=6.1, we merge 6.3)
- bug 1644253 will be fixed by fix being part of this merge

Changed in multipath-tools (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → ChristianEhrhardt (paelzer)

Hi,
I subscribed several of you who were contributors to the last uploads of multipath-tools.
I've added a dep8 test realizing that there was none, but that can't cover as much as I'd like.

I have made a ppa of the current state of the merge available for extra testing at:
https://launchpad.net/~paelzer/+archive/ubuntu/bug-1645274-multipath-merge

@Mathieu / Mauricio
As much as time permits I'd ask you to test whatever you formerly used to test your uploads on that ppa.
Also you certainly had special cases triggering your former uploads it would be great if you could at least throw those against it that would be possible without too much effort.

@Ryan - did you come up with a tweak to utilize the curtin vmtests witha a ppa or a custom image - I think this would be a great opportunity for some extra cross tests before an actual upload.
Even if you have nothing already please contact me to discuss if we could create something.

On Mon, Nov 28, 2016 at 5:07 AM, ChristianEhrhardt <
<email address hidden>> wrote:

> Hi,
> I subscribed several of you who were contributors to the last uploads of
> multipath-tools.
> I've added a dep8 test realizing that there was none, but that can't cover
> as much as I'd like.
>
> I have made a ppa of the current state of the merge available for extra
> testing at:
> https://launchpad.net/~paelzer/+archive/ubuntu/bug-1645274-multipath-merge
>
> @Mathieu / Mauricio
> As much as time permits I'd ask you to test whatever you formerly used to
> test your uploads on that ppa.
> Also you certainly had special cases triggering your former uploads it
> would be great if you could at least throw those against it that would be
> possible without too much effort.
>
> @Ryan - did you come up with a tweak to utilize the curtin vmtests witha a
> ppa or a custom image - I think this would be a great opportunity for some
> extra cross tests before an actual upload.
> Even if you have nothing already please contact me to discuss if we could
> create something.
>

We can certainly point to a PPA during a multipath-enabled vmtest run;
which I think satisfies this request; Or at a min, we can enable proposed
and run them.
I'll add a task for this to curtin.

>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1645274
>
> Title:
> Merge recent multipath-tools for zesty
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/multipath-tools/+bug/1645274/+
> subscriptions
>

FYI - MIR is done (or actually was already done with a little hickup of being universe in Xenial)

FYI -I'm still waiting for a review on my the merge.
But to make progress I kind of set a timer for myself that if no review happens I'm kind of forced to do it as-is.

Christian,

I couldn't handle it so far due to year end items plus vacation, on which I'm catching up from.

Can you explain a bit of how this review works? Mainly,
- is there any interface for that, or is plainly checking which files changed and how,
- then see if everything looks correct/compatible w/ previous expected behavior?

Thanks!

On Wed, Jan 11, 2017 at 3:18 PM, Mauricio Faria de Oliveira <
<email address hidden>> wrote:

> Can you explain a bit of how this review works? Mainly,
> - is there any interface for that, or is plainly checking which files
> changed and how,
> - then see if everything looks correct/compatible w/ previous expected
> behavior?
>

Hi,
sorry I missed your question here.
TL;DR we have established an improved workflow to merge complex packages.
That includes peer review - see this for more Detail
https://wiki.ubuntu.com/UbuntuDevelopment/Merging/GitWorkflow

BTW the multipath-tools upload is ready now, yet I have to find a sponsor
today or fix the upload permission.

Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package multipath-tools - 0.6.4-3ubuntu1

---------------
multipath-tools (0.6.4-3ubuntu1) zesty; urgency=medium

  * Merge from Debian. (LP: #1621340, LP: #1645274) Remaining changes:
    - d/control:
      - Bump udev dependencies
      - multipath-udeb: add sg3-udeb Depends
    - d/rules: Move udev rules to priority 95, because rules that load modules
      should be >90.
    - d/multipath-tools.preinst: modprobe dm-multipath; This will make sure
      that multipathd will be able to start.
    - Split kpartx initramfs bits into kpartx-boot for dmraid (LP: #941874)
      - d/initramfs/kpartx.hook
      - d/kpartx-boot.postinst
      - d/kpartx-boot.postrm
      - d/control: Add kpartx-boot package for dmraid
      - d/rules: Install kpartx initramfs hook
      - d/kpartx.install: install all arch /lib* kpartx udev rules
    - patches (some refreshed to new version) to multipath source
      - d/p/1000--set-umask-in-multipathd.patch: Set umask in multipathd.
      - d/p/path_selector.patch: switch the default path selector
        back to round-robin while service-time isn't available to the installer
        multipath-modules.
      - d/p/kpartx_more_loopback_fixes.patch: fix loopback mounted
        files some more: since we stat() the loopback device node, we can't rely
        on S_ISREG() tests to handle this case, and should look at the device
        itself instead. (LP: #1543430)
      - d/p/enable-find-multipaths.patch: re-enable find_multipaths
        by default -- see the removed 'add_find-multipaths.patch' (LP: #1463046)
   - multipath initramfs fixes for booting from multipathed devices
      - d/initramfs/hooks: also copy wwids file on the installed system to
        ensure all paths come up on boot. (LP: #1479929)
      - d/initramfs/hooks: install multipathd and required directories.
      - d/initramfs/hooks: copy dm-mpath-lvm & multipath udev rules to initramfs
      - d/initramfs/hooks: do not copy kpartx rules to initramfs
      - d/initramfs/local-bottom: remember to stop multipathd.
      - d/initramfs/local-premount: wait for udev to settle before the call to
        resolve_device() in local_mount_root(), so the by-uuid/ symlinks have a
        chance to be updated by the multipath udev rules (LP: #1503286).
      - d/initramfs/local-premount: Run multipath with -B so not to assign names
        nor change /etc/multipath/bindings during initramfs (LP: #1561103)
      - d/rules: install d/initramfs/local-bottom
      - d/rules: install d/initramfs/local-premount
   - Remove partition device nodes of individual paths (for LVM on multipath)
     (LP: #1540401)
   - Disable -fexceptions on multipath-udeb (LP: #1489379): the flag causes
     libchecktur.so to link with libgcc_s.so.1 (even with -static-libgcc),
     which is not available in the installer environment.
     - d/p/disable-fexceptions-udeb.patch: conditionally disable -fexceptions
       with CFLAGS_DISABLE_FEXCEPTIONS.
     - d/rules: set CFLAGS_DISABLE_FEXCEPTIONS to build multipath-udeb.
   - d/tests/kpartx-file-loopback: add an autopkgtest to catch future cases
     where uploads might break kpartx's loopback file handling.
   -...

Read more...

Changed in multipath-tools (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers