System will not start with multipathd enabled

Bug #1583563 reported by mike99mac on 2016-05-19
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
multipath-tools (Ubuntu)
High
Martin Pitt
Xenial
High
Dimitri John Ledkov

Bug Description

[Impact]

 * Both systemd units and init scripts are shipped for multipath-tools.

 * However units did not correctly take priority, as initscripts and units names did not match.

 * Further more multipath-tools was miscompiled without systemd support for Type=Notify unit

[Test Case]

 * Using service command, init script, or systemctl commands starting "multipath-tools" should operate on systemd "multipathd.service" unit.

 * Systems must boot with multipath-tools installed correctly, and multipathd.service started.

If I do these three commands on a fresh Ubuntu clone which has one pair of FCP devices pointing to a LUN:

# apt-get -y install multipath-tools
# systemctl enable multipathd
# reboot

The system will not come back up. It seems to spin with the messages: “A start job is running for Device-M...vice Controller (<x> / 1min 30s)” In 90 seconds it times out and starts counting again.

Changed in ubuntu-z-systems:
status: New → Triaged
tags: added: s390x
Dimitri John Ledkov (xnox) wrote :

That's expected. one must configure multipath devices too, if enabling this post-install.

Or use installer to install system onto multipath devices from the start, with correct multipath config, fstab and zipl.

Dimitri John Ledkov (xnox) wrote :

The installer has full support for multipath devices, so why not just use that? Or why have you enabled multipathd service, without configuring it in full first?

dann frazier (dannf) on 2016-05-19
Changed in ubuntu-z-systems:
assignee: nobody → Canonical Server Team (canonical-server)
Dimitri John Ledkov (xnox) wrote :

Playing with this more, I think I see what you mean now. Indeed there appear to be bugs.

Martin,

Could you please take a look at all the systemd units and init scripts, and how they intervene with each other?

* /etc/init.d/multipath-tools-boot
  - this one works fine

* /etc/init.d/multipath-tools
  - this one is enabled by default, and starts up without loading dm-multipath first

* /lib/systemd/system/multipathd.service
  - a trap, that is easy to shoot oneself in the foot.
  - has alias Alias=multipath-tools.service but doesn't appear to properly be enabled in maintainer scripts, and doesn't seem to be masking multipath-tools-boot initscript at all.
  - does not appear to be operational properly.
  - references non-existant units
  - deamon fails to create socket... yet unit declares that socket activation is to be used.

Could you please dig further into these units and check what needs fixing?

Changed in multipath-tools (Ubuntu):
status: New → Confirmed
no longer affects: ubuntu-z-systems
Changed in multipath-tools (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
Changed in multipath-tools (Ubuntu Xenial):
importance: Undecided → High
Martin Pitt (pitti) on 2016-05-31
Changed in multipath-tools (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in multipath-tools (Ubuntu Xenial):
status: New → Confirmed
Changed in multipath-tools (Ubuntu):
status: In Progress → Confirmed
Dimitri John Ledkov (xnox) wrote :

@xtrusia

tested, looks good.
i remerged with one more hunk LIB=lib -> LIB=/lib and a betterish changelog. Sorry, but I can't sponsor that source package with that changelog.

Uploading first to yakkety, will retest, and then SRU into xenial. ETA for 16.04.1.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multipath-tools - 0.5.0+git1.656f8865-5ubuntu3

---------------
multipath-tools (0.5.0+git1.656f8865-5ubuntu3) yakkety; urgency=medium

  * Cherrypick from debian:
   - Call clean target before rebuilding with systemd support
   - Call systemd in debian/rules. Also adapt init service
     aliasing.
   - Should resolve LP: #1578638, LP: #1589526, LP: #1583563.

 -- Dimitri John Ledkov <email address hidden> Thu, 16 Jun 2016 11:53:33 +0300

Changed in multipath-tools (Ubuntu):
status: Confirmed → Fix Released
description: updated
Louis Bouchard (louis) on 2016-06-21
Changed in multipath-tools (Ubuntu Xenial):
assignee: nobody → Louis Bouchard (louis-bouchard)
Changed in multipath-tools (Ubuntu Xenial):
assignee: Louis Bouchard (louis-bouchard) → Dimitri John Ledkov (xnox)

Hello mike99mac, or anyone else affected,

Accepted multipath-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/multipath-tools/0.5.0+git1.656f8865-5ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in multipath-tools (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multipath-tools - 0.5.0+git1.656f8865-5ubuntu2.1

---------------
multipath-tools (0.5.0+git1.656f8865-5ubuntu2.1) xenial; urgency=medium

  * Cherrypick from debian:
   - Call clean target before rebuilding with systemd support
   - Call systemd in debian/rules. Also adapt init service
     aliasing.
   - Resolves LP: #1578638, LP: #1589526, LP: #1583563. Separate bugs, all
    due to same root cause.

 -- Dimitri John Ledkov <email address hidden> Thu, 16 Jun 2016 11:53:33 +0300

Changed in multipath-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for multipath-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.