multipath tools wrong dependecy

Bug #1578638 reported by sles on 2016-05-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
multipath-tools (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]

 * Both systemd units and init scripts are shipped for multipath-tools.

 * However units did not correctly take priority, as initscripts and units names did not match.

 * Further more multipath-tools was miscompiled without systemd support for Type=Notify unit

[Test Case]

 * Using service command, init script, or systemctl commands starting "multipath-tools" should operate on systemd "multipathd.service" unit.

 * Systems must boot with multipath-tools installed correctly, and multipathd.service started.

16.04:

/etc/init.d/multipath-tools

# Required-Start: udev $local_fs $remote_fs $syslog

$remote_fs s wrong here, because it results in:

root@inetgw2:/etc/init.d# journalctl -x | grep mpath
май 05 16:53:46 inetgw2 ocfs2[1459]: Starting Oracle Cluster File System (OCFS2) mount.ocfs2: Device name specified was not found while opening device /dev/mapper/mpatha
май 05 16:55:15 inetgw2 systemd[1]: dev-mapper-mpatha.device: Job dev-mapper-mpatha.device/start timed out.
май 05 16:55:15 inetgw2 systemd[1]: Timed out waiting for device dev-mapper-mpatha.device.
-- Subject: Ошибка юнита dev-mapper-mpatha.device
-- Произошел сбой юнита dev-mapper-mpatha.device.
май 05 16:55:15 inetgw2 systemd[1]: dev-mapper-mpatha.device: Job dev-mapper-mpatha.device/start failed with result 'timeout'.
май 05 16:55:16 inetgw2 multipathd[1690]: mpatha: load table [0 314572800 multipath 1 queue_if_no_path 0 2 1 round-robin 0 2 1 8:32 1000 8:48 1000 round-robin 0 2 1 8:16 1000 8:64 1000]

i.e. multipathd is started _after_ systemd tries mount.

looks like removing $remote_fs solves problem.

Thank you!

Dimitri John Ledkov (xnox) wrote :

Nu ili mi prosto dolzhni ubrat init skripi, i tolko rabotat na systemd unitah.

Changed in multipath-tools (Ubuntu):
status: New → In Progress
Changed in multipath-tools (Ubuntu Xenial):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multipath-tools - 0.5.0+git1.656f8865-5ubuntu3

---------------
multipath-tools (0.5.0+git1.656f8865-5ubuntu3) yakkety; urgency=medium

  * Cherrypick from debian:
   - Call clean target before rebuilding with systemd support
   - Call systemd in debian/rules. Also adapt init service
     aliasing.
   - Should resolve LP: #1578638, LP: #1589526, LP: #1583563.

 -- Dimitri John Ledkov <email address hidden> Thu, 16 Jun 2016 11:53:33 +0300

Changed in multipath-tools (Ubuntu):
status: In Progress → Fix Released
description: updated

Hello sles, or anyone else affected,

Accepted multipath-tools into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/multipath-tools/0.5.0+git1.656f8865-5ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in multipath-tools (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multipath-tools - 0.5.0+git1.656f8865-5ubuntu2.1

---------------
multipath-tools (0.5.0+git1.656f8865-5ubuntu2.1) xenial; urgency=medium

  * Cherrypick from debian:
   - Call clean target before rebuilding with systemd support
   - Call systemd in debian/rules. Also adapt init service
     aliasing.
   - Resolves LP: #1578638, LP: #1589526, LP: #1583563. Separate bugs, all
    due to same root cause.

 -- Dimitri John Ledkov <email address hidden> Thu, 16 Jun 2016 11:53:33 +0300

Changed in multipath-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for multipath-tools has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers