LVM over multipath setups fail to boot

Bug #1480399 reported by Mathieu Trudel-Lapierre on 2015-07-31
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
multipath-tools (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

Wily, using multipath-tools 0.5.0-7ubuntu2

Installing Ubuntu on LVM over multipath disks fails to boot, falls to the recovery console from systemd (not the initramfs console).

This is likely to be because of a race between LVM and multipath -- if LVM tries to pick up the device and locks it before multipath-tools can do its job.

Tried to extract as much information as possible from this system while in the recovery console.

Note, this does not happen at all when installing directly to the multipath device, only with LVM on top of multipath.

Additional information. Output of multipath -v4 (as opposed to -v3) shows that the ioctl reload can't happen because something else already has a lock on it. I will need to dig in some more to verify whether that really is LVM, and how to correct this.

Shipping the wwids file from multipath doesn't seem to be enough, there may be a need to shuffle some things around in udev rules.

Changed in multipath-tools (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → High
status: New → Triaged

This appears to be reproducible again on 18.10, except at very early boot (premount):

Quiescing Open Firmware ...
Booting Linux via __start() @ 0x0000000002000000 ...
Linux ppc64le
#11-Ubuntu SMP T[ 0.795638] integrity: Unable to open file: /etc/keys/x509_ima.der (-2)
[ 0.795640] integrity: Unable to open file: /etc/keys/x509_evm.der (-2)
[ 2.058041] vio vio: uevent: failed to send synthetic uevent
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: PV dgFjip-AMJ8-ZsA9-7e0j-fyJR-lodF-ASXSYz on /dev/sdb2 was already found on /dev/sda2.
  WARNING: PV dgFjip-AMJ8-ZsA9-7e0j-fyJR-lodF-ASXSYz prefers device /dev/sda2 because device was seen first.
  Cannot activate LVs in VG ubuntu-vg while PVs appear on duplicate devices.
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
  WARNING: PV dgFjip-AMJ8-ZsA9-7e0j-fyJR-lodF-ASXSYz on /dev/sdb2 was already found on /dev/sda2.
  WARNING: PV dgFjip-AMJ8-ZsA9-7e0j-fyJR-lodF-ASXSYz prefers device /dev/sda2 because device was seen first.
  Cannot activate LVs in VG ubuntu-vg while PVs appear on duplicate devices.

Breaking at premount, to have multipath load before LVM gets to load the devices leads to a system that finishes booting but appears to be in read-only filesystem.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1480399

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers