Activity log for bug #1468897

Date Who What changed Old value New value Message
2015-06-25 20:53:21 Mike Rushton bug added bug
2015-06-30 14:17:56 Jeff Lane tags apport-bug ppc64el trusty uec-images apport-bug hwcert-server ppc64el trusty uec-images
2015-06-30 17:36:01 Chris J Arges multipath-tools (Ubuntu): assignee Chris J Arges (arges)
2015-06-30 17:36:03 Chris J Arges multipath-tools (Ubuntu): importance Undecided Medium
2015-07-02 16:42:00 Stefan Bader bug added subscriber Stefan Bader
2015-07-02 18:00:16 Chris J Arges multipath-tools (Ubuntu): status New Confirmed
2015-07-08 20:30:05 Mathieu Trudel-Lapierre multipath-tools (Ubuntu): assignee Chris J Arges (arges) Mathieu Trudel-Lapierre (mathieu-tl)
2015-07-08 20:30:07 Mathieu Trudel-Lapierre multipath-tools (Ubuntu): status Confirmed In Progress
2015-07-10 23:34:43 Steve Langasek nominated for series Ubuntu Trusty
2015-07-10 23:34:43 Steve Langasek bug task added multipath-tools (Ubuntu Trusty)
2015-07-10 23:35:11 Steve Langasek multipath-tools (Ubuntu Trusty): importance Undecided Medium
2015-07-10 23:35:11 Steve Langasek multipath-tools (Ubuntu Trusty): status New Triaged
2015-07-11 03:27:09 Mathieu Trudel-Lapierre multipath-tools (Ubuntu Trusty): assignee Mathieu Trudel-Lapierre (mathieu-tl)
2015-07-14 15:52:41 Launchpad Janitor branch linked lp:~mathieu-tl/ubuntu/vivid/multipath-tools/SRUs-fastio-usb-findmpath
2015-07-14 18:46:54 Launchpad Janitor multipath-tools (Ubuntu): status In Progress Fix Released
2015-07-15 19:29:00 Chris J Arges multipath-tools (Ubuntu Trusty): status Triaged Fix Committed
2015-07-15 19:29:02 Chris J Arges bug added subscriber Ubuntu Stable Release Updates Team
2015-07-15 19:29:06 Chris J Arges bug added subscriber SRU Verification
2015-07-15 19:29:13 Chris J Arges tags apport-bug hwcert-server ppc64el trusty uec-images apport-bug hwcert-server ppc64el trusty uec-images verification-needed
2015-07-20 16:55:12 Mathieu Trudel-Lapierre tags apport-bug hwcert-server ppc64el trusty uec-images verification-needed apport-bug hwcert-server ppc64el trusty uec-images verification-failed
2015-07-24 20:28:21 Launchpad Janitor branch linked lp:~mathieu-tl/ubuntu/trusty/multipath-tools/usb+local
2015-07-27 18:05:29 Adam Conrad multipath-tools (Ubuntu Trusty): status Fix Committed Confirmed
2015-07-27 18:05:42 Adam Conrad multipath-tools (Ubuntu Trusty): status Confirmed Fix Committed
2015-07-27 18:05:49 Adam Conrad tags apport-bug hwcert-server ppc64el trusty uec-images verification-failed apport-bug hwcert-server ppc64el trusty uec-images
2015-07-27 18:05:50 Adam Conrad tags apport-bug hwcert-server ppc64el trusty uec-images apport-bug hwcert-server ppc64el trusty uec-images verification-needed
2015-07-27 18:06:08 Adam Conrad multipath-tools (Ubuntu Trusty): status Fix Committed Confirmed
2015-07-28 17:41:40 Launchpad Janitor multipath-tools (Ubuntu Trusty): status Confirmed Fix Released
2015-07-28 17:52:02 Mathieu Trudel-Lapierre multipath-tools (Ubuntu Trusty): status Fix Released New
2015-07-28 17:52:07 Mathieu Trudel-Lapierre multipath-tools (Ubuntu Trusty): status New In Progress
2015-08-18 08:31:14 Mathieu Trudel-Lapierre description On a system with a multipath configuration, multipath bindings are being created for removable(USB) drives rendering them inaccessible as normal removable drives. in this case, the usb drive is detected as /dev/sdi: # lsblk|grep -A2 sdi sdi 8:128 1 14.7G 0 disk ├─sdi1 8:129 1 14.7G 0 part └─mpath4 (dm-9) 252:9 0 14.7G 0 mpath └─mpath4-part1 (dm-10) 252:10 0 14.7G 0 part # cat /etc/multipath/bindings # This file was created by curtin while installing the system. mpath0 1IBM IPR-0 5EC2590000000080 # End of content generated by curtin. # Everything below is maintained by multipath subsystem. mpath1 1IBM IPR-0 5EC2590000000060 mpath2 1IBM IPR-0 5EC2590000000040 mpath3 1IBM IPR-0 5EC2590000000020 mpath4 1ADATA USB Flash Drive Upon trying to format /dev/sdi1: # mkfs.ext4 /dev/sdi1 mke2fs 1.42.9 (4-Feb-2014) /dev/sdi1 is apparently in use by the system; will not make a filesystem here! ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: multipath-tools 0.4.9-3ubuntu7.2 ProcVersionSignature: User Name 3.16.0-41.55~14.04.1-generic 3.16.7-ckt11 Uname: Linux 3.16.0-41-generic ppc64le ApportVersion: 2.14.1-0ubuntu3.10 Architecture: ppc64el Date: Thu Jun 25 20:44:13 2015 ProcEnviron: TERM=screen PATH=(custom, no user) XDG_RUNTIME_DIR=<set> LANG=en_US.UTF-8 SHELL=/bin/bash SourcePackage: multipath-tools UpgradeStatus: No upgrade log present (probably fresh install) [Impact] Users installing with a USB key attached to the installing system, or adding a USB key on an installed system with multipath enabled will see the USB devices picked up by multipath. This is confusing because it changes the paths required to be used to access/mount/format the USB drives to paths under /dev/mapper, with mpath names. [Test Case] 1) Attach a USB key on a system with multipath enabled; either from the installer (booting the installer with USB attached), or on an installed system. 2) See that the device is picked up by multipath-tools and shows up in the output of 'multipath -ll' and under /dev/mapper with the same name as provided by multipath -ll. [Regression Potential] Some USB 3.0 devices *can* support multipath; users of such custom configurations will see USB devices not being considered as multipath devices. Other devices which should be considered as multipathed may not be picked up anymore. ---- On a system with a multipath configuration, multipath bindings are being created for removable(USB) drives rendering them inaccessible as normal removable drives. in this case, the usb drive is detected as /dev/sdi: # lsblk|grep -A2 sdi sdi 8:128 1 14.7G 0 disk ├─sdi1 8:129 1 14.7G 0 part └─mpath4 (dm-9) 252:9 0 14.7G 0 mpath   └─mpath4-part1 (dm-10) 252:10 0 14.7G 0 part # cat /etc/multipath/bindings # This file was created by curtin while installing the system. mpath0 1IBM IPR-0 5EC2590000000080 # End of content generated by curtin. # Everything below is maintained by multipath subsystem. mpath1 1IBM IPR-0 5EC2590000000060 mpath2 1IBM IPR-0 5EC2590000000040 mpath3 1IBM IPR-0 5EC2590000000020 mpath4 1ADATA USB Flash Drive Upon trying to format /dev/sdi1: # mkfs.ext4 /dev/sdi1 mke2fs 1.42.9 (4-Feb-2014) /dev/sdi1 is apparently in use by the system; will not make a filesystem here! ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: multipath-tools 0.4.9-3ubuntu7.2 ProcVersionSignature: User Name 3.16.0-41.55~14.04.1-generic 3.16.7-ckt11 Uname: Linux 3.16.0-41-generic ppc64le ApportVersion: 2.14.1-0ubuntu3.10 Architecture: ppc64el Date: Thu Jun 25 20:44:13 2015 ProcEnviron:  TERM=screen  PATH=(custom, no user)  XDG_RUNTIME_DIR=<set>  LANG=en_US.UTF-8  SHELL=/bin/bash SourcePackage: multipath-tools UpgradeStatus: No upgrade log present (probably fresh install)
2015-08-18 18:27:49 Steve Langasek multipath-tools (Ubuntu Trusty): status In Progress Fix Committed
2015-08-19 14:24:33 Mathew Hodson nominated for series Ubuntu Vivid
2015-08-19 14:38:23 Mathew Hodson multipath-tools (Ubuntu Trusty): milestone trusty-updates
2015-08-19 14:50:10 Mike Rushton tags apport-bug hwcert-server ppc64el trusty uec-images verification-needed apport-bug hwcert-server ppc64el trusty uec-images verification-done
2015-09-22 12:21:32 Mauricio Faria de Oliveira tags apport-bug hwcert-server ppc64el trusty uec-images verification-done apport-bug hwcert-server ppc64el trusty uec-images verification-failed
2015-09-22 12:22:15 Mauricio Faria de Oliveira bug added subscriber Mauricio Faria de Oliveira
2015-10-08 22:43:47 Brian Murray tags apport-bug hwcert-server ppc64el trusty uec-images verification-failed apport-bug hwcert-server ppc64el trusty uec-images
2015-10-08 22:43:48 Brian Murray tags apport-bug hwcert-server ppc64el trusty uec-images apport-bug hwcert-server ppc64el trusty uec-images verification-needed
2015-10-15 15:17:54 Mike Rushton tags apport-bug hwcert-server ppc64el trusty uec-images verification-needed apport-bug hwcert-server ppc64el trusty uec-images verification-failed
2015-10-16 22:42:21 Steve Langasek bug added subscriber Steve Langasek
2015-10-18 00:19:25 Mike Rushton tags apport-bug hwcert-server ppc64el trusty uec-images verification-failed apport-bug hwcert-server ppc64el trusty uec-images verification-done
2015-10-21 17:42:28 Mike Rushton tags apport-bug hwcert-server ppc64el trusty uec-images verification-done apport-bug hwcert-server ppc64el trusty uec-images verification-failed
2015-10-21 20:53:42 Steve Langasek tags apport-bug hwcert-server ppc64el trusty uec-images verification-failed apport-bug hwcert-server ppc64el trusty uec-images verification-done
2015-11-24 18:44:17 Launchpad Janitor multipath-tools (Ubuntu Trusty): status Fix Committed Fix Released
2015-11-24 18:44:27 Chris J Arges removed subscriber Ubuntu Stable Release Updates Team
2015-12-01 16:56:20 Mathieu Trudel-Lapierre bug task added multipath-tools (Ubuntu Vivid)
2015-12-01 16:56:52 Mathieu Trudel-Lapierre multipath-tools (Ubuntu Vivid): status New In Progress
2015-12-01 16:56:54 Mathieu Trudel-Lapierre multipath-tools (Ubuntu Vivid): importance Undecided Medium
2015-12-01 16:56:58 Mathieu Trudel-Lapierre multipath-tools (Ubuntu Vivid): assignee Mathieu Trudel-Lapierre (mathieu-tl)
2015-12-01 16:57:15 Mathieu Trudel-Lapierre bug added subscriber Ubuntu Stable Release Updates Team
2015-12-03 20:22:36 Brian Murray multipath-tools (Ubuntu Vivid): status In Progress Fix Committed
2015-12-03 20:22:43 Brian Murray tags apport-bug hwcert-server ppc64el trusty uec-images verification-done apport-bug hwcert-server ppc64el trusty uec-images
2015-12-03 20:22:43 Brian Murray tags apport-bug hwcert-server ppc64el trusty uec-images apport-bug hwcert-server ppc64el trusty uec-images verification-needed
2016-03-04 20:31:06 Ubuntu Foundations Team Bug Bot tags apport-bug hwcert-server ppc64el trusty uec-images verification-needed apport-bug hwcert-server ppc64el removal-candidate trusty uec-images verification-needed
2016-05-12 13:50:29 Martin Pitt multipath-tools (Ubuntu Vivid): status Fix Committed Won't Fix
2016-05-12 13:50:32 Martin Pitt removed subscriber Ubuntu Stable Release Updates Team
2016-05-12 13:50:33 Martin Pitt removed subscriber SRU Verification
2016-05-12 13:50:34 Martin Pitt tags apport-bug hwcert-server ppc64el removal-candidate trusty uec-images verification-needed apport-bug hwcert-server ppc64el removal-candidate trusty uec-images