multipath udev rules problem

Bug #1240049 reported by Andy Igoshin on 2013-10-15
108
This bug affects 19 people
Affects Status Importance Assigned to Milestone
multipath-tools (Ubuntu)
Medium
Seyeong Kim
Trusty
Undecided
Seyeong Kim

Bug Description

[SRU justification]

[Impact]

From saucy dist.

libudev0 > 178
udev > 178

multipath-tools 0.4.9-3ubuntu7
multipath-tools-boot 0.4.9-3ubuntu7

in dmesg i see folowing messages

[ 20.841480] systemd-udevd[4972]: failed to execute '/lib/udev/socket:/org/kernel/dm/multipath_event' 'socket:/org/kernel/dm/multipath_event': No such file or directory
[ 20.842117] systemd-udevd[4977]: failed to execute '/lib/udev/socket:/org/kernel/dm/multipath_event' 'socket:/org/kernel/dm/multipath_event': No such file or directory
[ 20.844770] systemd-udevd[4995]: failed to execute '/lib/udev/socket:/org/kernel/dm/multipath_event' 'socket:/org/kernel/dm/multipath_event': No such file or directory

RUN += "socket:// " line deprecated after udev 178

http://upstream-tracker.org/changelogs/libudev/178/changelog.html

[Test Case]

sudo apt-get install multipath-tools
sudo touch /etc/multipath.conf or touch /etc/multipath/multipath.conf
sudo udevadm trigger

sudo dmesg

[Regression Potential]

[Other Info]

Changed in multipath-tools (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in multipath-tools (Ubuntu):
status: New → Confirmed
Seb Bonnard (sebma) wrote :

Hi, I have the same pb. on ubuntu 13.10 and it's pollution my dmesg :

$ grep -c "systemd-udevd.*failed to execute '/lib/udev/socket:/org/kernel/dm/multipath_event" /var/log/dmesg
181

Got any suggestions ?

Seb..

Matthias Kerk (tuxlife) wrote :

We have the same problem with 14.04

I hope the bug will be fixed until the release.

Matthias Kerk (tuxlife) wrote :

the last Version from 2013-12-17 on http://christophe.varoqui.free.fr/ is multipath-tools-0.5.0

Changes :
* scsi3 persistent reservations on multipaths
* systemd integration
     ^^^^^^^^^^^^^^^
* better udev integration (get device events and ids from udev)
* kpartx support for non-512b blocksize disks
* multipathd maintenance of important kernel tunable like oom_score_adj, dev_loss_tmo and fast_io_fail
* followover failback mode
* handle offline paths and quiesced rports
* more synthetic and informative logs
* better threading and performance
* tons of bugfixes and stability improvements

Seyeong Kim (xtrusia) wrote :

udev doesn't support RUN+="socket://..." in udev rules after 178 version.

multipath-tools using libudev instead of file access.

http://upstream-tracker.org/changelogs/libudev/178/changelog.html

remove the RUN+="socket://..." line
in /lib/udev/rules.d/95-multipath.rules

then warning message will be gone.

Seyeong Kim (xtrusia) on 2014-07-18
description: updated
Seyeong Kim (xtrusia) on 2014-07-18
Changed in multipath-tools (Ubuntu):
status: Confirmed → In Progress
Louis Bouchard (louis) on 2014-07-18
description: updated
Seyeong Kim (xtrusia) on 2014-07-18
description: updated
Louis Bouchard (louis) on 2014-07-18
Changed in multipath-tools (Ubuntu):
assignee: nobody → Seyeong Kim (xtrusia)
Changed in multipath-tools (Ubuntu Trusty):
assignee: nobody → Seyeong Kim (xtrusia)
status: New → In Progress
Seyeong Kim (xtrusia) wrote :

debdiff above also fix problem on Utopic

description: updated
Louis Bouchard (louis) wrote :
Seyeong Kim (xtrusia) wrote :
Dimitri John Ledkov (xnox) wrote :

For utopic, I'd prefer to see a merge from debian, that includes this fix. However, for the sake of simplicity to SRU this change I'm going to sponsor this.

Changed in multipath-tools (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package multipath-tools - 0.4.9-3ubuntu8

---------------
multipath-tools (0.4.9-3ubuntu8) utopic; urgency=medium

  * Remove RUN+="socket:" statement in rules file since it is
    no longer supported after version 178 (LP: #1240049)
 -- Seyeong Kim <email address hidden> Fri, 18 Jul 2014 10:37:35 +0200

Changed in multipath-tools (Ubuntu):
status: Fix Committed → Fix Released
Guy Rozendorn (guy-rozendorn) wrote :

the patch removes the warning but still, something isn't right -- multipathd does not show the devices that shoul've been created by the udev rule. we're gathering more information and will update soon.

Guy Rozendorn (guy-rozendorn) wrote :

multipathd does not act upon udev changes -- its very easy to see when running udev monitor and multipathd -v9 -d and then attaching new disks.

by the looks of it, support for monitoring events by libudev was only added in 2013, far later than 0.4.9
everything seems to exist in 0.5, and none of it was merged to Ubuntu, yet.

Iain Lane (laney) wrote :

Seems this fix isn't enough then - I'm going to mark this bug as Incomplete. If somebody does merge the 0.5 release from Debian then please reset to Confirmed.

Changed in multipath-tools (Ubuntu Trusty):
status: In Progress → Incomplete
Changed in multipath-tools (Ubuntu):
status: Fix Released → Incomplete
Sebastien Bacher (seb128) wrote :

unsubscribing sponsors, seems like more work needs to be done there before it's ready for upload

Prasanth (prasantk) wrote :

Hitting the same issue. Any ETA on the availability for the fix .
Im running Ubuntu14.04.02 and Ubuntu 14.04 with multipath Version: 0.4.9-3ubuntu7.2.

As clearly mentioned in comment #13, multipathd is not working with the updated udev. We have identified this issue during testing at Netapp as well. None of the "add/remove/change" uevents are passed to multipathd and path mappings would be inconsistent when devices go away and rediscovered. Please updated the multipath-tools version to 0.5.0 so that it uses the libudev interface udev_monitor_new_from_netlink() instead of listening on udev socket.

Clint Byrum (clint-fewbar) wrote :

This bug is not "Incomplete", as we don't need more information from users. This bug was fixed, and is a Medium status because the problem reported was the erroneous warnings. We don't fix Medium bugs in SRU. So I've marked the Trusty portion as Won't Fix.

The lack of 0.5 and its udev listening features in trusty is also likely not going to be fixable as an SRU, unless an exception is made to allow this new feature. 0.5 should be merged into vivid+1 and backports used to bring the new udev functionality to trusty users. However, multipath being a non-leaf package, that may also be difficult as extensive testing would be necessary.

Changed in multipath-tools (Ubuntu):
status: Incomplete → Fix Released
Changed in multipath-tools (Ubuntu Trusty):
status: Incomplete → Won't Fix
Jakub Pavlik (pavlk-jakub) wrote :

I can confirm that multipath 0.5.0-7ubuntu3 resolved the issue. We had to built it for trusty 14.04.3 from willy.

@Jakub can you please share how you backported the proper multipath?

@Jakub HP has hit a similar issue and we have an open Launchpad bug here:

https://bugs.launchpad.net/hp/+bug/1487640

We are interested in getting the multipath 0.5.0 package for Ubuntu 14.04.2 with the fix.

Please provide where we can get the package.

There's already this fix in trusty-proposed, though not quite using multipath 0.5.0 (which is a very large changeset that would be quite difficult to review and conclusively say there are no regressions).

FWIW; I'm referring to https://launchpad.net/ubuntu/+source/multipath-tools/0.4.9-3ubuntu7.5 , which is meant to fix these bugs:
https://bugs.launchpad.net/ubuntu/+source/multipath-tools/+bug/1386637
https://bugs.launchpad.net/ubuntu/+source/multipath-tools/+bug/1468897

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers