muine.exe crashed with SIGSEGV in g_datalist_clear()

Bug #122733 reported by Evan on 2007-06-28
2
Affects Status Importance Assigned to Milestone
muine (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: muine

To reproduce:
Start Muine, hit 'a' to load the list of albums. The album list dialog will show and then Muine will crash.

This still occurs when I move my .gnome2/muine folder out of the way.

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Wed Jun 27 22:13:00 2007
Disassembly: 0x402854b0:
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/lib/muine/muine.exe
InterpreterPath: /usr/bin/mono
NonfreeKernelModules: nvidia
Package: muine 0.8.7-1ubuntu1
PackageArchitecture: amd64
ProcCmdline: /usr/bin/mono /usr/lib/muine/muine.exe
ProcCwd: /home/evan
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: muine
StacktraceTop:
 ?? ()
 g_datalist_clear () from /usr/lib/libglib-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_object_unref () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgnome-2.so.0
Title: muine.exe crashed with SIGSEGV in g_datalist_clear()
Uname: Linux candy 2.6.22-7-generic #1 SMP Mon Jun 25 17:07:55 GMT 2007 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner video

Related branches

Evan (ev) wrote :
Changed in muine:
importance: Undecided → Medium

StacktraceTop:?? ()
IA__g_datalist_clear (datalist=0xe0b080) at /build/buildd/glib2.0-2.13.5/glib/gdataset.c:120
g_object_finalize (object=0xe0b070) at /build/buildd/glib2.0-2.13.5/gobject/gobject.c:540
IA__g_object_unref (_object=<value optimized out>) at /build/buildd/glib2.0-2.13.5/gobject/gobject.c:1793
global_program_unref () at gnome-program.c:159

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package muine - 0.8.8-1ubuntu1

---------------
muine (0.8.8-1ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - Add recommends for gnome-icon-theme for KDE users
  * debian/patches/11_playlist_window.diff:
    - Added patch to fix FTBFS because of wrong named variable.
      Patch provided by Jo Shields <email address hidden>
      Thanks Jo.
  * Closes (LP: #117726) (LP: #122733)

muine (0.8.8-1) unstable; urgency=low

  * QA upload.
    + Set maintainer to Debian QA Group <email address hidden>.
  * Acknowledge NMUs.
  * Fix watch file. (Closes: #449835).
  * New upstream release.
    + Drop all previous patches.
    + Updated NDesk managed DBus import. (Closes: #440817, #427263).
    + Use external NDesk dbus. (Closes: #415419).
  * Move build system from CDBS to debhelper.
  * Move from simple-patchsys to quilt.
  * Remove -X revisions on build-depends.
  * Add authors and copyright holders in debian/copyright.
    + Point link to GPL-2.
  * Remove unneeded dirs file.
  * Escape hyphens in manpage.
  * 10_desktop_encoding.diff. (Remove deprecated encoding from desktop file.)
  * Bump Standards Version to 3.7.3.
    + Menu policy transition.

 -- Stephan Hermann <email address hidden> Thu, 15 May 2008 11:45:45 +0200

Changed in muine:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers