mugshot crashed with PermissionError in get_libreoffice_data(): [Errno 13] Permission denied: '/home/username/.config/libreoffice/4/user/registrymodifications.xcu'

Bug #1557744 reported by CelticJak
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fix Released
mugshot (Ubuntu)
Fix Released

Bug Description

I just clicked on Mugshot in Xubuntu 16.04 and it crashed.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: mugshot 0.3.0-0ubuntu5
ProcVersionSignature: Ubuntu 4.4.0-12.28-generic 4.4.4
Uname: Linux 4.4.0-12-generic x86_64
NonfreeKernelModules: prl_fs_freeze prl_fs prl_eth prl_tg
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue Mar 15 15:39:23 2016
ExecutablePath: /usr/bin/mugshot
InstallationDate: Installed on 2016-03-01 (14 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160224)
InterpreterPath: /usr/bin/python3.5
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/mugshot
 PATH=(custom, no user)
PythonArgs: ['/usr/bin/mugshot']
SourcePackage: mugshot
Title: mugshot crashed with PermissionError in get_libreoffice_data(): [Errno 13] Permission denied: '/home/username/.config/libreoffice/4/user/registrymodifications.xcu'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
CelticJak (odysseusjak) wrote :
information type: Private → Public
tags: removed: need-duplicate-check
Changed in mugshot (Ubuntu):
importance: Undecided → Medium
Revision history for this message
CelticJak (odysseusjak) wrote :

Now Mugshot won't load. I logged off and tried it again; won't load. I rebooted; won't load. I ran System Monitor after I clicked on Mugshot, it's not running. I launched a terminal and ran the command "mugshot" and got the following information:

sys:1: PyGIWarning: Gst was imported without specifying a version first. Use gi.require_version('Gst', '1.0') before import to ensure that the right version gets loaded.
Traceback (most recent call last):
  File "/usr/bin/mugshot", line 36, in <module>
  File "/usr/lib/python3/dist-packages/mugshot/", line 46, in main
    window = MugshotWindow.MugshotWindow()
  File "/usr/lib/python3/dist-packages/mugshot_lib/", line 52, in __new__
  File "/usr/lib/python3/dist-packages/mugshot/", line 223, in finish_initializing
  File "/usr/lib/python3/dist-packages/mugshot/", line 262, in init_user_details
    user_details = self.get_user_details()
  File "/usr/lib/python3/dist-packages/mugshot/", line 667, in get_user_details
    data = self.get_libreoffice_data()
  File "/usr/lib/python3/dist-packages/mugshot/", line 750, in get_libreoffice_data
    for line in open(prefs_file):
PermissionError: [Errno 13] Permission denied: '/home/jack/.config/libreoffice/4/user/registrymodifications.xcu'

Revision history for this message
Sean Davis (bluesabre) wrote :
Changed in mugshot:
status: New → Fix Committed
Sean Davis (bluesabre)
Changed in mugshot:
milestone: none → 0.3.1
Sean Davis (bluesabre)
Changed in mugshot:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mugshot - 0.3.1-0ubuntu1

mugshot (0.3.1-0ubuntu1) xenial; urgency=medium

  * New upstream bugfix release.
    - Fix: Failure in extracting details from /etc/passwd (LP: #1304920)
    - Fix: Failed reading of /etc/passwd with empty values (LP: #1394064)
    - Fix: Crash when ~/.face is empty or invalid (LP: #1400055)
    - Fix: Crash when unable to read LibreOffice config (LP: #1557744)
    - Fix: Incorrect handling of empty name fields (LP: #1559815)
  * debian/patches/01_disable-clutter-camera.patch
    - Added, clutter camera is broken in xenial
  * debian/rules
    - Drop depends on gstreamer1.0-tools

 -- Sean Davis <email address hidden> Thu, 31 Mar 2016 20:34:28 -0400

Changed in mugshot (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.