mugshot crashed with TypeError in _spawn(): The argument, args, must be a list.

Bug #1443283 reported by SEAD on 2015-04-13
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mugshot
Undecided
Unassigned
mugshot (Arch Linux)
New
Undecided
Unassigned
mugshot (Ubuntu)
Medium
Unassigned

Bug Description

Mugshot is not opening anymore since Xubuntu got the Beta 2 state

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: mugshot 0.2.5-1
ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
Uname: Linux 3.19.0-10-generic x86_64
ApportVersion: 2.17-0ubuntu2
Architecture: amd64
CrashCounter: 1
CurrentDesktop: XFCE
Date: Mon Apr 13 02:09:00 2015
ExecutablePath: /usr/bin/mugshot
InstallationDate: Installed on 2015-04-10 (2 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150326)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/mugshot
ProcEnviron:
 LANGUAGE=es_MX:es
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=es_MX.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/mugshot']
SourcePackage: mugshot
Title: mugshot crashed with TypeError in _spawn(): The argument, args, must be a list.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

SEAD (seadx6) wrote :
tags: removed: need-duplicate-check
Changed in mugshot (Ubuntu):
importance: Undecided → Medium
Jackson Doak (noskcaj) on 2015-07-09
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mugshot (Ubuntu):
status: New → Confirmed

I saw this bug on Arch, "sudo mugshot" works (edit root), just "mugshot" giveme the error
Someway it's unable to run sudo besides it happen on an user with sudo rights.

FOllowing full error message:
http://pastebin.com/uUBx6LNZ

Sean Davis (bluesabre) wrote :

Can you please see if this bug still affects you with the recent Mugshot 0.4.0 release? I am unable to reproduce this at this time.

Sean Davis (bluesabre) on 2018-04-18
Changed in mugshot:
status: New → Incomplete
Changed in mugshot (Ubuntu):
status: Confirmed → Incomplete
no longer affects: mugshot
Conrad Kostecki (conikost) wrote :

I can still reproduce. This patch fixed it for me.

The attachment "fix_env_spawn_args.patch.txt" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Sean Davis (bluesabre) wrote :

Adjusted the patch to account for another crash, and applied at the below commit. Thanks!

https://git.launchpad.net/mugshot/commit/?id=01674e74456f14efb06441bb59f76a8eada0949e

Changed in mugshot:
status: New → Fix Committed
Sean Davis (bluesabre) on 2018-08-08
Changed in mugshot:
milestone: none → 0.4.1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers