mtx package version 1.3.12-9 installation fails with duplicate bash-completion via apt-get

Bug #1642582 reported by bugproxy on 2016-11-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Medium
Canonical Server Team
mtx (Debian)
Fix Released
Unknown
mtx (Ubuntu)
High
Dimitri John Ledkov
Xenial
Critical
Dimitri John Ledkov
Yakkety
High
Dimitri John Ledkov
Zesty
High
Dimitri John Ledkov

Bug Description

[Impact]

* mtx package has an arch-skew contents. On xenial and yakkety, on s390x, the package was build with new enough bash-completion debhelper addon that has placed the completion files into /usr which generates file conflict with bash-completion package itself
* on all other architectures in xenial and yakkety the bash completion file is shipped by the mtx package, redundantly in /etc, when there is a completion file in /usr in bash-completion package already
* in zesty the bash completion file got remoted from the mtx package in favor of bash-completion package one.
* to avoid file conflict on s390x on xenial/yakkety, I'm proposing to rebuild mtx package on xenial and yakkety and remove the redudant bash completion file

[Testcase]
* Co-install mtx package and bash-completion package, without any file conflicts
* Verify that /etc/bash_completion.d/mtx file does not exist and/or is removed during the installation of the new mtx package (that should happen on non-s390x architectures)
* Verify that mtx bash completion is still available

[Original bug report]

Summary
=======
Machine: IBM z13, Ubuntu 16.04.01. uname -a
Linux s8314007 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:42:36 UTC 2016 s390x s390x s390x GNU/Linux
We were unable to install the 'mtx' package for control of tape autochangers via 'apt-get install mtx'

Details
=======
We wanted to install both the mt-st and mtx packages for s390 tape support.
We encountered a problem in the mtx_1.3.12-9_s390x.deb package which was downloaded to /var/cache/apt/archives/ location but installation was not performed due to duplicate bash completion data being delivered.
See the console output section below for results and more details about the error itself.
We expect the mtx package to install smoothly with apt-get install mtx.

We worked around with:
~~~~~~~~~~~~~~~~~~~~~~
# dpkg --force-overwrite -i /var/cache/apt/archives/mtx_1.3.12-9_s390x.deb
(Reading database ... 76609 files and directories currently installed.)
Preparing to unpack .../mtx_1.3.12-9_s390x.deb ...
Unpacking mtx (1.3.12-9) ...
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: trying to overwrite '/usr/share/bash-completion/completions/mtx', which is also in package bash-completion 1:2.1-4.2ubuntu1.1
Setting up mtx (1.3.12-9) ...
Processing triggers for man-db (2.7.5-1) ...
# dpkg -l|grep mtx
ii mtx 1.3.12-9 s390x controls tape autochangers

Console output
==============
# apt-get install mtx -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  mtx
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 93.9 kB of archives.
After this operation, 395 kB of additional disk space will be used.
Get:1 http://ports.ubuntu.com xenial/main s390x mtx s390x 1.3.12-9 [93.9 kB]
Fetched 93.9 kB in 0s (0 B/s)
(Reading database ... 76609 files and directories currently installed.)
Preparing to unpack .../mtx_1.3.12-9_s390x.deb ...
Unpacking mtx (1.3.12-9) ...
dpkg: error processing archive /var/cache/apt/archives/mtx_1.3.12-9_s390x.deb (--unpack):
 trying to overwrite '/usr/share/bash-completion/completions/mtx', which is also in package bash-completion 1:2.1-4.2ubuntu1.1
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/mtx_1.3.12-9_s390x.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
#

bugproxy (bugproxy) on 2016-11-17
tags: added: architecture-s39064 bugnameltc-148858 severity-medium targetmilestone-inin1604
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → mtx (Ubuntu)
Frank Heimes (frank-heimes) wrote :

affects ubuntu-z-systems project, but is not limited to s390x

Changed in ubuntu-z-systems:
importance: Undecided → Medium
assignee: nobody → Canonical Server Team (canonical-server)
Robie Basak (racb) on 2016-11-28
Changed in mtx (Ubuntu):
importance: Undecided → Medium
Dimitri John Ledkov (xnox) wrote :

I agree that there is a conflict, however I cannot reproduce it the way it is specified in the bug description, out of the box. From archive Contents file:

etc/bash_completion.d/mtx admin/mtx
usr/share/bash-completion/completions/mtx shells/bash-completion

One ships the completion file in the new location, whilst the other ships it in the old location.

The two should not create a dpkg conflict. And they do not, in a clean Ubuntu Xenial chroot (e.g. $ mk-sbuild xenial; schroot -u root -c xenial-s390x; apt update; apt install bash-completion mtx)

From the affected system, can you please provide output of:
$ ls -latr /etc/ | grep bash

to verify that e.g. /etc/bash_completion.d is not a symlink to usr/share/bash-completion/completions/ on your system.

Nonetheless, I will open a new bug report about this completion conflict between these two packages in Debian.

Changed in bash-completion (Ubuntu):
status: New → Incomplete
Changed in mtx (Ubuntu):
status: New → Incomplete
importance: Medium → Wishlist
no longer affects: bash-completion (Ubuntu)

------- Comment From <email address hidden> 2016-12-12 10:22 EDT-------
Hello Dmitri,

on a Ubuntu 16.04.01 machine where 'mtx' was not yet installed and running apt-get install mtx failed the decribed way above, here's the requested output and some hopefully helpful info:
# ls -latr /etc/ | grep bash
-rw-r--r-- 1 root root 45 Aug 12 2015 bash_completion
-rw-r--r-- 1 root root 2188 Dec 3 2015 bash.bashrc
drwxr-xr-x 2 root root 4096 Apr 21 2016 bash_completion.d
# file /etc/bash_completion.d
/etc/bash_completion.d: directory
# ll /etc/bash_completion.d/mtx
ls: cannot access '/etc/bash_completion.d/mtx': No such file or directory
# ll /usr/share/bash-completion/completions/mtx
-rw-r--r-- 1 root root 1212 May 18 2016 /usr/share/bash-completion/completions/mtx
# ll -R /etc/bash_completion.d/
/etc/bash_completion.d/:
total 12
drwxr-xr-x 2 root root 4096 Apr 21 2016 ./
drwxr-xr-x 90 root root 4096 Sep 26 12:53 ../
-rw-r--r-- 1 root root 408 Dec 3 2015 cryptdisks
# dpkg -l mtx
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=========================-=================-=================-=======================================================
in mtx <none> s390x (no description available)
# dpkg -L mtx
dpkg-query: package 'mtx' is not installed
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

Let me know if you need further details.

Thanks.

bugproxy (bugproxy) on 2016-12-14
tags: added: targetmilestone-inin16042
removed: targetmilestone-inin1604
Changed in mtx (Debian):
status: Unknown → New
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2017-01-18 08:40 EDT-------
Changed target to 17.04 after Communication with [CAN]

tags: added: targetmilestone-inin1704
removed: targetmilestone-inin16042
Changed in mtx (Debian):
status: New → Fix Released
Changed in ubuntu-z-systems:
status: New → Incomplete
Dimitri John Ledkov (xnox) wrote :

This bug report is not reproducible.

On a clean xenial system installing mtx & bash-completion simultaniously works without any file conflicts.

If there are systems you still experience this on, please provide steps to reproduce the problem starting from a clean install, preferably.

(xenial-amd64)root@ottawa:~# apt install mtx bash-completion
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  bash-completion mtx
0 upgraded, 2 newly installed, 0 to remove and 61 not upgraded.
Need to get 243 kB of archives.
After this operation, 1598 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 bash-completion all 1:2.1-4.2ubuntu1.1 [152 kB]
Get:2 http://archive.ubuntu.com/ubuntu xenial/main amd64 mtx amd64 1.3.12-9 [90.5 kB]
Fetched 243 kB in 0s (3452 kB/s)
Selecting previously unselected package bash-completion.
(Reading database ... 12323 files and directories currently installed.)
Preparing to unpack .../bash-completion_1%3a2.1-4.2ubuntu1.1_all.deb ...
Unpacking bash-completion (1:2.1-4.2ubuntu1.1) ...
Replaced by files in installed package apt (1.2.15) ...
Selecting previously unselected package mtx.
Preparing to unpack .../mtx_1.3.12-9_amd64.deb ...
Unpacking mtx (1.3.12-9) ...
Setting up bash-completion (1:2.1-4.2ubuntu1.1) ...
Setting up mtx (1.3.12-9) ...

Changed in mtx (Ubuntu):
status: Incomplete → Invalid
Dimitri John Ledkov (xnox) wrote :

frank helped me to reproduce this bug correctly. will fix soon.

Changed in mtx (Ubuntu):
status: Invalid → Fix Released
status: Fix Released → Confirmed
Changed in mtx (Ubuntu Xenial):
status: New → Confirmed
Changed in mtx (Ubuntu Yakkety):
status: New → Confirmed
Changed in mtx (Ubuntu Xenial):
importance: Undecided → Critical
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in mtx (Ubuntu Yakkety):
importance: Undecided → High
Changed in mtx (Ubuntu Zesty):
importance: Wishlist → High
Changed in mtx (Ubuntu Yakkety):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in mtx (Ubuntu Zesty):
assignee: Skipper Bug Screeners (skipper-screen-team) → Dimitri John Ledkov (xnox)
no longer affects: mtx (Ubuntu Aa-series)
Changed in mtx (Ubuntu Zesty):
status: Confirmed → Fix Released
description: updated
Changed in ubuntu-z-systems:
status: Incomplete → Confirmed
description: updated
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2017-04-12 06:05 EDT-------
We have been able to reproduce the problem on s390x with the command used in the comment above on amd64 which is slightly different from the original error report (see steps to reproduce). Since the problem is immediately reproducible I presume there are architecture dependent differences in the package, i.e. mtx_1.3.12-9_s390x.deb versus mtx_1.3.12-9_amd64.deb.

# apt install mtx bash-completion
Reading package lists... Done
Building dependency tree
Reading state information... Done
bash-completion is already the newest version (1:2.1-4.2ubuntu1.1).
The following NEW packages will be installed:
mtx
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/93.9 kB of archives.
After this operation, 395 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 76129 files and directories currently installed.)
Preparing to unpack .../mtx_1.3.12-9_s390x.deb ...
Unpacking mtx (1.3.12-9) ...
dpkg: error processing archive /var/cache/apt/archives/mtx_1.3.12-9_s390x.deb (--unpack):
trying to overwrite '/usr/share/bash-completion/completions/mtx', which is also in package bash-completion 1:2.1-4.2ubuntu1.1
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
/var/cache/apt/archives/mtx_1.3.12-9_s390x.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Changed in mtx (Ubuntu Xenial):
status: Confirmed → In Progress
Changed in mtx (Ubuntu Yakkety):
status: Confirmed → In Progress
Changed in ubuntu-z-systems:
status: Confirmed → In Progress

Hello bugproxy, or anyone else affected,

Accepted mtx into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mtx/1.3.12-9ubuntu0.16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mtx (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in mtx (Ubuntu Xenial):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello bugproxy, or anyone else affected,

Accepted mtx into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mtx/1.3.12-9ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Frank Heimes (frank-heimes) wrote :

Hi Lukasz,
the issue seems to be fixed for me on xenial:

### negative test, using the old package (without proposed):

apt-cache policy mtx
mtx:
  Installed: (none)
  Candidate: 1.3.12-9
  Version table:
     1.3.12-9 500
        500 http://us.ports.ubuntu.com/ubuntu-ports xenial/main s390x Packages

sudo apt-get install mtx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-67 linux-headers-4.4.0-67-generic
  linux-image-4.4.0-67-generic linux-image-extra-4.4.0-67-generic
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  mtx
0 upgraded, 1 newly installed, 0 to remove and 13 not upgraded.
Need to get 93.9 kB of archives.
After this operation, 395 kB of additional disk space will be used.
Get:1 http://us.ports.ubuntu.com/ubuntu-ports xenial/main s390x mtx s390x 1.3.12-9 [93.9 kB]
Fetched 93.9 kB in 0s (7,215 kB/s)
Selecting previously unselected package mtx.
(Reading database ... 134486 files and directories currently installed.)
Preparing to unpack .../mtx_1.3.12-9_s390x.deb ...
Unpacking mtx (1.3.12-9) ...
dpkg: error processing archive /var/cache/apt/archives/mtx_1.3.12-9_s390x.deb (--unpack):
 trying to overwrite '/usr/share/bash-completion/completions/mtx', which is also in package bash-completion 1:2.1-4.2ubuntu1.1
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/mtx_1.3.12-9_s390x.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

### now with the package from proposed:

apt-cache policy mtx
mtx:
  Installed: (none)
  Candidate: 1.3.12-9ubuntu0.16.04.1
  Version table:
     1.3.12-9ubuntu0.16.04.1 500
        500 http://ports.ubuntu.com/ubuntu-ports xenial-proposed/main s390x Packages
     1.3.12-9 500
        500 http://us.ports.ubuntu.com/ubuntu-ports xenial/main s390x Packages

sudo apt-get install mtx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-67 linux-headers-4.4.0-67-generic
  linux-image-4.4.0-67-generic linux-image-extra-4.4.0-67-generic
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  mtx
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 93.5 kB of archives.
After this operation, 392 kB of additional disk space will be used.
Get:1 http://ports.ubuntu.com/ubuntu-ports xenial-proposed/main s390x mtx s390x 1.3.12-9ubuntu0.16.04.1 [93.5 kB]
Fetched 93.5 kB in 0s (364 kB/s)
(Reading database ... 155443 files and directories currently installed.)
Preparing to unpack .../mtx_1.3.12-9ubuntu0.16.04.1_s390x.deb ...
Unpacking mtx (1.3.12-9ubuntu0.16.04.1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up mtx (1.3.12-9ubuntu0.16.04.1) ...

Thx

tags: added: verification-done-xenial

------- Comment From <email address hidden> 2017-04-24 09:45 EDT-------
Thanks Frank for verifying. Intersting, I was thinking from the above messages that the package was only available in yakkety-proposed for the time being.

Summary: The updated mtx package now installs fine. See details below, first negative test by trying from yakkety and failing, then adding yakkety-proposed repo:

# apt-get install mtx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
g++-5 libasprintf0v5 libboost-iostreams1.58.0 libicu55 libjson-c-dev libjson0 libstdc++-5-dev
linux-headers-4.4.0-21 linux-headers-4.4.0-21-generic linux-image-4.4.0-21-generic
linux-image-extra-4.4.0-21-generic
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
mtx
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 93.9 kB of archives.
After this operation, 395 kB of additional disk space will be used.
Get:1 http://ports.ubuntu.com yakkety/main s390x mtx s390x 1.3.12-9 [93.9 kB]
Fetched 93.9 kB in 0s (1079 kB/s)
Selecting previously unselected package mtx.
(Reading database ... 100030 files and directories currently installed.)
Preparing to unpack .../mtx_1.3.12-9_s390x.deb ...
Unpacking mtx (1.3.12-9) ...
dpkg: error processing archive /var/cache/apt/archives/mtx_1.3.12-9_s390x.deb (--unpack):
trying to overwrite '/usr/share/bash-completion/completions/mtx', which is also in package bash-completion 1:2.1-4.3ubuntu1
Errors were encountered while processing:
/var/cache/apt/archives/mtx_1.3.12-9_s390x.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@s8314003:~# apt-cache policy mtx
mtx:
Installed: (none)
Candidate: 1.3.12-9
Version table:
1.3.12-9 500
500 http://ports.ubuntu.com yakkety/main s390x Packages

________________________________________________________________________________

After adding yakkety-proposed to the /etc/apt/sources.list file and apt-get update
apt-get install mtx was processing without error.

# apt-get install mtx
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
g++-5 libasprintf0v5 libboost-iostreams1.58.0 libicu55 libjson-c-dev libjson0 libstdc++-5-dev
linux-headers-4.4.0-21 linux-headers-4.4.0-21-generic linux-image-4.4.0-21-generic
linux-image-extra-4.4.0-21-generic
Use 'apt autoremove' to remove them.
The following NEW packages will be installed:
mtx
0 upgraded, 1 newly installed, 0 to remove and 31 not upgraded.
Need to get 93.2 kB of archives.
After this operation, 392 kB of additional disk space will be used.
Get:1 http://ports.ubuntu.com/ubuntu-ports yakkety-proposed/main s390x mtx s390x 1.3.12-9ubuntu0.16.10.1 [93.2 kB]
Fetched 93.2 kB in 0s (662 kB/s)
(Reading database ... 100030 files and directories currently installed.)
Preparing to unpack .../mtx_1.3.12-9ubuntu0.16.10.1_s390x.deb ...
Unpacking mtx (1.3.12-9ubuntu0.16.10.1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up mtx (1.3.12-9ubuntu0.16.10.1) ...

Download full text (8.5 KiB)

Hi Christian,
well, the messages that ask for verification are created for all Ubuntu
releases that are affected and currently still in service.
And these msgs look very similar:
The Yakkety msg:
https://bugs.launchpad.net/ubuntu/+source/mtx/+bug/1642582/comments/8
and the Xenial msg:
https://bugs.launchpad.net/ubuntu/+source/mtx/+bug/1642582/comments/9

Anyway, good that you were able to do the verification for yakkety as well
- thx for that!

Frank Heimes | Tech. Lead z | Canonical Ltd.
mail: <email address hidden>
irc: jfh
P: +49 (0) 7031 415515
www.canonical.com | www.ubuntu.com | ubuntu-on-big-iron.blogspot.com
<http://ubuntu-on-big-iron.blogspot.com/?view=sidebar> |
http://fridge.ubuntu.com

On Mon, Apr 24, 2017 at 3:50 PM, bugproxy <email address hidden> wrote:

> ------- Comment From <email address hidden> 2017-04-24 09:45 EDT-------
> Thanks Frank for verifying. Intersting, I was thinking from the above
> messages that the package was only available in yakkety-proposed for the
> time being.
>
> Summary: The updated mtx package now installs fine. See details below,
> first negative test by trying from yakkety and failing, then adding
> yakkety-proposed repo:
>
> # apt-get install mtx
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following packages were automatically installed and are no longer
> required:
> g++-5 libasprintf0v5 libboost-iostreams1.58.0 libicu55 libjson-c-dev
> libjson0 libstdc++-5-dev
> linux-headers-4.4.0-21 linux-headers-4.4.0-21-generic
> linux-image-4.4.0-21-generic
> linux-image-extra-4.4.0-21-generic
> Use 'apt autoremove' to remove them.
> The following NEW packages will be installed:
> mtx
> 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
> Need to get 93.9 kB of archives.
> After this operation, 395 kB of additional disk space will be used.
> Get:1 http://ports.ubuntu.com yakkety/main s390x mtx s390x 1.3.12-9 [93.9
> kB]
> Fetched 93.9 kB in 0s (1079 kB/s)
> Selecting previously unselected package mtx.
> (Reading database ... 100030 files and directories currently installed.)
> Preparing to unpack .../mtx_1.3.12-9_s390x.deb ...
> Unpacking mtx (1.3.12-9) ...
> dpkg: error processing archive /var/cache/apt/archives/mtx_1.3.12-9_s390x.deb
> (--unpack):
> trying to overwrite '/usr/share/bash-completion/completions/mtx', which
> is also in package bash-completion 1:2.1-4.3ubuntu1
> Errors were encountered while processing:
> /var/cache/apt/archives/mtx_1.3.12-9_s390x.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> root@s8314003:~# apt-cache policy mtx
> mtx:
> Installed: (none)
> Candidate: 1.3.12-9
> Version table:
> 1.3.12-9 500
> 500 http://ports.ubuntu.com yakkety/main s390x Packages
>
> ____________________________________________________________
> ____________________
>
> After adding yakkety-proposed to the /etc/apt/sources.list file and
> apt-get update
> apt-get install mtx was processing without error.
>
> # apt-get install mtx
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following packages were automatically installed and are no longer
> required:
> g++-5 ...

Read more...

tags: added: verification-done verification-done-yakkety
removed: verification-needed

------- Comment From <email address hidden> 2017-04-25 02:27 EDT-------
IBM Bugzilla Status -> closed ; fixed and verfied.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2017-04-25 03:09 EDT-------
For completeness on Yakkety on s390x architecture I quickly checked
* Co-install mtx package and bash-completion package, without any file conflicts
(ok, see previous comments)
* Verify that /etc/bash_completion.d/mtx file does not exist and/or is removed during the installation of the new mtx package (that should happen on non-s390x architectures)
OK # ll /etc/bash_completion.d/mtx
ls: cannot access '/etc/bash_completion.d/mtx': No such file or directory
* Verify that mtx bash completion is still available
OK
mt<TAB>
mt mt-gnu mtr mtrace mtx
# mtx<TAB>
--version eepos inquiry invert load noattach status
-f first inventory last next nobarcode unload

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mtx - 1.3.12-9ubuntu0.16.04.1

---------------
mtx (1.3.12-9ubuntu0.16.04.1) xenial; urgency=medium

  * Remove bash completions, they are also in the bash-completion package.
    This avoids file-conflict on the s390x architecture, as new enough
    bash-completion debhelper addon generated the conflict on that
    architecture only. LP: #1642582

 -- Dimitri John Ledkov <email address hidden> Wed, 12 Apr 2017 10:44:20 +0100

Changed in mtx (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mtx has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mtx - 1.3.12-9ubuntu0.16.10.1

---------------
mtx (1.3.12-9ubuntu0.16.10.1) yakkety; urgency=medium

  * Remove bash completions, they are also in the bash-completion package.
    This avoids file-conflict on the s390x architecture, as new enough
    bash-completion debhelper addon generated the conflict on that
    architecture only. LP: #1642582

 -- Dimitri John Ledkov <email address hidden> Wed, 12 Apr 2017 10:44:20 +0100

Changed in mtx (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.