mtr no longer works as regular user: mtr: unable to get raw sockets.

Bug #1542757 reported by Marlin Cremers on 2016-02-07
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
mtr (Ubuntu)
High
Unassigned

Bug Description

mtr used to work when being run as regular user. This is no longer the case: mtr: unable to get raw sockets.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: mtr-tiny 0.86-1
ProcVersionSignature: Ubuntu 4.4.0-2.16-generic 4.4.0
Uname: Linux 4.4.0-2-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.19.4-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Feb 7 02:45:28 2016
SourcePackage: mtr
UpgradeStatus: No upgrade log present (probably fresh install)

Marlin Cremers (marlinc) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mtr (Ubuntu):
status: New → Confirmed
Changed in mtr (Ubuntu):
importance: Undecided → High
tags: added: regression-release
Brian Murray (brian-murray) wrote :

I was unable to recreate this on Xenail using mtr version 0.86-1.

Brian Murray (brian-murray) wrote :

Could you add some more information about the steps you took to encounter this bug? Did you use any switches with mtr?

Changed in mtr (Ubuntu):
status: Confirmed → Incomplete
Marlin Cremers (marlinc) wrote :

Not really I just run 'mtr'.

For example:

marlinc@marlinc-laptop:~$ mtr 8.8.8.8
mtr: unable to get raw sockets.

Haw Loeung (hloeung) on 2016-05-23
Changed in mtr (Ubuntu):
status: Incomplete → Confirmed
Haw Loeung (hloeung) wrote :

Seems to be missing the cap_net_raw+ep file capability.

| hloeung@somebox:~$ sudo getcap /usr/bin/mtr
| [sudo] password for hloeung:
| hloeung@somebox:~$ sudo setcap cap_net_raw+ep /usr/bin/mtr
| hloeung@somebox:~$ sudo getcap /usr/bin/mtr
| /usr/bin/mtr = cap_net_raw+ep

So mtr.postinst not called with "configure"?

Haw Loeung (hloeung) wrote :

Re-installing the mtr package seems to have fixed it on our Ubuntu Archive servers.

Marlin Cremers (marlinc) wrote :

Reinstalling appeared to work. I have this 16.04 install since February so it could be a leftover issue.

Changed in mtr (Ubuntu):
status: Confirmed → Invalid
Haw Loeung (hloeung) wrote :

Seen this on a fresh Xenial install:

hloeung@steelix:~$ apt-cache policy mtr-tiny
mtr-tiny:
  Installed: 0.86-1ubuntu0.1
  Candidate: 0.86-1ubuntu0.1
  Version table:
 *** 0.86-1ubuntu0.1 500

Changed in mtr (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers