libmtp error copying big files

Bug #1472789 reported by Sergio Cazzolato on 2015-07-08
56
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
John McAleely
mtp (Ubuntu)
High
Alfonso Sanchez-Beato

Bug Description

An error message is shown when trying to copy a file of 3GB from my ubuntu desktop to my krillin phone using Nautilus.

Steps to reproduce:
1. Plug a krillin device
2. Create a file with > dd if=/dev/urandom of=/tmp/bigfile.txt bs=1024 count=3000000
3. Using Nautilus, copy the file to the Documents directory in the device

In my machine it is happening that after that 2.1 GB are copied the process does not copy more content and an error screen appears (see atached). The error displayed is: "libmtp error: Could not send object"

The free space in my device is about 3.7 GB
My desktop os: Ubuntu 15.04
My krilling version is: 58 (rc-proposed)

Related branches

Pat McGowan (pat-mcgowan) wrote :

We have an MR for this at https://code.launchpad.net/~mathieu-tl/mtp/file-sizes/+merge/263248
as it was previously reported in a private bug at https://bugs.launchpad.net/barajas/+bug/1455464

Changed in mtp (Ubuntu):
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
status: New → In Progress
Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → High
milestone: none → ww34-2015
status: New → In Progress
Changed in mtp (Ubuntu):
assignee: Bill Filler (bfiller) → Pat McGowan (pat-mcgowan)
Pat McGowan (pat-mcgowan) wrote :

I tried matheiu's branch and I also bumped the storage allocation from 2GB to 4GB, no difference. The _IOW call always returns -1 when it hits a size greater than 31 bits or 2GB. The sizes passed in the mtp_file_range are correct.

Changed in mtp (Ubuntu):
assignee: Pat McGowan (pat-mcgowan) → nobody
Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → John McAleely (john.mcaleely)
status: In Progress → Triaged
Changed in mtp (Ubuntu):
status: In Progress → Triaged
Changed in canonical-devices-system-image:
milestone: ww34-2015 → ww40-2015
Changed in canonical-devices-system-image:
milestone: ww40-2015 → backlog
summary: - libmtp error copying big files
+ [FHD] libmtp error copying big files
Changed in mtp (Ubuntu):
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
status: Triaged → In Progress
Noemí (noemi-gallego) on 2016-04-13
summary: - [FHD] libmtp error copying big files
+ libmtp error copying big files
Selene ToyKeeper (toykeeper) wrote :

I copied a 4.3 GiB file to an arale with this fix, via gmtp, and it worked well with matching md5sums before and after. So, it looks like it's fixed. :)

Changed in canonical-devices-system-image:
status: Triaged → In Progress
milestone: backlog → 11
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Simon Fels (morphis) on 2016-04-25
Changed in mtp (Ubuntu):
status: In Progress → Fix Released
Javier Ibáñez (javier-ibanez) wrote :

Hi all,

Tested on fw Ubuntu 15.04 (r10) HD and Ubuntu 15.04 (r14) FHD, the issue is already fixed.

Thanks.

BR

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers