Comment 18 for bug 343069

Dave Thiede (davidrthiede) wrote :

jcornwall: I still haven't found a bug for my problem then. I tried your amd64 package but got the following:

dave@quad:~$ sudo aptitude install mt-daapd_0.9~r1696.dfsg-9ubuntu1_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
E: Unknown pattern type: r
E: Unknown pattern type: r
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

I then tried your instructions from comment 8 and couldn't get the build-dep working.

dave@quad:~$ sudo apt-get build-dep mt-daapd
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Build-dependencies for mt-daapd could not be satisfied.

I made a stab at manually adding the packages and ran into several dependency issues that were not reported normally but the apt tools. The build then proceeded but had multiple errors such as the following:

dpkg-shlibdeps: warning: symbol avcodec_decode_audio used by debian/mt-daapd/usr/lib/mt-daapd/plugins/ssc-ffmpeg.so found in none of the libraries.

should I create a new bug for my problem? from the initial poster documentation it is apparent that this same problem is present there also. as far as I can tell, if the ffmpeg plugin doesn't load then any files that require conversion (ogg at least) for itunes will fail. this also seems to affect display of mpeg movies to a tivo. it could be that the plugin failure is masking the real issue but I can't tell yet. the program worked great just prior to the upgrade.