Ubuntu

package ttf-mscorefonts-installer (not installed) failed to install/upgrade: subprocess new pre-installation script returned error exit status 128

Reported by CESAR on 2012-01-26
484
This bug affects 85 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
High
Fetra rfa

Bug Description

It happens when i installed "play on linux" software.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: ttf-mscorefonts-installer (not installed)
ProcVersionSignature: Ubuntu 2.6.32-38.83-generic 2.6.32.52+drm33.21
Uname: Linux 2.6.32-38-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed Jan 25 21:07:19 2012
ErrorMessage: el subproceso script pre-installation nuevo devolvió el código de salida de error 128
InstallationMedia: Ubuntu 10.04.3 LTS "Lucid Lynx" - Release amd64 (20110720.1)
SourcePackage: msttcorefonts
Title: package ttf-mscorefonts-installer (not installed) failed to install/upgrade: el subproceso script pre-installation nuevo devolvió el código de salida de error 128

CESAR (mamanicesar) wrote :
Steve Langasek (vorlon) wrote :

This looks like bug #442941, but the fix for that bug was included in the install media for 10.04.3.

Changed in msttcorefonts (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in msttcorefonts (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

Could you please add the log file /var/log/installer/syslog to your bug report? Thanks in advance.

Colin Watson (cjwatson) wrote :

I think it may in fact be bug 500175, which is AFAICT not automatically distinguishable from bug 442941.

Brian Murray (brian-murray) wrote :

While the error message is the same, the installation media should allow us to distinguish between the two reasons shouldn't it?

Colin Watson (cjwatson) wrote :

Strictly no. Bug 442941 could have recurred for some reason (although I don't see any evidence of that in my tests), or it could be some other problem with the same symptom. Also, bug 500175 could have occurred before bug 442941 was fixed.

But it's a better assumption than the alternative, I suppose.

summary: package ttf-mscorefonts-installer (not installed) failed to
- install/upgrade: el subproceso script pre-installation nuevo devolvió el
- código de salida de error 128
+ install/upgrade: subprocess new pre-installation script returned error
+ exit status 128
Pierre Ligot (pierre-ligot-s) wrote :

I have the same problem, I think it deny me the agreement windows (you know, where you'd sign the eula) when installing by ubuntu installer.

On 7 May 2012 08:53, Pierre Ligot <email address hidden> wrote:

> I have the same problem, I think it deny me the agreement windows (you
> know, where you'd sign the eula) when installing by ubuntu installer.
>

Hi, Pierre,

Une deuxième fois, lorsque j'ai coché la case d'agrément,
les fontes se sont installées normalement.

Galen Currah

Lorenzo Bettini (bettini) wrote :

I think this can be due to the wrong sourceforge download url? The url http://downloads.sourceforge.net/corefonts/andale32.exe does not seem to be valid... probably it should be http://sourceforge.net/projects/corefonts/files/the%20fonts/final/andale32.exe/download

indeed I get this

Preconfiguring packages ...
(Reading database ... 283869 files and directories currently installed.)
Preparing to replace ttf-mscorefonts-installer 3.4ubuntu3 (using .../ttf-mscorefonts-installer_3.4ubuntu3_all.deb) ...
mscorefonts-eula license has already been accepted
Unpacking replacement ttf-mscorefonts-installer ...
Processing triggers for fontconfig ...
Processing triggers for update-notifier-common ...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Traceback (most recent call last):
  File "/usr/lib/update-notifier/package-data-downloader", line 234, in process_download_requests
    dest_file = urllib.urlretrieve(files[i])[0]
  File "/usr/lib/python2.7/urllib.py", line 93, in urlretrieve
    return _urlopener.retrieve(url, filename, reporthook, data)
  File "/usr/lib/python2.7/urllib.py", line 239, in retrieve
    fp = self.open(url, data)
  File "/usr/lib/python2.7/urllib.py", line 207, in open
    return getattr(self, name)(url)
  File "/usr/lib/python2.7/urllib.py", line 358, in open_http
    return self.http_error(url, fp, errcode, errmsg, headers)
  File "/usr/lib/python2.7/urllib.py", line 371, in http_error
    result = method(url, fp, errcode, errmsg, headers)
  File "/usr/lib/python2.7/urllib.py", line 664, in http_error_301
    return self.http_error_302(url, fp, errcode, errmsg, headers, data)
  File "/usr/lib/python2.7/urllib.py", line 634, in http_error_302
    data)
  File "/usr/lib/python2.7/urllib.py", line 660, in redirect_internal
    return self.open(newurl)
  File "/usr/lib/python2.7/urllib.py", line 207, in open
    return getattr(self, name)(url)
  File "/usr/lib/python2.7/urllib.py", line 358, in open_http
    return self.http_error(url, fp, errcode, errmsg, headers)
  File "/usr/lib/python2.7/urllib.py", line 371, in http_error
    result = method(url, fp, errcode, errmsg, headers)
  File "/usr/lib/python2.7/urllib.py", line 634, in http_error_302
    data)
  File "/usr/lib/python2.7/urllib.py", line 660, in redirect_internal
    return self.open(newurl)
  File "/usr/lib/python2.7/urllib.py", line 207, in open
    return getattr(self, name)(url)
  File "/usr/lib/python2.7/urllib.py", line 344, in open_http
    h.endheaders(data)
  File "/usr/lib/python2.7/httplib.py", line 954, in endheaders
    self._send_output(message_body)
  File "/usr/lib/python2.7/httplib.py", line 814, in _send_output
    self.send(msg)
  File "/usr/lib/python2.7/httplib.py", line 776, in send
    self.connect()
  File "/usr/lib/python2.7/httplib.py", line 757, in connect
    self.timeout, self.source_address)
  File "/usr/lib/python2.7/socket.py", line 571, in create_connection
    raise err

root (shaman-t) wrote :

I have same output as post #10 while trying: sudo apt-get install --reinstall ttf-mscorefonts-installer
But after "raise err" at the end I see: IOError: [Errno socket error] [Errno 101] Network is unreachable
I was trying winetricks, playonliux, ubuntu-restricted-extras. Nothing help.
/var/log/installer/syslog have no output about reinstall action.

There was one workaround for this bug that I found here: https://bugs.launchpad.net/debian/+source/msttcorefonts/+bug/431217 post #21
BUT I need to change ~148 line of file /var/lib/dpkg/info/ttf-mscorefonts-installer.postinst , and I have there about 50 lines and nothing similar to what he wrote about.

I attached my /var/lib/dpkg/info/ttf-mscorefonts-installer.postinst if needed.

root (shaman-t) wrote :

Sorry, forgot to add that I have 12.04 and was upgrading it from 10.04

Luciano Fleischfresser (l-fle) wrote :

It happened when installing the Adobe Flash Player plug-in with the ms core fonts as an add-on. Will be glad to send needed information/file.

Galen Currah (galen-currah) wrote :

On 1 February 2013 03:09, Luciano Fleischfresser <email address hidden>wrote:

> It happened when installing the Adobe Flash Player plug-in with the ms
> core fonts as an add-on. Will be glad to send needed information/file.
>

Hi, Luciano,

I thank you for your reply and explanation. I think I know what to do, now.
You great service to millions of LO users has not gone unnoticed.

Galen

Guy Stone (stoneguy3) wrote :

I'm in the RR final beta context. Looks like it's been dragging on for awhile.

I encountered this bug as well. It happened when I installed the latest updates on Ubuntu 13.04.

Andrea B (news-andrea) wrote :

Ubuntu 13.04.

The installation of the packages among the Ubuntu restricted extras failed. After accepting the EULA I had a popup saying I had not accepted it and therefore the package was not installed.

I used the terminal:

sudo apt-get install ttf-mscorefonts-installer

and the installation was successful with the acceptance of EULA in the terminal window.

I don't know if it helps.

Peter Chapa (pchapa) wrote :

I had a failed installation of Ubuntu restricted extras also. After that I was directed by Ubuntu error reporter to this site to report this bug. After reading all the above reports I tried using terminal to install ttf-mscorefonts-installer as suggested by #17 above and the window for the EULA appeared, however it would not allow me to "OK" the agreement using the mouse or keyboard.

Changed in msttcorefonts (Ubuntu):
status: Confirmed → Fix Released

I had an error:

error: ELF header smaller than expected.
grub rescue>

I did not know how this developed.... I turned on the laptop and suddenly it was there!

I could not get rid of it.... the laptop would not boot. I had to reburn a new DVD disc with

Ibuntu 13.04 from scratch and reload this into the laptop. It overwrote the corrupted boot up file.

I now have the fully functioning laptop again I hope?

Thank you.

Joel Wishengrad
Rockville, MD 20850
<email address hidden>

Tried installing PlayOnLinux on the daily live cd for Saucy Salamander and it failed to locate the package mscorefonts .

Brian Murray (brian-murray) wrote :

I believe the multiverse repository is disabled on Live CDs which would explain being unable to find msttcorefonts.

mauno peltonen (satsu323) wrote :

its ok.

Changed in msttcorefonts (Ubuntu):
assignee: nobody → Johnathan Nowacki (j-wacki24)
Bruce Lockert (bclockert) wrote :

Clicked on Ubuntu Software Center button, and issue gave boxes to click for sofware bug reporting. Then launchpad came up, and there was a bug fix, and clicked that link, and got to this page or fix.

Steve Lockett (schprocket) wrote :

Ubuntu 13.04

Launched PlayOnLinux from Ubuntu Software Center.
EULA appeared to install this module, after which an error-dialog was displayed.

As with #27, was directed to this page but I see no fix that doesn't require knowledge of Terminal. Will try workaround in #17.

General comment:
Whilst the fix in #17 is something that I can work with (beginner to intermediate wrt Linux in general), the fact that this seems to have been around since Ubuntu 10.04 I find mildly disappointing.

CLI fixes will confound new adopters of Linux if using Ubuntu, particularly as it is one of the two most touted distros to use: remember that most of these people will rarely have seen or used the command line in Windows.

Considering that PlayOnLinux is recommended to run, love it or hate it, iTunes in lieu of there being a native Linux iTunes app and that there would be a fair number of converts who have an iTunes account, I would have thought that solving this issue so that no CLI interaction is required would have been a priority to ease the pain of "Windows-separation" until such time as a Linux-native app is developed.

Steve Lockett (schprocket) wrote :

OK, now here's what happens using the fix in #17.

For some people - not sure how many - but the result will be the same as #18 - no apparent way to accept the EULA.

I went to Ubuntu Software Centre to install ttf-mscorefonts-installer from there (s-l-o-w compared to apt-get) only to find others had reported the same issue.

The fix for this is as follows:

"Thanks Stiles for the workaround.

Just a quick note, if you install the fonts using the command "sudo apt-get install ttf-mscorefonts-installer",

you have to press the TAB button to highlight "Ok" in order to accept the EULA through terminal..

Don't close out of terminal until you've done this."

When posting fixes, please try not to miss steps which are second nature to you or it'll add to the frustration level :)

Tom Hollis (thollis88) wrote :

not sure. only thing i did out of the ordinary is apply a wall paper for the first time(right hand click on image, set as desktop wall paper on firefox) . the error occurred just as i switched to the desktop.

Changed in msttcorefonts (Ubuntu):
assignee: Johnathan Nowacki (j-wacki24) → Emmanuel Yaw Frimpong (emmanuel225)
alcab (alexandre-cabrit) wrote :

Get same problem when trying to install Wine... (I know this could be bad ;_)

Giuseppe Pennisi (giupenni78) wrote :

Same problem tryng to install ubuntu-restricted-extras

Happened when installing steam

my wine is working well

On 24 October 2013 15:31, Tom Robinson <email address hidden> wrote:

> Happened when installing steam
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/921889
>
> Title:
> package ttf-mscorefonts-installer (not installed) failed to
> install/upgrade: subprocess new pre-installation script returned error
> exit status 128
>
> Status in “msttcorefonts” package in Ubuntu:
> Fix Released
>
> Bug description:
> It happens when i installed "play on linux" software.
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.04
> Package: ttf-mscorefonts-installer (not installed)
> ProcVersionSignature: Ubuntu 2.6.32-38.83-generic 2.6.32.52+drm33.21
> Uname: Linux 2.6.32-38-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> Date: Wed Jan 25 21:07:19 2012
> ErrorMessage: el subproceso script pre-installation nuevo devolvió el
> código de salida de error 128
> InstallationMedia: Ubuntu 10.04.3 LTS "Lucid Lynx" - Release amd64
> (20110720.1)
> SourcePackage: msttcorefonts
> Title: package ttf-mscorefonts-installer (not installed) failed to
> install/upgrade: el subproceso script pre-installation nuevo devolvió el
> código de salida de error 128
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/921889/+subscriptions
>

Eu quero jogar League of legends porem tf nao responde

Miller (wirelessmiller) wrote :

# 17 & #25 worked, but with the following deviation:

sudo apt-get -f install

This corrected a problem with packages with unmet dependencies:
wine1.4-i386 : Depends: wine1.4 (= 1.4.10ubuntu7) but is not going to be installed
recommends: libcap20-3 but it is not going to be installed
recommends: unixdbc but it is not going to be installed

All the .ttfs and other packages installed without a problem after entering the slight aforementioned modification.

I'm still not sure of the root cause, but the fix appears to have worked (everything loaded successfully).

Kyubutsu (jf) wrote :

ubuntu 13.10 3.11.0-14-generic x86_64
automatic crash report lead me here after login (restart required by updates).
i ran dpkg --configure -a, no issues found. then apt-get update/upgrade again, zero packages to upgrade, no issues found.
/shrugs

matt reischer (matt-reischer) wrote :

crashed because I switched from WiFi to wired internet connection during installation (plugged in ethernet then disabled the active WiFi connection).

Suggestion - more graceful handling of loss of or change of internet connection.

Marc Bourgoin (jagged-jimmy-j) wrote :

Heyyo,
Same error affects me. I was installing PlayOnLinux at the time it occured right off the Ubuntu Software Centre.

Ubuntu 14.04 alpha build from Jan 1 2014 with 3.12.0-7-generic kernel.

Joshua Rose (joshuarose84) wrote :

Thanks for the help! It is appriciated! Hope everything in your world is going well!

Ambrose (ambi-tas) on 2014-02-08
Changed in msttcorefonts (Ubuntu):
assignee: Emmanuel Yaw Frimpong (emmanuel225) → Ambrose (ambi-tas)

This error message popped up as I'd had just logged in to the system.

Fetra rfa (fettra3rfa) on 2014-03-28
Changed in msttcorefonts (Ubuntu):
assignee: Ambrose (ambi-tas) → Fetra rfa (fettra3rfa)
To post a comment you must log in.