Package needs to be Multi-Arch enabled so Multi-Arch packages can depend on it

Bug #905055 reported by Scott Ritchie on 2011-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cabextract (Debian)
Fix Released
Unknown
cabextract (Ubuntu)
Low
Unassigned
defoma (Ubuntu)
Low
Unassigned
msttcorefonts (Debian)
Fix Released
Unknown
msttcorefonts (Ubuntu)
Undecided
Scott Ritchie
xfonts-utils (Ubuntu)
Low
Unassigned

Bug Description

I was packaging a commercial application for the App store that depended on a font in this package. The package was binary, i386 only, and writing a dependency would cause apt to fail as ttf-mscorefonts-installer, while arch: all, is not multi-arch enabled and thus was treated as i386 and uninstallable on amd64.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ttf-mscorefonts-installer 3.3ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Thu Dec 15 10:52:01 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: msttcorefonts
UpgradeStatus: Upgraded to oneiric on 2011-09-13 (93 days ago)

Scott Ritchie (scottritchie) wrote :
tags: added: multi-arch
removed: multiarch
tags: added: multiarch
removed: multi-arch
Scott Ritchie (scottritchie) wrote :

Note that this package depends on wget, cabextract, xfonts-utils, defoma, and debconf. Debconf and wget are already M-A: foreign, however cabextract, xfonts-utils, and defoma are not (in Oneiric)

Steve Langasek (vorlon) wrote :

It's correct for each of cabextract, xfonts-utils, and defoma to be Multi-Arch: foreign, because each provides an architecture-independent executable interface. But there's no need for them to be tagged in order to fix this issue - *only* the ttf-mscorefonts-installer package needs to be tagged Multi-Arch: foreign, because it's the only package which is a direct dependency of the foreign-architecture package.

Scott Ritchie (scottritchie) wrote :

Actually, these other packages may not need to be M-A: foreign, only the immediate dependency needs to be, so we can reduce this bug to just ttf-mscorefonts-installer (and related packages that may be immediate dependencies of multiarch packages)

Changed in defoma (Ubuntu):
status: New → Invalid
Changed in cabextract (Ubuntu):
status: New → Invalid
Changed in xfonts-utils (Ubuntu):
status: New → Invalid
Scott Ritchie (scottritchie) wrote :

I'm reopening the cabextract task because winetricks, playonlinux, and some other non-arch-specific scripts depend on it.

Changed in cabextract (Ubuntu):
status: Invalid → Confirmed
Changed in msttcorefonts (Ubuntu):
status: New → In Progress
assignee: nobody → Scott Ritchie (scottritchie)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package msttcorefonts - 3.4ubuntu1

---------------
msttcorefonts (3.4ubuntu1) precise; urgency=low

  * Merge from Debian testing with help of MOM. Remaining changes:
    - Ubuntu preinst and postrm scripts have deltas
  * debian/control: Add Multi-Arch: foreign (LP: #905055)
 -- Scott Ritchie <email address hidden> Thu, 19 Jan 2012 00:47:02 -0800

Changed in msttcorefonts (Ubuntu):
status: In Progress → Fix Released
Scott Ritchie (scottritchie) wrote :

This is still a reasonable bug for defoma and xfonts-utils, even though there is no extant package depending on it yet, so I'm marking it low priority.

Changed in defoma (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
Changed in xfonts-utils (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
Changed in cabextract (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in msttcorefonts (Debian):
status: Unknown → New
Changed in msttcorefonts (Debian):
status: New → Fix Committed
Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package cabextract - 1.4-4

---------------
cabextract (1.4-4) unstable; urgency=low

  * Mark as multi-arch foreign: Closes: #700683

 -- Eric Sharkey <email address hidden> Sun, 17 Feb 2013 13:22:35 -0500

Changed in cabextract (Ubuntu):
status: Triaged → Fix Released
Changed in defoma (Ubuntu):
status: Triaged → Invalid
Jeremy Bicha (jbicha) wrote :

I'm closing the defoma task since defoma was removed from Debian last year since it's obsolete and will probably be removed from Ubuntu soon.

Changed in xfonts-utils (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) wrote :

 xfonts-utils (1:7.7~1) unstable; urgency=low

   * font-util 1.3.0
   * mkfontdir 1.0.7
   * mkfontscale 1.1.0
   * Drop dh_testroot from debian/rules clean.
   * Move fontutil.pc to /usr/share/pkgconfig.
   * Mark xfonts-utils Multi-arch: foreign.

Changed in msttcorefonts (Debian):
status: Fix Committed → Fix Released
Changed in cabextract (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.