Ubuntu

EULA not shown for Microsoft Fonts

Reported by Rick Spencer on 2010-11-03
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
msttcorefonts (Ubuntu)
Medium
Michael Vogt
Lucid
Medium
Michael Vogt
Maverick
High
Michael Vogt

Bug Description

Binary package hint: ubuntu-restricted-extras

When installing Ubuntu-Restricted-Extras, the user never has a chance to see the EULA that comes with the Microsoft Fonts. Can this be fixed in the package?

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: ubuntu-restricted-extras 42
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Wed Nov 3 14:03:26 2010
Dependencies: ubuntu-restricted-addons 4
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: ubuntu-restricted-extras

Changed in ubuntu-restricted-extras (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → Medium
milestone: none → natty-alpha-1
tags: removed: maverick ubuntu-une
Michael Vogt (mvo) wrote :

Thanks for the bugreprt, I work on this now.

Michael Vogt (mvo) on 2010-11-04
affects: ubuntu-restricted-extras (Ubuntu) → msttcorefonts (Ubuntu)
Changed in msttcorefonts (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package msttcorefonts - 3.3ubuntu1

---------------
msttcorefonts (3.3ubuntu1) natty; urgency=low

  * display the EULA for the fonts when installing the
    package (LP: #670629)
 -- Michael Vogt <email address hidden> Thu, 04 Nov 2010 21:52:26 +0100

Changed in msttcorefonts (Ubuntu):
status: In Progress → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

Please fail silently and do not trigger an error when the user refuses the UELA otherwise we will receive tons of reports of people refusing it.

With the current package the result is:
----
user did not accept the mscorefonts-eula license
dpkg: error processing /var/cache/apt/archives/ttf-mscorefonts-installer_3.3ubuntu1_all.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/ttf-mscorefonts-installer_3.3ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
----

Mantas Kriaučiūnas (mantas) wrote :

I've noticed, that mscorefonts are available packaged in deb package too, see ttf-microsoft-corefonts package:

http://archive.debian-maintainers.org/unofficial/packages/microsoft-corefonts/
https://launchpad.net/~ivan1986/+archive/ppa/+packages

It seems font license remains the same, I'm not sure if this license allows to distribute the fonts not only in original compressed cab archive (.exe) form, but also in other forms, like tar and deb packages - look at license file in ttf-microsoft-corefonts package above...

Changed in msttcorefonts (Ubuntu Lucid):
assignee: nobody → Michael Vogt (mvo)
Changed in msttcorefonts (Ubuntu Maverick):
assignee: nobody → Michael Vogt (mvo)
Changed in msttcorefonts (Ubuntu Lucid):
importance: Undecided → Medium
Changed in msttcorefonts (Ubuntu Maverick):
importance: Undecided → Medium

@mvo - apparently getting this fixed in 10.10 is a priority, so I upped the importance for it there.

Changed in msttcorefonts (Ubuntu Maverick):
importance: Medium → High
Michael Vogt (mvo) on 2010-11-18
Changed in msttcorefonts (Ubuntu Maverick):
status: New → In Progress

Accepted msttcorefonts into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in msttcorefonts (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
Michael Vogt (mvo) on 2010-11-25
Changed in msttcorefonts (Ubuntu Lucid):
status: New → In Progress
Dmitry Shachnev (mitya57) wrote :

I saw the EULA on the latest Wine update.

tags: added: verification-done
removed: i386 verification-needed
Michael Vogt (mvo) wrote :

Uploaded to lucid-proposed now as well.

Changed in msttcorefonts (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package msttcorefonts - 3.2ubuntu2

---------------
msttcorefonts (3.2ubuntu2) maverick-proposed; urgency=low

  * change EULA display so that on refusal fonts are removed
  * do not fails the install if the EULA is not accepted, but instead
    do not download the fonts (LP: #670629)
 -- Michael Vogt <email address hidden> Thu, 25 Nov 2010 18:43:26 +0100

Changed in msttcorefonts (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Accepted msttcorefonts into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Martin Pitt (pitti) wrote :

FAILED: msttcorefonts (The source msttcorefonts - 3.2ubuntu1 is already accepted in ubuntu/maverick and you cannot upload the same version within the same distribution. You have to modify the source version and re-upload.)

I suggest using ubuntu0.1 for lucid.

Changed in msttcorefonts (Ubuntu Lucid):
status: Fix Committed → In Progress
tags: removed: verification-needed
Martin Pitt (pitti) wrote :

Accepted msttcorefonts into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in msttcorefonts (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Bruno Clermont (b.clermont) wrote :

This bug fix broke this package, I have this host I install with a debconf frontend non-interactive:

Unpacking ttf-mscorefonts-installer (from .../ttf-mscorefonts-installer_3.2ubuntu0.1_all.deb) ...
mscorefonts-eula license could not be presented
try 'dpkg-reconfigure debconf' to select a frontend other than noninteractive

Good, I did not accept the license, then at postinst step:
in package postinst script, the following code is running:

FONTDIR=/usr/share/fonts/truetype/msttcorefonts
license=mscorefonts-eula
db_get msttcorefonts/accepted-$license
if [ "$RET" != "true" ]; then
    echo "user did not accept the $license license" >&2
    rm -f $FONTDIR/*.ttf
    cat > $FONTDIR/README <<EOF
License refused.
[snip]
EOF
    exit 0
else
    rm -f $FONTDIR/README
fi

But, on a clean installation, without any trace of ttf-mscorefonts-installer before, there is no folder /usr/share/fonts/truetype/msttcorefonts yet, it's created later in postinst script, if license is approved.
this cause cat to fail :

Setting up ttf-mscorefonts-installer (3.2ubuntu0.1) ...
user did not accept the mscorefonts-eula license
/var/lib/dpkg/info/ttf-mscorefonts-installer.postinst: 36: cannot create /usr/share/fonts/truetype/msttcorefonts/README: Directory nonexistent
dpkg: error processing ttf-mscorefonts-installer (--configure):
 subprocess installed post-installation script returned error exit status 2

maybe with something like this:

if [ "$RET" != "true" ]; then
    if [ -d $FONTDIR ]; then
        rm -f $FONTDIR/*.ttf
        cat > $FONTDIR/README <<EOF

or the folder /usr/share/fonts/truetype/msttcorefonts should be in debian/dirs

Martin Pitt (pitti) wrote :

Thanks for testing! Michael, can you please look at this?

tags: added: verification-failed
removed: verification-needed
Changed in msttcorefonts (Ubuntu Lucid):
status: Fix Committed → In Progress
Otus (jan-varho) wrote :

I got an EULA prompt on upgrade. I see no point in showing it at all, since many other things in restricted extras have similar terms, but don't prompt. However, prompting on upgrade seems especially pointless, since it's been agreed to already. Was it intentional?

We are being asked to show this by the provider and Jane Silber has
approved it. Please ensure that this is included.

Thanks

Amanda

Amanda Brock, General Counsel
Canonical
27 Floor, Millbank Tower
London SW1P 4QP
+44 2076302446
+44 7809389878
Ubuntu - Linux for Human Beings
www.canonical.com

On 19/12/10 14:41, Otus wrote:
> I got an EULA prompt on upgrade. I see no point in showing it at all,
> since many other things in restricted extras have similar terms, but
> don't prompt. However, prompting on upgrade seems especially pointless,
> since it's been agreed to already. Was it intentional?
>

@Otus,

Thank you for your bug report. I'm not 100% what behavior you are reporting, would you please clarify.

Are you say that you already saw the EULA screen and accepted it in a previous release, and now that you're upgrading, you are seeing it second time?

Previously, the EULA screen was not showing, but should have. So, in fact, users have not already had a chance to see and accept or reject the EULA, which is what this bug fix is supposed to fix.

Amanda Brock (amanda-brock) wrote :

Hi there

My comment was in response to the comment implying no need to fix this -
we need to fix it. I have not seen the click through or EULA.

Amanda

Amanda Brock, General Counsel
Canonical
27 Floor, Millbank Tower
London SW1P 4QP
+44 2076302446
+44 7809389878
Ubuntu - Linux for Human Beings
www.canonical.com

On 20/12/10 02:37, Rick Spencer wrote:
> @Otus,
>
> Thank you for your bug report. I'm not 100% what behavior you are
> reporting, would you please clarify.
>
> Are you say that you already saw the EULA screen and accepted it in a
> previous release, and now that you're upgrading, you are seeing it
> second time?
>
> Previously, the EULA screen was not showing, but should have. So, in
> fact, users have not already had a chance to see and accept or reject
> the EULA, which is what this bug fix is supposed to fix.
>

@Amanda,

I don't think anyone was implying that we shouldn't show the EULA. I believe the bug comment you are referring to was asking why we would shoe the EULA on *upgrade* as the user would have already accepted the EULA when the fonts were installed.

We need to ascertain if the EULA is being continually shown after it has been accepted, because that would, indeed, be a bug.

Martin Pitt (pitti) wrote :

Michael says he confirmed that we need to show the EULA on upgrades as well (once).

tags: added: verification-done
removed: verification-failed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package msttcorefonts - 3.2ubuntu0.1

---------------
msttcorefonts (3.2ubuntu0.1) lucid-proposed; urgency=low

  * Display the EULA for the fonts when installing the package. Do not
    fails the install if the EULA is not accepted, but instead do not
    download the fonts (LP: #670629)
 -- Michael Vogt <email address hidden> Fri, 03 Dec 2010 18:08:16 +0100

Changed in msttcorefonts (Ubuntu Lucid):
status: In Progress → Fix Released
hazelsct (hazelsct) wrote :

Just got the fix in lucid using update-manager. Unfortunately, I accidentally didn't accept the EULA in the GNOME debconf front-end.

Trouble is, dpkg-reconfigugre would *not* let me accept the EULA to correct my mistake! I had to apt-get install --reinstall the package, which presented me with the opportunity again, and I accepted it, and it worked.

I think this is a bug: dpkg-reconfigure should allow one to accept the EULA.

-Adam

Amanda Brock (amanda-brock) wrote :

I have had a problem with this too.

It might be simpler to just have an "I accept" tick box? At the moment
we seem to be getting stuck in the process?

Thanks

Amanda
On 26/01/11 14:44, hazelsct wrote:
> Just got the fix in lucid using update-manager. Unfortunately, I
> accidentally didn't accept the EULA in the GNOME debconf front-end.
>
> Trouble is, dpkg-reconfigugre would *not* let me accept the EULA to
> correct my mistake! I had to apt-get install --reinstall the package,
> which presented me with the opportunity again, and I accepted it, and it
> worked.
>
> I think this is a bug: dpkg-reconfigure should allow one to accept the
> EULA.
>
> -Adam
>

pt123 (pt123) wrote :

Me too, accepting the EULA was not clear.

Ended up losing all the MS fonts which affected the rendering of most websites.

Had to to reinstall it again.

Louis Marascio (marascio) wrote :

This fix appears to break non-interactive upgrades. I have the same problem as Bruno from above (https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/670629/comments/14). Manually creating the directory he mentions before running the non-interactive install keeps it from erroring out; however, it should handle this more gracefully.

Louis Marascio (marascio) wrote :

I take that back. I had to build a dummy package to automate this properly. Please fix.

I'm so confuse...

Changed in msttcorefonts (Ubuntu):
assignee: Michael Vogt (mvo) → ragas prihatmaja (ragasprihatmaja)
Steve Langasek (vorlon) on 2011-01-29
Changed in msttcorefonts (Ubuntu):
assignee: ragas prihatmaja (ragasprihatmaja) → Michael Vogt (mvo)
Changed in baltix:
status: New → Fix Released
Jonathan Reed (jdreed) wrote :

We encountered the same thing Bruno saw in comment #14. It was consistently reproducible on Natty when leaving tasksel blank (that is, only installing "standard"), but running a postinstall script that, among other things, pulls in fontconfig and ttf-msttcorefonts-installer in the same aptitude transaction (a metapackage which depends on both of those and a ton of other things. The problem is actually a poor interaction between those two packages. Two of my colleagues tracked it down:
1) Both packages are unpacked. Since it's part of ttf-mscorefonts-installer, /usr/share/fonts/truetype/msttcorefonts is created and exists.
2) fontconfig is configured first. fontconfig's postinst "helpfully" "cleans up" empty all subdirectories under /usr/share/fonts when it's upgrading from pre-2.4.0-1 (and since "" sorts earlier, it's triggered on a fresh install)
3) ttf-msttcorefonts-installer is now configured, and attempts to write the README to a nonexistent directory.

Arguably, fontconfig's conditional is wrong and should use "lt-nl", however msttcorefonts could also fix this by "mkdir -p" before writing the README file. Bugs will be filed for these issues, but I wanted to leave this comment here in case anyone encounters this in a Google search and wants to know what the hell is going on.

Geoffrey Thomas (geofft) wrote :

I filed the following bugs about the fontconfig issue:
http://bugs.debian.org/636173
https://bugs.launchpad.net/bugs/819097

I'm attaching a debdiff that creates /usr/share/fonts/truetype/msttcorefonts in the postinst (unconditionally) instead of using debian/dirs for this. I've tested that this package installs fine whether or not I accept the license.

This change seems safe enough to go into natty-updates, but getting it into oneiric would be a good start.

Geoffrey Thomas (geofft) wrote :

I guess I can't reopen a "Fix released" bug, and in any case a new bug report seems better, so I've attached that debdiff to a new bug #819106.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers