The installer should use system proxy settings.

Bug #56880 reported by Burt on 2006-08-19
88
This bug affects 8 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
Low
Marc Deslauriers
Natty
Low
Marc Deslauriers

Bug Description

Binary package hint: msttcorefonts

This package connects to the internet to retrieve the fonts. However it ignores the proxy in /etc/apt/apt.conf and therefor can not retrieve the fonts through a proxy. This is for Edgy

Update: This issue occours for Hardy too.

Burt (albertus-wilson) on 2006-08-19
description: updated
Changed in msttcorefonts:
importance: Untriaged → Low
Hugh Parker (hcp) wrote :

I'm also behind a proxy, and I got the same problem. As suggested in
http://ubuntuforums.org/archive/index.php/t-75413.html
I changed /etc/wgetrc to include these lines:

http_proxy = http://eduproxy.bgfl.org:80/
use_proxy = on

Synaptic's terminal window now includes this line:

Resolving [myproxy]... failed: Connection timed out.

The same wget line works fine outside synaptic.

Thijs Kinkhorst (kink) wrote :

msttcorefonts does not use apt's proxy settings because the fonts are downloaded separately in the postinst. Use the debconf question about http_proxy that was added by Ubuntu to specify a proxy, or set the http_proxy environment variable.

Hugh Parker (hcp) wrote :

I've just checked: the http_proxy environment variable is set. the msstcorefonts install mechanism seems to ignore it.

David Morris (dave-greenacre) wrote :

I've created a patch to use the apt proxy if its set.

Thijs Kinkhorst (kink) wrote :

Thanks. A problem with the patch is that it doesn't seem to deal with /etc/apt/apt.conf.d/*.

Isn't there a way to "ask" apt what its proxy is?

Thijs Kinkhorst (kink) wrote :

Hugh Parker: are you using sudo or are you actually logged in as root during the install?

Hugh Parker (hcp) wrote :

I'm not logged in as root. I'm using synaptic, which I must mean I'm sudo'd in.

Noe Nieto (tzicatl) wrote :

This is exactly the same beavior we find in flashplugin-nonfree:

https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/45722

Roni (ronibalthazar) on 2008-05-14
description: updated
Changed in msttcorefonts:
status: New → Confirmed

This is not yet solved in Intrepid Ibex. Sad to see. Guys, this bug is more than 2 and a half years old! I'm really disappointed now.

David Robert Lewis (afrodeity) wrote :

An extremely irritating bug that appears to be getting worse. I now find myself in exactly the same situation I was in about three or four months ago. I can't get the bloody msstcorefonts because of the proxy issue and I keep getting them half-installed whenever I try to install something else, and can't seem to purge them. My WINE has also stopped working due to a font issue that resolves down to the msstcorefonts. Why is this still a bug with no workaround?

If you are still on INtrepid 8.10 I think most simple solution is to update
on Jaunty 9.04. On my PC it solved it.
Greetings
Kenan

2009/5/23 afrodeity <email address hidden>

> An extremely irritating bug that appears to be getting worse. I now find
> myself in exactly the same situation I was in about three or four months
> ago. I can't get the bloody msstcorefonts because of the proxy issue and
> I keep getting them half-installed whenever I try to install something
> else, and can't seem to purge them. My WINE has also stopped working due
> to a font issue that resolves down to the msstcorefonts. Why is this
> still a bug with no workaround?
>
> --
> Not working with proxy
> https://bugs.launchpad.net/bugs/56880
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “msttcorefonts” source package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: msttcorefonts
>
> This package connects to the internet to retrieve the fonts. However it
> ignores the proxy in /etc/apt/apt.conf and therefor can not retrieve the
> fonts through a proxy. This is for Edgy
>
> Update: This issue occours for Hardy too.
>

I found the fix for this, works like magic.

sudo dpkg-reconfigure --force msttcorefonts

brings up a nice graphical screen that guides you through the problem. Wish I had this weeks ago. Anyway, now all I have to do is figure out how to do the same for freetype so I can get Wine working again.

Burt (albertus-wilson) wrote :

I can also confirm that this bug has been fixed for Jaunty 9.04. The output shows the use of the proxy that is used to retrieve the fonts. Thanks guys.

MilchFlasche (robertus0617) wrote :

I own my thanks to David Robert Lewis at #12. After executing

sudo dpkg-reconfigure --force msttcorefonts

the interactive interface (I'm not sure if it's graphical yet) guides well, including asking for a customized mirror. Since I found the problem is with the default mirror of my country is not working (changing to another mirror on Sourceforge.net enables downloading well), I have found that typing a custom mirror may bring the font installer to life, for example:
http://nchc.dl.sourceforge.net/project/corefonts/the%20fonts/final/

Then msttcorefonts installer will be able to locate the files, and extracts and installs well.

So I figure that such bugs (there has been a whole bunch around this package on Launchpad...) may be related to proxy settings, but may also be due to invalid Sourceforge mirror (frustrating...). So, just change to another valid mirror. Guys, why not give it a try.

Thelasko (stever530) wrote :

Apparently this bug still occurs in Karmic, which frankly is disgraceful. How could such a simple bug go for so long without being fixed!

Dont know if I can respond to this but ill give it a try.
The main issue with this explanation is that I wasnt running a proxy. Got
any other ideas?

On Fri, Oct 30, 2009 at 7:57 AM, Thelasko <email address hidden> wrote:

> Apparently this bug still occurs in Karmic, which frankly is
> disgraceful. How could such a simple bug go for so long without being
> fixed!
>
> --
> Not working with proxy
> https://bugs.launchpad.net/bugs/56880
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “msttcorefonts” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: msttcorefonts
>
> This package connects to the internet to retrieve the fonts. However it
> ignores the proxy in /etc/apt/apt.conf and therefor can not retrieve the
> fonts through a proxy. This is for Edgy
>
> Update: This issue occours for Hardy too.
>

--
Live today like you'll die tomorrow!

The core problem of this bug is probably in wget, see Bug #232469

summary: - Not working with proxy
+ The installer should use system proxy settings.
adhi (adrat-smiles) on 2010-02-16
Changed in msttcorefonts (Ubuntu):
status: Confirmed → Fix Released

On 16 February 2010 07:59, adhi <email address hidden> wrote:
> ** Changed in: msttcorefonts (Ubuntu)
>       Status: Confirmed => Fix Released

Are you sure this bug is fixed?
--
## Przemysław Kulczycki <<=>> Azrael Nightwalker ##
# Jabber/XMPP/Gtalk/Tlen ID: azrael[na]jabster.pl #
# (Co to jest? Zobacz na: http://jabberfaq.info ) #
## www: http://reksio.ftj.agh.edu.pl/~azrael/ #####

Changed in msttcorefonts (Ubuntu):
status: Fix Released → Confirmed

@adhi: please don't change statuses without leaving a comment. It is not fixed, the package uses it's own proxy settings.

Changed in msttcorefonts (Ubuntu):
status: Confirmed → Triaged
tags: added: patch
Geoff Williams (gjsw) wrote :

I had this problem today with 10.04. The root cause is that environment variables such as http_proxy are not preserved when you use sudo. As a workaround you can get a root shell with:

sudo bash

Then set http_proxy to what it should be:

export http_proxy=http://user:<email address hidden>:8080

Then you can do apt-get install or dpkg --configure -a if you had to manually kill the previous install

HTH

@Geoff Williams : Thanks, worked beautifully. :-)

Hugh Parker (hcp) wrote :

This bug is going to prevent any school from using Ubuntu linux, since any school will need these fonts, and no school will allow un-filtered web access. Its importance needs to be changed from "low".

Jan Claeys (janc) wrote :

Hugh Parker: most schools have sysadmins that know how to set environment variables for the system, so it won't really prevent schools from using Ubuntu. (Neither will the lack of those fonts, really.)

That doesn't mean it shouldn't get fixed somehow though...

I wonder if it would be possible to store the proxy config in NetworkManager and have NM change it system-wide (it could e.g. remember the proxy setting related to the wifi network you connect to)?

Hugh Parker (hcp) wrote :

Jan Claeys: I am a sysadmin at a school, and I have set the enviroment variables. The nature of this bug is that the package management system doesn't correctly use the environment's proxy setting.

Most primary schools don't have sysadmins and some secondaries don't.

Most schools considering migrating won't go much further than an intial trial if their first experiments show them that they can't use their familiar fonts, or youtube, etc. The existence of googlable kludges is not a good solution to bug 1.

Changed in msttcorefonts (Ubuntu Lucid):
status: New → Triaged
Changed in msttcorefonts (Ubuntu Natty):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in msttcorefonts (Ubuntu Maverick):
status: New → Triaged
Changed in msttcorefonts (Ubuntu Lucid):
importance: Undecided → Low
Changed in msttcorefonts (Ubuntu Maverick):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package msttcorefonts - 3.3ubuntu2

---------------
msttcorefonts (3.3ubuntu2) natty; urgency=low

  * update-ms-fonts: make wget use the proxy defined for apt (LP: #56880)
 -- Marc Deslauriers <email address hidden> Fri, 19 Nov 2010 16:44:56 -0500

Changed in msttcorefonts (Ubuntu Natty):
status: Triaged → Fix Released
Ruben (info-rubenfelix) wrote :

Hey!

Bedankt voor je mail! Ik ben er even tussenuit geknepen naar een lekker warm land! Ik beantwoord je mail na mijn vakantie (11 oktober).

Groetjes!

Ruben

Rolf Leggewie (r0lf) on 2011-10-02
tags: added: patch-needswork
removed: patch
Adolfo Jayme (fitojb) on 2013-05-17
no longer affects: msttcorefonts (Ubuntu Lucid)
no longer affects: msttcorefonts (Ubuntu Maverick)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments