Ubuntu

msttcorefonts lacks the 'Tahoma' font

Reported by Conrad Knauer on 2006-06-21
82
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Baltix
Low
Mantas Kriaučiūnas
msttcorefonts (Debian)
Fix Released
Unknown
msttcorefonts (Ubuntu)
Wishlist
Unassigned
Declined for Dapper by Scott Ritchie
Declined for Edgy by Luca Falavigna
Nominated for Feisty by Troy Hoshor
Declined for Gutsy by Luca Falavigna
Nominated for Hardy by Troy Hoshor
Nominated for Intrepid by r12056
Nominated for Jaunty by r12056
Nominated for Karmic by Ruslan Rudenko
Nominated for Lucid by r12056

Bug Description

According to http://corefonts.sourceforge.net/ as of April 30, 2006 there was "A long awaited overhaul. Many things are fixed, links updated. Selects a random mirror. Uses tahoma from word 97 viewer instead of the ie6 update so no windows license is needed."

I have downloaded the word 97 viewer in question (e.g. from http://dl.sourceforge.net/sourceforge/corefonts/wd97vwr32.exe) and then extracted it with these commands, only slightly altered from the sourceforge version of msttcorefonts:

cabextract --lowercase --directory=cab-contents wd97vwr32.exe

cabextract --lowercase --directory=cab-contents cab-contents/viewer1.cab

The EULA (see license.txt) states in part:

---
This EULA grants you the following rights:

- Installation and Use. You may install and use an unlimited number of

copies of the SOFTWARE PRODUCT.

- Reproduction and Distribution. You may reproduce and distribute an

unlimited number of copies of the SOFTWARE PRODUCT; provided that each

copy shall be a true and complete copy, including all copyright and

trademark notices, and shall be accompanied by a copy of this EULA. Copies

of the SOFTWARE PRODUCT may be distributed as a standalone product or

included with your own product.
---

Thus the Tahoma font, now being available from a package of nearly identical licensing as the others, should be added back to the files downloaded by msttcorefonts. Please set this as a "whishlist" type bug if approved.

this is debian bug #380294 (http://bugs.debian.org/380294). i have made a patch (awaiting review by the package maintainer), which is available there and directly applicable to the ubuntu package.

mike

Gert Kulyk (gkulyk) wrote :

If the license permitts it (I don't know if debian-legal team would see a problem or not), it would be nice to have the font.

Changed in msttcorefonts:
status: Unconfirmed → Confirmed
Dan Roberts (ademan555) wrote :

Wine users would appreciate this especially. A lot of wine users use it for videogames, generally half life related, which generally implies Steam, which requires the tahoma font. (I've heard mixed stories about "substituting" fonts, some say it causes crashes, don't know why, but i'm personally about to try it out)

cheers
-Dan

Conrad Knauer (atheoi) wrote :

I added a comment to the Debian bug two months ago and there hasn't been any reply to my suggestion so I'm going to repeat it here in the hopes that it will be an addition to Feisty that can be sent back to Debian if they want it:

---
From: "Conrad Knauer" <email address hidden>
To: <email address hidden>
Subject: msttcorefonts-tahoma?
Date: Sat, 28 Oct 2006 10:52:53 -0600

On 14 Oct 2006 Thijs Kinkhorst <email address hidden> wrote:

"My problem with this patch specifically is that it codes a special
exception for that font, and that the package for that font is more than 10 times (!) larger than the average sizes of the others."

Would it solve the problem to spin this off to a new package, say
msttcorefonts-tahoma, and have it recommended by msttcorefonts?

CK
---

Przemysław Kulczycki (azrael) wrote :

Feisty's got released and this bug is still not fixed.

Also maybe the new Vista fonts could be included somehow? They can be downloaded for free with PowerPoint Viewer 2007 and used without Windows (EULA permits it).
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=048dc840-14e1-467d-8dca-19d2a8fd7485

Conrad Knauer (atheoi) wrote :
Download full text (6.6 KiB)

Przemysław Kulczycki: the software you linked to has some nice fonts, but if you read the EULA closely, it does not appear to permit use of the TTF files in the way we want:

"You may use the software only to view and print files created with Microsoft Office software. You may not use the software for any other purpose." Also, "You may not [...] distribute the software with any non-Microsoft software that may use the software to enhance its functionality,"

Sorry :(

Here's the full EULA:

---
MICROSOFT SOFTWARE LICENSE TERMS

MICROSOFT OFFICE VIEWER 2007

These license terms are an agreement between Microsoft Corporation (or based on where you live, one of its affiliates) and you. Please read them. They apply to the software named above, which includes the media on which you received it, if any. The terms also apply to any Microsoft

• updates,

• supplements,

• Internet-based services, and

• support services

for this software, unless other terms accompany those items. If so, those terms apply.

BY USING THE SOFTWARE, YOU ACCEPT THESE TERMS. IF YOU DO NOT ACCEPT THEM, DO NOT USE THE SOFTWARE.

If you comply with these license terms, you have the rights below.

1. INSTALLATION AND USE RIGHTS.

a. General. You may install and use any number of copies of the software on your devices. You may use the software only to view and print files created with Microsoft Office software. You may not use the software for any other purpose.

b. Distribution. You may copy and distribute the software, provided that:

• each copy is complete and unmodified, including presentation of this agreement for each user's acceptance; and

• you indemnify, defend, and hold harmless Microsoft and its affiliates and suppliers from any claims, including attorneys’ fees, related to your distribution of the software.

You may not:

• distribute the software with any non-Microsoft software that may use the software to enhance its functionality,

• alter any copyright, trademark or patent notices in the software,

• use Microsoft’s or affiliates or suppliers’ name, logo or trademarks to market your products or services,

• distribute the software with malicious, deceptive or unlawful programs, or

• modify or distribute the software so that any part of it becomes subject to an Excluded License. An Excluded License is one that requires, as a condition of use, modification or distribution, that

• the code be disclosed or distributed in source code form; or

• others have the right to modify it.

2. SCOPE OF LICENSE. The software is licensed, not sold. This agreement only gives you some rights to use the software. Microsoft reserves all other rights. Unless applicable law gives you more rights despite this limitation, you may use the software only as expressly permitted in this agreement. In doing so, you must comply with any technical limitations in the software that only allow you to use it in certain ways. You may not

• work around any technical limitations in the software;

• reverse engineer, decompile or disassemble the software, except and only to the extent that applicable law expressly permits, despite this limitation;

• make more copies of...

Read more...

Przemysław Kulczycki (azrael) wrote :

There is an Arch Linux package that uses Microsoft Office Compatibility Pack for Word, Excel, and PowerPoint 2007 File Formats instead of PowerPoint Viewer, but in the comments I can see that the problem with it is pretty same.
http://aur.archlinux.org/packages.php?do_Details=1&ID=8475

Changed in msttcorefonts:
status: Unknown → Fix Committed
Conrad Knauer (atheoi) wrote :
Download full text (6.0 KiB)

I just downloaded the Compatibility Pack and it seems its EULA has provisions specifically aimed against projects like msttcorefonts:

"4. FONT COMPONENTS. You may use the fonts that accompany this software only to display and print content from a device running a Microsoft Windows operating system. Additionally, you may only

• embed fonts in content as permitted by the embedding restrictions in the fonts; and

• when printing content, temporarily download them to a printer or other output device.

You may not copy, install or use the fonts on other devices."

The TTF files are identical to the other one BTW.

Here's the full EULA:

---
MICROSOFT SOFTWARE LICENSE TERMS

MICROSOFT OFFICE COMPATIBILITY PACK FOR WORD, EXCEL, AND POWERPOINT 2007 FILE FORMATS

These license terms are an agreement between Microsoft Corporation (or based on where you live, one of its affiliates) and you. Please read them. They apply to the software named above, which includes the media on which you received it, if any. The terms also apply to any Microsoft

• updates,

• supplements,

• Internet-based services, and

• support services

for this software, unless other terms accompany those items. If so, those terms apply.

BY USING THE SOFTWARE, YOU ACCEPT THESE TERMS. IF YOU DO NOT ACCEPT THEM, DO NOT USE THE SOFTWARE.

If you comply with these license terms, you have the rights below.

1. INSTALLATION AND USE RIGHTS. You may install and use any number of copies of the software on your devices.

2. SCOPE OF LICENSE. The software is licensed, not sold. This agreement only gives you some rights to use the software. Microsoft reserves all other rights. Unless applicable law gives you more rights despite this limitation, you may use the software only as expressly permitted in this agreement. In doing so, you must comply with any technical limitations in the software that only allow you to use it in certain ways. You may not

• work around any technical limitations in the software;

• reverse engineer, decompile or disassemble the software, except and only to the extent that applicable law expressly permits, despite this limitation;

• make more copies of the software than specified in this agreement or allowed by applicable law, despite this limitation;

• publish the software for others to copy;

• rent, lease or lend the software;

• transfer the software or this agreement to any third party; or

• use the software for commercial software hosting services.

3. BACKUP COPY. You may make one backup copy of the software. You may use it only to reinstall the software.

4. FONT COMPONENTS. You may use the fonts that accompany this software only to display and print content from a device running a Microsoft Windows operating system. Additionally, you may only

• embed fonts in content as permitted by the embedding restrictions in the fonts; and

• when printing content, temporarily download them to a printer or other output device.

You may not copy, install or use the fonts on other devices.

5. DOCUMENTATION. Any person that has valid access to your computer or internal network may copy and use the documentation for your internal, reference purposes....

Read more...

Changed in msttcorefonts:
status: Fix Committed → Fix Released
Conrad Knauer (atheoi) wrote :

Ooo... the new Debian package (2.0) which installs Tahoma works perfectly in Feisty. You can get a copy from the link on http://packages.debian.org/unstable/x11/msttcorefonts

I've posted on the forums (http://ubuntuforums.org/showthread.php?t=431063) to let people know.

Thijs Kinkhorst (kink) wrote :

The addition of Tahoma has been reverted again in 2.1. The problem was that Tahoma did not include a bold variant, and this causes far more problems than the availability of Tahoma solves.

Scott Ritchie (scottritchie) wrote :

What sort of problems? Even having a very stupid "bold" that didn't make any changes would be better, since at this point the main purpose of this font is to allow users to run Steam in Wine.

If Tahoma can't be put into the msttcorefonts package, then we'll have to put it somewhere else. Either way, it needs to be packaged.

Conrad Knauer (atheoi) wrote :

Scott Ritchie: what do you think of my idea for creating a "msttcorefonts-tahoma" package?

Scott Ritchie (scottritchie) wrote :

It's a fine idea, actually.

Thijs Kinkhorst (kink) wrote :

Scott Ritchie: there were al kinds of problems with ugly fonts being filled in into the Tahoma-Bold font, e.g. in web browsers, creating ugly pages. The problem is that installing a font will have a system wide impact, so you can't package it just for Steam and not use it in e.g. Firefox.

A separate package could be possible but it's still quite a hack. The problems with the webpages would resurface on systems where you would install that package.
Is there no way to fix Steam?

Tahoma still missing from Gutsy. It seems puzzling to me that Tahoma bold is unavailable. An alternative hack would be that msttcorefonts should try to pull in the fonts from the Windows partition, if there is one present.

Scott Ritchie (scottritchie) wrote :

The latest Wine, 0.9.47 (not yet in Ubuntu) includes a Tahoma replacement font of its own. Perhaps this is the way forward.

Fred (eldmannen+launchpad) wrote :

I am using Ubuntu 7.10 Gutsy Gibbon.
I would like to have Tahoma font too...

Fred (eldmannen+launchpad) wrote :

Can someone make an unofficial external third-party repository, so I can add it like;
* wget -q http://www.example.com/apt/387EE263.gpg -O- | sudo apt-key add -
* sudo wget http://www.example.com/apt/sources.list.d/gutsy.list -O /etc/apt/sources.list.d/tahoma.list
* sudo apt-get install tahoma

So, that I can install Tahoma on my computer?
Please, I need it!

Fred (eldmannen+launchpad) wrote :

Debian fixed this, so I want Ubuntu to fix this too!

exactt (giesbert) wrote :

https://launchpad.net/ubuntu/+source/msttcorefonts/ states for version 2.2 of msttcorefonts: "* Also deregister the removed Tahoma with defoma (Closes: #425228)."

any information why the font has been removed again?

From https://launchpad.net/ubuntu/gutsy/+source/msttcorefonts/2.2:

* Drop Tahoma font introduced in 2.0. Since it lacks a bold counterpart,
    it causes more trouble than it solves (Closes: #424852, #424864).

maybe life could be made easier for those who have the font available anyway?

a msttfonts-support package would supply just the defoma hint files for the windows fonts and a command to copy and install the font files.

if users have mounted there windows partitions this could be done automatically via
 locate .ttf | grep -i <font> | grep -v /usr/share/wine
and choosing the most appropriate font files for copying.
The user has to be informed when doing this, as he has to remove the files, if he quits his windows license.

Candidates are Wingding* and of course Tahoma.

Lennart (lennartackermans) wrote :

There's no Tahoma bold??? In my VirtualBox Windows installation is a Tahoma bold and it works perfectly on Ubuntu. It is a shame that this font isn't available in msttcorefonts since it is the very best font when using as application font.

Conrad Knauer (atheoi) wrote :

Lennart: The problem is that the Tahoma set (tahoma.ttf and tahomabd.ttf) was not part of Microsoft's "TrueType core fonts for the Web" (see http://web.archive.org/web/20020802092546/http://www.microsoft.com/truetype/fontpack/win.htm for what the site looked like six years ago before it was "discontinued"). The latter were nicely redistributable as per the licenses they contain. The former can easily be found on http://support.microsoft.com/kb/188081 as the link to "Tahoma32.exe" BUT if you run that exe, you are presented with a license that is not so nice for us; it reads in part:

"You may install and use one copy of the SOFTWARE on a single computer which is running a validly licensed copy of Microsoft Office, or any standalone software application that is part of Microsoft Office. [...] Copies of the SOFTWARE may not be distributed on a standalone basis or included as part of your own product."

The best that they could find was the Word 97 viewer which IS redistributable, but only contains tahoma.ttf

If you can find a source for tahomabd.ttf that is redistributable and not overly restrictive, please let us know! :-)

Conrad Knauer (atheoi) wrote :

I wrote: "If you can find a source for tahomabd.ttf that is redistributable and not overly restrictive, please let us know! :-)"

I sent a message to the contact e-mail on http://corefonts.sourceforge.net/ regarding something I noticed, but I'm excited that it might work so I thought I'd put a copy here for general comment:

---
I discovered something interesting that I thought I should contact
you about:

http://support.microsoft.com/kb/169813/EN-US/

"Microsoft Office 97 Developer Edition includes a Setup Wizard that
you can use to create a Setup program that users can run to install
files for a custom application. [...] The files available for
distribution allow you to distribute an application developed using
Microsoft Access to users who do not have Microsoft Access."

http://support.microsoft.com/kb/163535/en-us

"a list of the files that you can redistribute with a run-time
application which you create using the Microsoft Office 97 Developer
Edition Tools [...] TAHOMA.TTF TAHOMABD.TTF"

Does that mean what I think it does? :-)
---

Does anyone reading this happen to have/have access to a copy of ODE97 to try this out? This would not only solve the problem of the missing bold version, but also the download size...

Conrad Knauer (atheoi) wrote :

I've opened a thread on the ubuntu-devel-discuss ML to discuss the ODE97 redistributable runtime idea:

https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2008-August/005056.html

And yes, something as simple as a "Hello World" application will suffice :-)

Conrad Knauer (atheoi) wrote :

I sent another e-mail to the msttcorefonts maintainer:

---
Oh wow, I just discovered something else neat too! :)

http://support.microsoft.com/kb/113822/en-us

"Microsoft Word allows you to embed TrueType fonts in a Word document
so that you can view and edit the fonts (if licensing rights allow),
even if you open the document on a computer that does not have the
font installed.

There are apparently four embed 'license' options, but the one of
interest to us is "Installable": "The font is installed on the target
computer permanently when you open the document. This allows you to
use the new fonts as if you installed the fonts directly into Windows
yourself."

"To determine the licensing rights of a particular font, Microsoft
provides a Font Properties Extension tool"
http://www.microsoft.com/typography/TrueTypeProperty21.mspx

Now, unfortunately Tahoma and Tahoma Bold aren't that kind, but I note
that Arial Narrow IS (its absence from msttcorefonts is mentioned
along with Tahoma on https://wiki.ubuntu.com/Fonts). There are other
fonts like this too. Now, when you install the Font Properties tool
and right-click a font (e.g. in Windows XP) there is also a "License"
Window (note http://www.microsoft.com/typography/TrueTypeEmbedding.mspx).
 So long as the embed says "installable" and there is no specific
language in the license preventing copying onto a Linux system, I
think we have a redistributable container (a DOC file) with which to
send out MS fonts...

The only question is how to extract them from the DOC file; I wonder
if Wine plus the word97 viewer could do that.
---

Conrad Knauer (atheoi) wrote :

"The only question is how to extract them from the DOC file; I wonder if Wine plus the word97 viewer could do that."

It can! =D

They are automatically put into Wine's C:\windows\Fonts when you load the DOC file in the Word 97 viewer...

Haven't got the Sample DOC working quite right yet, but soon I think...

Lennart (lennartackermans) wrote :

Hey good work man! :)

But wouldn't it be better if someone develops a DOC extractor where you don't need wine and the word 97 viewer for. Now the apt script needs to run wine... Maybe OpenOffice.org Writer can see truetype fonts in DOCs?

Conrad Knauer (atheoi) wrote :

Even better than DOC, I can embed the font in a RTF file! So it literally can be edited by gedit :) And the start/stop strings are fairly straightforward, so its just a question of figuring out what sort of compression they used.

Here, I will post a working RTF I just finished. It contains the Arial Narrow font which, according to Microsoft's own program in XP: "may be embedded in documents and permanently installed on the remote system"

That sure sounds like a license to redistribute to me! =D

Try generating the TTF with Wine+W97viewer and drop it into ~/.fonts and see if it works in OpenOffice.org for you :-)

Lennart (lennartackermans) wrote :

Actually I was wondering if OpenOffice could see the Arial Narrow font within the doc/rtf WITHOUT first extracting the font with use of wine and W97, since if we want to include Arial Narrow into the msttcorefonts package, apt/dpkg/whatever needs to run wine to install the Arial Narrow font. And I don't want wine :P. If I'd want Arial Narrow myself I'd just copy it from my illegally downloaded windows installation ;).

Anyways, I tried opening your RTF with OpenOffice but it didn't display the Arial Narrow as it should, so I don't think so.

Conrad Knauer (atheoi) wrote :

Lennart: it may just take someone poking at it a bit to get it to work; like I said, I don't know what kind of compression they use.

Here's a mini-FAQ I just made, BTW:

---
Do the Windows fonts allow "installable embedding"? Based on my copy of XP...

Arial v3.00 YES! (note: v2.82 was a corefont)
Arial Black v2.40 NO. (note: v2.35 was a corefont)
Arial Narrow v2.20 YES!
Bookman Old Style v2.20 YES!
Comic Sans MS v2.20 YES! (note: v2.10 was a corefont)
Courier New v2.90 YES! (note: v2.82 was a corefont)
Estrangelo Edessa v1.00 NO.
Franklin Gothic Medium v2.20 NO.
Garamond v2.20 NO.
Gautami v1.21 NO.
Georgia v2.12 YES! (note: v2.05 was a corefont)
Impact v2.37 NO. (note: v2.35 was a corefont)
Kartika v1.06 NO.
Latha v1.21 NO.
Lucida Console v1.60 NO.
Lucida Sans Unicode v2.00 NO.
Mangal v1.20 NO.
Microsoft Sans Serif v1.42 NO.
MV Boli v1.00 NO.
Palatino Linotype v1.40 NO.
Raavi v1.06 NO.
Shruti v1.22 NO.
Sylfaen v1.00 YES!
Symbol v1.60 YES!
Tahoma v3.15 NO.
Times New Roman v3.00 YES! (note: v2.82 was a corefont)
Trebuchet v1.23 NO. (note: v1.22 was a corefont)
Tunga v1.07 NO.
Verdana v2.43 YES! (note: v2.35 was a corefont)
Vrinda v1.03 NO.
Webdings v1.03 YES! (note: v1.03 was a corefont)
Wingdings v2.55 YES!

...and AFAICT, for the XP fonts that do allow installable embedding, there is noting in the "License" field to prevent their installation in a different OS.

Andale Mono was also a corefont, but I didn't see it installed on my system.
---

The most important fonts to make RTF files for are thus the ones that weren't core fonts (easy install :), but do allow "installable embedding". And of those, just Arial Narrow, Symbol and Wingdings jump out at me as important ones. I'll just whip up a RTF right now :)

Conrad Knauer (atheoi) wrote :

And looking into matters a bit, Symbol wouldn't be missed too much methinks...

Conrad Knauer (atheoi) wrote :

Here's Wingdings as an RTF. Its much smaller, so would be better to work with to figure out the compression than Arial Narrow.

Przemysław Kulczycki (azrael) wrote :

Why don't you try to generate PDFs with these fonts? Maybe it would be easier to extract them from PDFs.

Przemysław Kulczycki (azrael) wrote :

I mean: create PDFs from these RTFs - this shouldn't violate the license.
Besides, the font in your Wingdings file seems to be encoded with base64, but I didn't manage to decode it properly.

Conrad Knauer (atheoi) wrote :

Addendum:

Wingdings2 v1.55 NO.
Wingdings3 v1.55 NO.

Conrad Knauer (atheoi) wrote :

Przemysław Kulczycki: Apparently OO.o has an "experimental embedded ttf dumper" mentioned on
http://www.openoffice.org/servlets/ReadMsg?list=discuss&msgNo=59931

If you're at all familiar with such things, maybe try to strip it out and work it into a simple rtf2ttf app (as I suggested in a new thread on ubuntu-devel-discuss: https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2008-August/005084.html :)

Przemysław Kulczycki (azrael) wrote :

I don't know C nor Java, so I won't be able to do that.
This dumper code is available at http://lxr.go-oo.org/source/sw/sw/source/filter/ww8/ww8par.cxx

Conrad Knauer (atheoi) wrote :

Interestingly, I found a copy of Tahoma/Tahoma Bold inside Microsoft's WEFT:
http://www.microsoft.com/typography/web/embedding/weft3/weft01.htm
("cabextract WEFTIII2b1.exe" then "cabextract fonts.cab" then "wine tahoma.exe" will put the two in Wine's C:\windows\Fonts)

But unfortunately its not redistributable.

(BTW, WEFT appears to be part of *yet another* sinister Microsoft plot to make the web proprietary; see http://en.wikipedia.org/wiki/Embedded_OpenType for some info; its basically DRM for fonts online... not surprisingly, only IE supports it, though MS would like it to become a 'standard')

Benjamin Drung (bdrung) on 2009-04-10
Changed in msttcorefonts (Ubuntu):
importance: Undecided → Wishlist

Still no tahoma (and tahomabd) in Jaunty. As a workaround, this script will do it for you.

[ ! -f /usr/share/fonts/truetype/msttcorefonts/tahoma.ttf -o ! -f /usr/share/fonts/truetype/msttcorefonts/tahomabd.ttf ] &&
wget http://download.microsoft.com/download/ie6sp1/finrel/6_sp1/W98NT42KMeXP/EN-US/IELPKTH.CAB &&
cabextract -F 'tahoma*ttf' IELPKTH.CAB &&
mkdir -p /usr/share/fonts/truetype/msttcorefonts/ &&
mv -f tahoma*ttf /usr/share/fonts/truetype/msttcorefonts/ &&
chmod 644 /usr/share/fonts/truetype/msttcorefonts/tahoma* &&
fc-cache -v &&
rm -f IELPKTH.CAB &&
echo "Installed Tahoma"

Run it as root. What it does is:
1. Check whether you already have the fonts; if so exit.
2. Get the file Microsoft distribute.
3. Extract the fonts we care about.
4. Move them into place.
5. Update the font config caceh.
6. Tidy up.

Will this be fixed in Karmic?

Murz (murznn) wrote :

In karmic there are package "ttf-tahoma-replacement" that have a free font from the Wine project with exactly the same metrics as Tahoma. But this font looks very ugly with sub-pixel antialiasing.
The script from RichardNeill works very good.

Murz (murznn) wrote :

Confirm the problem on all Karmic installs with LCD monitors.
There are screenshot of microsft.com site in Firefox via tahoma.ttf from ttf-tahoma-replacement and from windows-xp.
In ttf-tahoma-replacement there are no bold font and normal font looks very blurred.

adhi (adrat-smiles) on 2010-02-16
Changed in baltix:
status: Confirmed → Fix Released
Changed in baltix:
assignee: nobody → Mantas Kriaučiūnas (mantas)
milestone: dapper → none
status: Fix Released → New
Mantas Kriaučiūnas (mantas) wrote :

Tahoma font was added to ttf-mscorefonts-installer ver. 2.0 but was removed in next version (2.1) because of lacking Bold variant, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=424852

Changed in msttcorefonts (Debian):
status: Fix Released → Unknown
Changed in msttcorefonts (Debian):
status: Unknown → Fix Released
Conrad Knauer (atheoi) wrote :

Just to document another source of Tahoma and Tahoma Bold: Office 97 Service Release 2b (23 MB)
https://www.microsoft.com/download/en/details.aspx?displaylang=EN&id=10791
cabextract does the trick, but it's only for computers with validly licensed copies of Office, of course, and probably not redistributable at all.

Trying to find a cheap copy of MS Office 97 Developer Edition, but still no luck. I wonder if someone long ago made some redistributable freeware with ODE97 for Win 95 or such that has the tahoma and tahoma bold fonts hiding in them... Will have to look around.

Conrad Knauer (atheoi) wrote :

https://www.microsoft.com/typography/fonts/font.aspx?FMID=1806

"Products that supply this font"

One wonders if there are demos for some of those that are smallish and redistributable...

Conrad Knauer (atheoi) wrote :

After reading "ODE97: Creating Run-Time Applications for Microsoft Excel, Microsoft Word, or Microsoft PowerPoint" on http://support.microsoft.com/kb/163410/EN-US it really does sound like we can create a basic installer using ODE97 (after installing SR2 to get the newest file versions available) with:

- a word doc that expects the two fonts
- tahoma.ttf
- tahomabd.ttf

that is simply gratis and redistributable...

Conrad Knauer (atheoi) wrote :

Ah, here we go! I won an eBay auction for ODE97 and here's a trial run of an installer that will give any Windows 95 computer the Tahoma font! ^_^ Oh and if you happen to download this 922 KB *gratis redistributable* onto a Linux machine and unzip it and install the two fonts, there's not much Microsoft can do about that. ^_- Enjoy!

The attachment "gratis redistributable bearing Tahoma and Tahoma Bold fonts" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Conrad Knauer (atheoi) wrote :

Based on RichardNeill's June 2009 script:

[ ! -f /usr/share/fonts/truetype/msttcorefonts/tahoma.ttf -o ! -f /usr/share/fonts/truetype/msttcorefonts/tahomabd.ttf ] &&
wget https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/50529/+attachment/2385660/+files/Tahoma_Test.zip &&
unzip -j -LL Tahoma_Test.zip installer/tahoma*ttf &&
mkdir -p /usr/share/fonts/truetype/msttcorefonts/ &&
mv -f tahoma*ttf /usr/share/fonts/truetype/msttcorefonts/ &&
chmod 644 /usr/share/fonts/truetype/msttcorefonts/tahoma* &&
fc-cache -v &&
echo "Installed Tahoma"

Brian Murray (brian-murray) wrote :

Looking at the attachments in this bug report, I noticed that "gratis redistributable bearing Tahoma and Tahoma Bold fonts" was flagged as a patch. A patch contains changes to an Ubuntu package that will resolve a bug, since this was not one I've unchecked the patch flag for it. In the future keep in mind the definition of a patch. You can learn more about what qualifies as a patch at https://wiki.ubuntu.com/Bugs/Patches. Thanks!

tags: removed: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.