Error parsing proxy URL wpad://: Unsupported scheme «wpad»

Bug #504075 reported by rainaway on 2010-01-07
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libsoup
Fix Released
Medium
wget
Invalid
Undecided
Unassigned
libsoup2.4 (Ubuntu)
Low
Unassigned
msttcorefonts (Ubuntu)
Undecided
Unassigned

Bug Description

This bug is essentially the same as

    Bug #433827: Regression: "Automatic proxy configuration" + gnome-terminal now breaks apt-get, curl, wget...

where the http_proxy environment variable got set incorrectly by libsoup-gnome2.4-1 when "Automatic proxy configuration" is used in Gnome. For example:

    "http://wpad.example.org/wpad.dat"
        becomes http_proxy=pac+http://wpad.example.org/wpad.dat

    "file:///etc/proxy.pac"
        becomes http_proxy=wpad:// as we see here.

This breaks A LOT of applications. It has been reported upstream, see https://bugzilla.gnome.org/show_bug.cgi?id=603285 for more information.

Old Description:

Binary package hint: msttcorefonts

problem

ProblemType: Package
Architecture: i386
Date: Thu Jan 7 04:27:36 2010
<span name=z27 id=z27 style='color:#000;background-color:yellow;'><span name=z62 id=z62 style='color:#000;background-color:yellow;'>DistroRelease: Ubuntu 10.04</span></span>
ErrorMessage: подпроцесс установлен сценарий post-installation возвратил код ошибки 1
InstallationMedia: Ubuntu 9.10 "<span name=z27 id=z27 style='color:#000;background-color:yellow;'><span name=z62 id=z62 style='color:#000;background-color:yellow;'>Karmic</span></span> Koala" - Release i386 (20091028.5)
Package: ttf-mscorefonts-installer 3.0
PackageArchitecture: all
ProcVersionSignature: Ubuntu 2.6.32-9.13-generic
<span name=z27 id=z27 style='color:#000;background-color:yellow;'><span name=z62 id=z62 style='color:#000;background-color:yellow;'>SourcePackage: msttcorefonts</span></span>
Tags: <span name=z27 id=z27 style='color:#000;background-color:yellow;'><span name=z62 id=z62 style='color:#000;background-color:yellow;'>lucid</span></span>
Title: package ttf-mscorefonts-installer 3.0 failed to install/upgrade: подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Uname: Linux 2.6.32-9-generic i686

rainaway (rainaway) wrote :
description: updated
summary: - package ttf-mscorefonts-installer 3.0 failed to install/upgrade:
- подпроцесс установлен сценарий post-installation возвратил код ошибки 1
+ package ttf-mscorefonts-installer 3.0 failed to install/upgrade: Error
+ parsing proxy URL wpad://: Unsupported scheme «wpad»

The error message

    Error parsing proxy URL wpad://: Unsupported scheme `wpad'.

comes from Wget when the environment variable http_proxy is set to wpad:// .

As of Wget 1.12, Anyone can reproduce the problem as follows:

    $ env LANG=C http_proxy=wpad:// wget http://example.org/
    Error parsing proxy URL wpad://: Unsupported scheme `wpad'.

I don't know where this comes from, except that it has something to do with the Gnome network proxy settings. It would be great if someone could shed some light on this puzzle. :-)

Jean-Baptiste Lallement (jibel) wrote :

wget doesn't do javascript, so can't use a proxy.pac / wpad.dat file.
I'm keeping the msttcorefonts task opened as a reminder to see if there's is something we can do on a higher level.

Changed in wget:
status: New → Invalid
Anthony Fok (foka) wrote :

It turns out that this bug is a manifestation of a bug in libsoup-gnome2.4-1:

    Bug: #433827 Regression: "Automatic proxy configuration" + gnome-terminal now breaks apt-get, curl, wget...

in libsoup/soup-proxy-resolver-gnome.c:

        } else if (proxy_mode == SOUP_PROXY_RESOLVER_GNOME_MODE_AUTO) {
                char *autoconfig_url;

                autoconfig_url = gconf_client_get_string (
                        gconf_client, SOUP_GCONF_PROXY_AUTOCONFIG_URL, NULL);
                if (autoconfig_url && !strncmp (autoconfig_url, "http", 4))
                        http_proxy = g_strconcat ("pac+", autoconfig_url, NULL);
                else
                        http_proxy = g_strdup ("wpad://");
                g_free (autoconfig_url);

So, in Gnome network proxy settings, if we set the automatic proxy URL to http://wpad.example.org/wpad.dat, we get http_proxy=pac+http://wpad.example.org/wpad.dat .

Otherwise, if we set the automatic proxy URL to e.g. file:///etc/proxy.pac, we get http_proxy=wpad:// .

This bug has been reported to the upstream author: https://bugzilla.gnome.org/show_bug.cgi?id=603285 , though I think a bit of convincing is necessary, as setting the http_proxy= to these pac+http:// or wpad:// stuff is just *wrong* IMHO, especially because it breaks 90% of the existing programs out there.

Changed in libsoup2.4 (Ubuntu):
status: New → Confirmed
Anthony Fok (foka) on 2010-03-20
description: updated
summary: - package ttf-mscorefonts-installer 3.0 failed to install/upgrade: Error
- parsing proxy URL wpad://: Unsupported scheme «wpad»
+ Error parsing proxy URL wpad://: Unsupported scheme «wpad»
Changed in libsoup:
status: Unknown → Fix Released
Pedro Villavicencio (pedro) wrote :

this is fixed upstream already, thanks for reporting.

Changed in libsoup2.4 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed
Changed in libsoup:
importance: Unknown → Medium
Martin Pitt (pitti) wrote :

Was fixed a while ago, closing.

Changed in libsoup2.4 (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) on 2012-04-09
Changed in msttcorefonts (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.