ttf-mscorefonts installer error on 17.10

Bug #1719863 reported by Sebastian Rost on 2017-09-27
96
This bug affects 20 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
Undecided
Unassigned

Bug Description

During install, i get:

ttf-mscorefonts-installer: processing...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Fehl:1 http://downloads.sourceforge.net/corefonts/andale32.exe
  Could not handshake: An unexpected TLS packet was received.
E: Fehlschlag beim Holen von https://netix.dl.sourceforge.net/project/corefonts/the fonts/final/andale32.exe Could not handshake: An unexpected TLS packet was received.
E: Herunterladen fehlgeschlagen

Package version: ttf-mscorefonts-installer (3.6ubuntu2)

Ricardo (nu118yt3) wrote :

Every Ubuntu release have the same problem, over and over again with ubuntu-restricted-extras package... come on!!!
sourceforge connection is just a pain...

I'll keep running:

sudo rm -rf /var/lib/update-notifier/package-data-downloads/partial/*
sudo apt purge ttf-mscorefonts-installer
sudo apt install ttf-mscorefonts-installer

Until it manage to download all .exe files!!!

Why is this package is not containing the files by it self by now?!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in msttcorefonts (Ubuntu):
status: New → Confirmed
Andrei B. (andrei-balint) wrote :

I followed the solution on this page (get the .deb from Debian upstream) and it worked
https://askubuntu.com/questions/852302/failure-to-download-extra-data-files-ttf-mscorefonts-installer

Struggling with this myself - different kind of error though:

$ sudo apt-get install ttf-mscorefonts-installer
....

ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/arialb32.exe
Err:1 http://downloads.sourceforge.net/corefonts/arialb32.exe
  Redirection from https to 'http://downloads.sourceforge.net/mirrorproblem?failedmirror=vorboss.dl.sourceforge.net' is forbidden
E: Failed to fetch https://vorboss.dl.sourceforge.net/project/corefonts/the fonts/final/arialb32.exe Redirection from https to 'http://downloads.sourceforge.net/mirrorproblem?failedmirror=vorboss.dl.sourceforge.net' is forbidden
E: Download Failed
Setting up ttf-mscorefonts-installer (3.6ubuntu2) ...
Processing triggers for fontconfig (2.11.94-0ubuntu2) ...

This should ideally by moved to a more reliable hosting solution than sourceforge.net.

Will try the "deb" package mentioned above.

Videonauth (videonauth) wrote :

can confirm this is ongoing since 15.10 till now 17.10. A possible workaround which always works is the following:

# install it
sudo apt install ttf-mscorefonts-installer

# dont purge or uninstall despite of errors, instead do the following
TMP=$(mktemp -d)
cd "$TMP"
awk '/Url/ {system("wget "$2)}' /usr/share/package-data-downloads/ttf-mscorefonts-installer
sudo /usr/lib/msttcorefonts/update-ms-fonts "$TMP"/*
sudo touch /var/lib/update-notifier/package-data-downloads/ttf-mscorefonts-installer
cd ..
rm -r "$TMP"

Hope this helps guys.

Nenad (uxbal) wrote :

Seems to work and install normally on 18.04 since the last couple of days.

Shane Reimer (zenon222-s) wrote :

Does not work in 18.04. Videonauth's workaround doesn't work. This is pathetic.

Videonauth (videonauth) wrote :

What on my workaround does not work anymore, the folders did not change as far I can see.

Ivan Cruz (ivan-cruz) wrote :

Just worked for me. Thanks Videonauth!

EDEMPCO (edemco) wrote :

I had the same ttf-mscorefonts problem that I have had for the past three upgrades from 14.04 to 16.04 and now to 18.04. Thanks Videonauth for a great solution. Someone, or the author, might think about creating a FIX-script using Videonauth's set-by-step. I'm sure that It will be needed again in 20.04!

We've been told that it was fixed; how many times?

Mike Lagan (mike-lagan) wrote :

I had this bug since 14.04 and still around with Ubuntu 18.04 "apt install ttf-mscorefonts-installer" not installing fonts properly bombing out with timeouts and redirection errors.

Videonauth work around finishes off the job correctly

Can somebody (I know it is big ask) please fix this so we don't have to keep repeating this tedious step.

Viczai Gábor (gviczai) wrote :

I had the same problem on 18.04. I noticed that the version it tries to install is 3.6 already, so it isn't the wrong version what's the problem here. Than I realized that apt uses ipv6 addresses...
Forcing apt to use ipv4 solved the problem for me. (https://unix.stackexchange.com/questions/9940/convince-apt-get-not-to-use-ipv6-method)
What I've done exactly:
$>sudo rm -rf /var/lib/update-notifier/package-data-downloads/partial/*
$>sudo apt purge ttf-mscorefonts-installer
$>sudo apt-get install -o Acquire::ForceIPv4=true ttf-mscorefonts-installer

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers