ttf-mscorefonts-installer fails to download fonts

Bug #1655565 reported by BSA on 2017-01-11
98
This bug affects 23 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu Xenial I try to reinstall ttf-mscorefonts-installer but it fails to download first font (andale32.exe) because user _apt has no permissions to access /var/lib/update-notifier/package-data-downloads/partial/

# apt-get install --reinstall msttcorefonts
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'ttf-mscorefonts-installer' instead of 'msttcorefonts'
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/29,5 kB of archives.
After this operation, 0 B of additional disk space will be used.
Preconfiguring packages ...
(Reading database ... 266330 files and directories currently installed.)
Preparing to unpack .../ttf-mscorefonts-installer_3.4+nmu1ubuntu2_all.deb ...
mscorefonts-eula license has already been accepted
Unpacking ttf-mscorefonts-installer (3.4+nmu1ubuntu2) over (3.4+nmu1ubuntu2) ...
Processing triggers for fontconfig (2.11.94-0ubuntu1.1) ...
Processing triggers for update-notifier-common (3.168.3) ...
ttf-mscorefonts-installer: processing...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Err:1 http://downloads.sourceforge.net/corefonts/andale32.exe
  404 Not Found
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
E: Failed to fetch https://vorboss.dl.sourceforge.net/project/corefonts/the fonts/final/andale32.exe 404 Not Found

E: Download Failed
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...

$ ls -l /var/lib/update-notifier/package-data-downloads/
drwxr-xr-x 1 root root 22 Jan 11 11:30 partial
-rw-r--r-- 1 root root 0 Jan 11 11:30 ttf-mscorefonts-installer.failed

$ grep _apt /etc/passwd
_apt:x:125:65534::/nonexistent:/bin/false

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in msttcorefonts (Ubuntu):
status: New → Confirmed
Benitron (benlarcher-1) wrote :

Downloading the 3.6 version correct the bug, but on Xubuntu 16.04 (don't know for Ubuntu, but I think too) it's the 3.4 version.

For a LTS, stability is cool ;) and it's the only upgrade failure I have got, correcting it will be nice.

https://packages.debian.org/fr/jessie/all/ttf-mscorefonts-installer/download

Thanks for the amazing job you do and the time you give !

Naël (nathanael-naeri) wrote :

Duplicate of bug 1607535, whose cause was found in package apt, see bug 1651923.

BSA (b-s-a) wrote :

After updating APT to 1.2.19 error is not fixed, but changed:

# apt install --reinstall ttf-mscorefonts-installer
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/29,5 kB of archives.
After this operation, 0 B of additional disk space will be used.
Preconfiguring packages ...
(Reading database ... 266357 files and directories currently installed.)
Preparing to unpack .../ttf-mscorefonts-installer_3.4+nmu1ubuntu2_all.deb ...
mscorefonts-eula license has already been accepted
Unpacking ttf-mscorefonts-installer (3.4+nmu1ubuntu2) over (3.4+nmu1ubuntu2) ...
Processing triggers for fontconfig (2.11.94-0ubuntu1.1) ...
Processing triggers for update-notifier-common (3.168.3) ...
ttf-mscorefonts-installer: processing...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Get:1 http://downloads.sourceforge.net/corefonts/andale32.exe [198 kB]
Fetched 198 kB in 2s (70,3 kB/s)
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/arial32.exe
Get:1 http://downloads.sourceforge.net/corefonts/arial32.exe [554 kB]
Fetched 554 kB in 4s (129 kB/s)
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/arial32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/arialb32.exe
Err:1 http://downloads.sourceforge.net/corefonts/arialb32.exe
  Protocol "http" not supported or disabled in libcurl
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/arialb32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
E: Failed to fetch https://heanet.dl.sourceforge.net/project/corefonts/the fonts/final/arialb32.exe Protocol "http" not supported or disabled in libcurl

E: Download Failed
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...

Naël (nathanael-naeri) wrote :

Did you update apt-transport-https to 1.2.19 too? If I understand correctly the fix is in this binary package. apt is the source package, compiled into several binary packages: apt, apt-utils, apt-transport-https, libapt-*, ...

BSA (b-s-a) wrote :

Yes. I have updated all packages produced by apt source.

Naël (nathanael-naeri) wrote :

Sigh. Your first two downloads worked though, the third one failed. You should report this on bug 1651923, Julian Klode might be able to help. The error message you get now, "Protocol http not supported or disabled in libcurl", is symptomatic of the same bug 1607535/1651923 I suggested as a duplicate, just like the error "404 Not Found". The error message depends on the contacted mirror.

In particular, see Elvis Stansvik's comment 25 in bug 1651923: he got the same error message as you from the vorboss.dl.sourceforge.net mirror even after he upgraded apt-transport-https to 1.2.19.

You can use apt-helper for tests instead of reinstalling ttf-mscorefonts-installer over and over again (line breaks for readability only):

$ /usr/lib/apt/apt-helper
    [-o debug::acquire::https=1 -o debug::acquire::http=1]
    download-file
    http://downloads.sourceforge.net/corefonts/andale32.exe test.exe
    OR
    "https://people.debian.org/~jak/a b/c" test.exe

The optional part is for debug output.

BSA (b-s-a) wrote :

ttf-mscorefonts-installer (3.6) from debian stretch (testing) is installed without any errors.

Naël (nathanael-naeri) wrote :

Yes, this is well-known. The Debian and Ubuntu versions of ttf-mscorefonts installer cannot be compared, with respect to this bug, and no matter their respective version numbers, because of how differently they download the fonts. See bug 1607535.

Naël (nathanael-naeri) wrote :

The fix for this bug has been released to Xenial on Jan 26. Can you try again? Purge Debian's ttf-mscorefonts-installer 3.6, update apt-transport-https, install Ubuntu's ttf-mscorefonts-installer 3.4. It should work now.

Changed in msttcorefonts (Ubuntu):
status: Confirmed → Incomplete
BSA (b-s-a) wrote :

After updating apt-transport-https by manual reinstalling (current version is differs from previous one, but has same version number 1.2.19) package ttf-mscorefonts-installer installed successfully, but it produce many warnings (for each font file):
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

Naël (nathanael-naeri) wrote :

Glad to hear ttf-mscorefonts-installer now installs successfully.

I got the warnings too, they were there before (in addition to the error). They don't show up every time. This is probably something to report against update-notifier or apt-helper one day.

Changed in msttcorefonts (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers