Download script fails

Bug #1645253 reported by FM33
214
This bug affects 50 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

Trying to figure out a font issue, I removed ttf-mscorefonts-installer and reinstalled it, but fonts download script fails for at least 10 days. The terminal window always closes after a few seconds , without completing.
Here is a screenshot I made right before it closes. There is errors.
https://framapic.org/86c1SgxnpcIV/p3P5wuhMVJV6.png

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ttf-mscorefonts-installer 3.4+nmu1ubuntu2
Uname: Linux 4.6.4-040604-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Nov 28 10:02:54 2016
InstallationDate: Installed on 2016-04-23 (218 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=fr_FR
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: msttcorefonts
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
FM33 (foxxm) wrote :
Revision history for this message
Yaron (sh-yaron) wrote :

While this might be the former location I think I managed to download the file anyway and it's located here:
https://netix.dl.sourceforge.net/project/corefonts/the%20fonts/final/andale32.exe

Maybe selecting another mirror is better but this is no longer the location anyway.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in msttcorefonts (Ubuntu):
status: New → Confirmed
Revision history for this message
Vincent Gerris (vgerris) wrote :

Indeed. I posted a workaround to have it run here:
https://askubuntu.com/a/857970/585518

A copy:

There is an issue with the sourceforge downloads (mirrors and redirects being slow and/or failing). To workaround this you can grab the files manually from here for example: https://sourceforge.net/projects/corefonts/files/the%20fonts/final/ and save them in the same directory (say mscorefonts).

The files are (from the installer): Those files are in the Microsoft Windows self-installing format, and are named

andale32.exe, arial32.exe, arialb32.exe, comic32.exe, courie32.exe, georgi32.exe, impact32.exe, times32.exe, trebuc32.exe, verdan32.exe and webdin32.exe.
Make sure the package is purged and no remaining setup triggers are remaining:

sudo apt-get remove --purge ttf-mscorefonts-installer
Then in a terminal run:

sudo apt-get install ttf-mscorefonts-installer #(this will fail again most likely)
sudo dpkg-reconfigure ttf-mscorefonts-installer
That should give you a "graphical" interface in the terminal. Then point to the directory with downloaded files like /home//Downloads/mscorefonts.

Make sure no deb files are in there, the seem to be picked up too and then it fails.

Revision history for this message
welefort (welefort) wrote :

#4 workaround works for me.. However I still get the update notification failed and it wants to run again. I just close it out, but I do get it once a day.

Revision history for this message
John Erling Blad (jeblad) wrote :

#4 workaround works for me. Will now wait for the next failed download…

Revision history for this message
Van French (newgene) wrote :

This affects me, too.

Revision history for this message
Mysterious Muscle (rubyspaam) wrote :

I'm also affected by this issue

Revision history for this message
Michael Martin (mar10m) wrote :

I am also affected by this issue.

Revision history for this message
Gerald Brown (sirg-brown) wrote :

Also affected by this issue. Did as instructed here and it looks like a fix https://computerobz.wordpress.com/2016/12/15/ttf-mscorefonts-installer-fails-to-installupgrade/

Naël (nathanael-naeri)
Changed in msttcorefonts (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Leow Kah Man (kmleow) wrote :

I have a workaround to propose, could not post on askubuntu because I had no reputation score.
Before I get flamed, just to reiterate the word **workaround**.

Firstly, the .deb installer on Ubuntu is just a live installer that pulls EXE files from sourceforge.net, we know the files are at https://sourceforge.net/projects/corefonts/files/the%20fonts/final/.

What you need to do is to download all of them, put it into a <whatever>/corefonts/ folder.
Host a simple web server on <whatever>, the simplest is starting up a NodeJS web server.
I had an active Apache instance that I could use, so I did not need Node.

Next, we need to add a temporary host entry into /etc/hosts file:
<ip address of your server> downloads.sourceforge.net

Then, we need to temporarily allow APT to accept an invalid SSL cert, which I followed from https://unix.stackexchange.com/questions/317695/is-it-possible-to-have-apt-accept-an-invalid-certificate

Cleanup the previously failed installation just to be sure
sudo apt-get purge ttf-mscorefonts-installer

And then reinstall:
sudo apt-get install ttf-mscorefonts-installer

Once done, naturally undo the temporary steps, and you are good to go.

IMHO, this way is better than other suggestions because it properly marks the package as installed neither needing to "apt mark hold" nor using debian repository .deb installer.

Hope this helps.

Revision history for this message
Karlis Vesters (karlisve) wrote :

Bug still actual 18.04.3 LTS

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers