apt: packages that need to download other files do not work

Bug #1551511 reported by Hariharan Iyer on 2016-03-01
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
Undecided
Unassigned

Bug Description

Packages that need to download and install other files, such as pepperflashplugin-nonfree and msttfcorefonts fail to download the files. Errors similar to the following are observed:
Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/courie32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
or
ERROR: failed to retrieve status information from google : W: Can't drop privileges for downloading as file './var/lib/apt/lists/partial/dl.google.com_linux_chrome_deb_dists_stable_InRelease' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
More information might be available at:
  http://wiki.debian.org/PepperFlashPlayer

Ubuntu version: 16.04
apt version: 1.2.3 (amd64)

Julian Andres Klode (juliank) wrote :

I don't see how that's a bug in APT. That's a bug in the package. APT runs dpkg as root, so the package has access to everything.

affects: apt (Ubuntu) → pepperflashplugin-nonfree (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pepperflashplugin-nonfree (Ubuntu):
status: New → Confirmed
Fabio C. Barrionuevo (luzfcb) wrote :
Download full text (3.4 KiB)

i have the same error message: "Can't drop privileges for downloading as file '/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_xenial_InRelease' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permissão negada)"

I think this error may be the apt-get and not pepperflashplugin-nonfree

full traceback:

fabio@luzfcb:~$ sudo apt-get update
[sudo] senha para fabio:
Obter:1 http://repo.steampowered.com/steam precise InRelease [2.842 B]
Obter:2 http://archive.ubuntu.com/ubuntu xenial InRelease [247 kB]
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease
Atingido:4 http://ppa.launchpad.net/gregory-hainaut/pcsx2.official.ppa/ubuntu xenial InRelease
Atingido:5 http://archive.canonical.com/ubuntu xenial InRelease
Atingido:6 http://dl.google.com/linux/chrome/deb stable Release
Atingido:7 http://ppa.launchpad.net/gwendal-lebihan-dev/hexchat-stable/ubuntu xenial InRelease
Obter:8 http://dl.google.com/linux/chrome/deb stable Release.gpg [181 B]
Obter:9 http://repo.steampowered.com/steam precise/steam Sources [550 B]
Atingido:10 http://apt.postgresql.org/pub/repos/apt xenial-pgdg InRelease
Atingido:11 http://ppa.launchpad.net/indicator-brightness/ppa/ubuntu xenial InRelease
Atingido:12 http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu xenial InRelease
Atingido:13 http://archive.ubuntu.com/ubuntu xenial-updates InRelease
Obter:14 http://repo.steampowered.com/steam precise/steam amd64 Packages [606 B]
Atingido:15 http://archive.ubuntu.com/ubuntu xenial-backports InRelease
Atingido:16 http://ppa.launchpad.net/saiarcot895/myppa/ubuntu xenial InRelease
Atingido:17 http://archive.ubuntu.com/ubuntu xenial-security InRelease
Obter:18 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages [1.197 kB]
Obter:19 http://repo.steampowered.com/steam precise/steam i386 Packages [803 B]
Obter:20 http://archive.ubuntu.com/ubuntu xenial/main i386 Packages [1.193 kB]
Obter:21 http://archive.ubuntu.com/ubuntu xenial/main Translation-en [567 kB]
Obter:22 http://archive.ubuntu.com/ubuntu xenial/main amd64 DEP-11 Metadata [636 kB]
Obter:23 http://archive.ubuntu.com/ubuntu xenial/main DEP-11 64x64 Icons [400 kB]
Obter:24 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages [7.479 kB]
Obter:25 http://archive.ubuntu.com/ubuntu xenial/universe i386 Packages [7.460 kB]
Obter:26 http://archive.ubuntu.com/ubuntu xenial/universe Translation-en [4.350 kB]
Obter:27 http://archive.ubuntu.com/ubuntu xenial/universe amd64 DEP-11 Metadata [1.849 kB]
Obter:28 http://archive.ubuntu.com/ubuntu xenial/universe DEP-11 64x64 Icons [7.484 kB]
Obter:29 http://archive.ubuntu.com/ubuntu xenial/multiverse amd64 Packages [146 kB]
Obter:30 http://archive.ubuntu.com/ubuntu xenial/multiverse i386 Packages [142 kB]
Baixados 33,2 MB em 1min 11s (465 kB/s)
AppStream cache update completed, but some metadata was ignored due to errors.
Lendo listas de pacotes... Pronto
W: Can't drop privileges for downloading as file '/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_xenial_InRelease' cou...

Read more...

Naël (nathanael-naeri) wrote :

The warnings reported here, about user _apt and their privileges, are non-blocking and don't impact the successful download of the additional data. They have been reported in several other bug reports (e.g. bug 1658707), but not investigated yet.

Actual errors in the download of additional data have been solved recently for ttf-mscorefonts-installer (see bug 1607535) and pepperflashplugin-nonfree (that shouldn't be used anymore anyway, use adobe-flashplugin instead) (see bug 1632870). If you encounter such an error, update to the most recent version of the package and refer to these bug reports. Closing the bug as Fix Released.

affects: pepperflashplugin-nonfree (Ubuntu) → msttcorefonts (Ubuntu)
Changed in msttcorefonts (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers