ttf-mscorefonts-installer doesn't work from Ubuntu Software Center because of EULA, breaks APT

Bug #1437764 reported by Sb73542-gmail on 2015-03-29
104
This bug affects 23 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
High
Unassigned
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Hello, on Vivid 15.04 Beta 2, the package ttf-mscorefonts-installer installs from the Ubuntu Software Center but doesn't actually download and install the proprietary fonts. The reason appears to be that the package requires first agreeing to an EULA before downloading the fonts, and apparently the Software Center can't handle that. Please make the Software Center pop up a GUI to accept the EULA.

affects: openssh (Ubuntu) → msttcorefonts (Ubuntu)
Sb (sb56637) wrote :

I'm adding the Ubuntu Software Center too, because this EULA bug effectively breaks the Software Center. It makes the Software Center freeze, and later after logging out and back in to a new Unity session the update manager starts producing messages about broken packages.

It should be noted that this is one of the most commonly installed 3rd party packages, and even more so given the fact that it is a requirement of ubuntu-restricted-extras which practically everyone uses. As a result, the ubuntu-restricted-extras packages is also not installable via the Software Center.

It would be nice to fix this before the release of 15.04, else we'll be seeing a lot of negative reviews about broken Software Center etc.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in msttcorefonts (Ubuntu):
status: New → Confirmed
Sb (sb56637) wrote :

I just did an install of Ubuntu 14.04 LTS on two systems, and this major bug is also present there. Not pretty.

Sb (sb56637) wrote :

I can't believe that this bug isn't getting more attention. Here's another embarrassing report in a review of 15.04:

http://linux.about.com/od/dist/fl/An-Aboutcom-Review-Of-Ubuntu-1504_3.htm
``````````````````````````````````````````````````
Unfortunately installing the "Ubuntu Restricted Extras" package from within the Ubuntu Software Center has a major flaw. During the installation a license acceptance box is supposed to appear for using Microsoft's TrueType fonts.

Sometimes the license acceptance box appears behind the Software Centre window. You can access the box by clicking on the "?" icon in the launcher.

Even worse though is that sometimes the acceptance message doesn't appear at all.

To be honest the easiest way to install the "Ubuntu Restricted Extras" package is to use the terminal.
``````````````````````````````````````````````````

Sb (sb56637) on 2015-05-12
summary: ttf-mscorefonts-installer doesn't work from Ubuntu Software Center
- because of EULA
+ because of EULA, breaks APT
Doug McMahon (mc3man) wrote :

It pops up here in front of S-C in a ubuntu session (unity/compiz
However I have compiz > General options > Focus & Raise Behaviour > Focus Prevention Level set to off as the default of on is incorrect & causes other focus issues.
Bug #1403140

Sb (sb56637) wrote :

For me, the issue is that the EULA simply does not appear, even when I specifically look for it underneath the installer.

Jerome (langj23) wrote :

I'm a newbie running 14.04 LTS and trying to get WINE for 3 different times on three different machines with the same mscorefonts FAIL is very frustrating for me! After downloading and printing five other "answers" that haven't worked, I finally get to a forum that says I need to TAB and then ENTER to accept the EULA. Now I have to sudo remove (dpkg?) everything and try again... <sigh/on>... Please fix this for all the other newbies out there, thanks!

Martin Wimpress (flexiondotorg) wrote :

I've just tested installing ubuntu-restricted-extras via Ubuntu Software Centre in Ubuntu MATE 15.10 and the appropriate EULA dialogue was displayed and the install worked as expected. Also worked using AppGrid too.

Sb (sb56637) wrote :

Hi Martin, thanks for confirming. I'll try it later on myself. Did anything actually change between Ubuntu MATE 15.04 and 15.10 in terms of the Software Centre so that it would start working? Or just ancillary changes?

Changed in ubuntu-mate:
status: New → Incomplete
Sb (sb56637) wrote :

I can confirm that this bug does NOT appear to exist in Ubuntu MATE 15.10.

I'm not sure about Ubuntu (Unity) 15.10, haven't tried it yet.

Sb (sb56637) wrote :

And I just installed Unity (Unity) 15.10 with the daily ISO, and this bug remains. During installation of
ttf-mscorefonts-installer or ubuntu-restricted-extras the whole software center freezes and the package database is left in a broken state.

Seriously guys, this bug can not be allowed to remain. It's a huge shame for Ubuntu that reflects very poorly on the quality of the whole distro.

I just double confirmed that ubuntu-restricted-extras can be installed with the Ubuntu Software Center and AppGrid on Ubuntu MATE 15.10.

no longer affects: ubuntu-mate
Changed in msttcorefonts (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: software-center → software-center (Ubuntu)
Changed in software-center (Ubuntu):
status: New → Confirmed
tags: added: rls-x-incoming
Changed in software-center (Ubuntu):
status: New → Confirmed
BettieJander (bettiejander) wrote :

Just happened to me this evening. I'm a new ubuntu user, and it freaked me out ... But I found some info out there and could fix it. I didn't get any window, my Software Center just froze. >_<

Martin G Miller (mgmiller) wrote :

Actually, this bug has existed since 14.04. It is still present today in 16.04. Sometimes the EULA appears in a window underneath the software center, sometimes it doesn't. Sometimes the ubuntu-restricted-extras package won't even show up in software center. My workaround since 14.04 has been to install synaptic package manager and then install the restricted extras package from there. That works as expected every time.

JujuLand (alain-aupeix) wrote :

Hi,
I don't know if similar reason, but ttf-mscorefonts-installer doesn't installs correctly (Xubuntu 16.04), and each time I connect to my computer, I have this message:

_________________________________________________________
Échec du téléchargement des données supplémentaires

Les paquet suivants nécessitent le téléchargement de données supplémentaires après leur installation,
mais les données n'ont pas pu être téléchargées ou traitées.

ttf-mscorefonts-installer
_________________________________________________________

Trying with synaptics, or with apt-get always fail.

_________________________________________________________
alain@Dell-DM061:~$ sudo apt-get install ttf-mscorefonts-installer
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  ttf-mscorefonts-installer
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/29,5 ko dans les archives.
Après cette opération, 134 ko d'espace disque supplémentaires seront utilisés.
Préconfiguration des paquets...
Sélection du paquet ttf-mscorefonts-installer précédemment désélectionné.
(Lecture de la base de données... 312025 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../ttf-mscorefonts-installer_3.4+nmu1ubuntu2_all.deb ...
mscorefonts-eula license has already been accepted
Dépaquetage de ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...
Traitement des actions différées (« triggers ») pour fontconfig (2.11.94-0ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour update-notifier-common (3.168.3) ...
ttf-mscorefonts-installer: processing...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe

Err:1 http://downloads.sourceforge.net/corefonts/andale32.exe
   Le serveur http a envoyé un en-tête « Content-Range » invalide

W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe'
   couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission non accordée)

E: Impossible de récupérer https://netcologne.dl.sourceforge.net/project/corefonts/the fonts/final/andale32.exe
   Le serveur http a envoyé un en-tête « Content-Range » invalide

E: Download Failed
Paramétrage de ttf-mscorefonts-installer (3.4+nmu1ubuntu2) ...
_________________________________________________________

I tried this:

- uninstall ttf-mscorefonts-installer
- download andale32.exe with wget
- moving it in /var/lib/update-notifier/package-data-downloads/partial
- install ttf-mscorefonts-installer with apt-get

The message as andale32.exe can't be found on the server is always here, but the install seems to be done, and andale32.exe is removed from /var/lib/update-notifier/package-data-downloads/partial

I thought it was now ok, but I have always the same message when connecting.

Just curious that the url embedded a space (the fonts):

E: Impossible de récupérer https://netcologne.dl.sourceforge.net/project/corefonts/the fonts/final/andale32.exe

Thanks
A+

JujuLand (alain-aupeix) wrote :

A solution which seems to work for Xubuntu 16.04 (and probably for Ubuntu ...):

sudo apt-get remove ttf-mscorefonts-installer
and the apply this

https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1022891/comments/11

A+

@Alain: not the same bug, you clearly have accepted the EULA already (it's written in the output). See bug 1649203/comments/13 for your Content-Range issue. Also make sure that apt-transport-https is 1.2.19 to avoid bug 1607535. Then you can remove Debian's version of ttf-mscorefonts-installer with "sudo dpkg -P /path/to/ttf-mscorefonts-installer_3.6_all.deb", and reinstall the Ubuntu one (that said the Debian version works fine too).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers