microsoft font package fails to install

Bug #1354709 reported by i30817 on 2014-08-09
78
This bug affects 18 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
Undecided
Unassigned

Bug Description

The first gksu install is because i was told that it might fix this on ask ubuntu ( http://askubuntu.com/questions/153928/failure-to-download-extra-data-files-after-installing-ttf-mscorefonts-installe/168377#168377 ), but it didn't (the error is the same and the window 'Failure to download extra data files' comes up again):

i30817@AIVAS:~$ sudo apt-get install gsudo
[sudo] password for i30817:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package gsudo
i30817@AIVAS:~$ sudo apt-get install gksu
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libgcrypt11-dev libgnutlsxx27 libgpg-error-dev
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libgksu2-0
The following NEW packages will be installed:
  gksu libgksu2-0
0 upgraded, 2 newly installed, 0 to remove and 15 not upgraded.
Need to get 99,6 kB of archives.
After this operation, 740 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://pt.archive.ubuntu.com/ubuntu/ utopic/universe libgksu2-0 amd64 2.0.13~pre1-6ubuntu4 [71,8 kB]
Get:2 http://pt.archive.ubuntu.com/ubuntu/ utopic/universe gksu amd64 2.0.2-6ubuntu2 [27,8 kB]
Fetched 99,6 kB in 0s (271 kB/s)
Selecting previously unselected package libgksu2-0.
(Reading database ... 232286 files and directories currently installed.)
Preparing to unpack .../libgksu2-0_2.0.13~pre1-6ubuntu4_amd64.deb ...
Unpacking libgksu2-0 (2.0.13~pre1-6ubuntu4) ...
Selecting previously unselected package gksu.
Preparing to unpack .../gksu_2.0.2-6ubuntu2_amd64.deb ...
Unpacking gksu (2.0.2-6ubuntu2) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for gconf2 (3.2.6-2ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu2) ...
Processing triggers for mime-support (3.55ubuntu1) ...
Setting up libgksu2-0 (2.0.13~pre1-6ubuntu4) ...
update-alternatives: using /usr/share/libgksu/debian/gconf-defaults.libgksu-sudo to provide /usr/share/gconf/defaults/10_libgksu (libgksu-gconf-defaults) in auto mode
Processing triggers for gconf2 (3.2.6-2ubuntu1) ...
Setting up gksu (2.0.2-6ubuntu2) ...
Processing triggers for libc-bin (2.19-4ubuntu1) ...
i30817@AIVAS:~$ sudo apt-get install --reinstall ttf-mscorefonts-installer
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libgcrypt11-dev libgnutlsxx27 libgpg-error-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 15 not upgraded.
Need to get 27,8 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://pt.archive.ubuntu.com/ubuntu/ utopic/multiverse ttf-mscorefonts-installer all 3.4+nmu1ubuntu1 [27,8 kB]
Fetched 27,8 kB in 0s (221 kB/s)
Preconfiguring packages ...
(Reading database ... 232342 files and directories currently installed.)
Preparing to unpack .../ttf-mscorefonts-installer_3.4+nmu1ubuntu1_all.deb ...
mscorefonts-eula license has already been accepted
Unpacking ttf-mscorefonts-installer (3.4+nmu1ubuntu1) over (3.4+nmu1ubuntu1) ...
Processing triggers for update-notifier-common (3.156) ...
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/andale32.exe
Get:1 http://downloads.sourceforge.net/corefonts/andale32.exe [198 kB]
Fetched 198 kB in 1s (107 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/arial32.exe
Get:1 http://downloads.sourceforge.net/corefonts/arial32.exe [554 kB]
Fetched 554 kB in 2s (194 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/arialb32.exe
Get:1 http://downloads.sourceforge.net/corefonts/arialb32.exe [168 kB]
Fetched 168 kB in 1s (117 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/comic32.exe
Get:1 http://downloads.sourceforge.net/corefonts/comic32.exe [246 kB]
Fetched 246 kB in 1s (148 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/courie32.exe
Get:1 http://downloads.sourceforge.net/corefonts/courie32.exe [646 kB]
Fetched 646 kB in 2s (235 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/georgi32.exe
Get:1 http://downloads.sourceforge.net/corefonts/georgi32.exe [392 kB]
Fetched 392 kB in 2s (177 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/impact32.exe
Get:1 http://downloads.sourceforge.net/corefonts/impact32.exe [173 kB]
Fetched 173 kB in 1s (112 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/times32.exe
Get:1 http://downloads.sourceforge.net/corefonts/times32.exe [662 kB]
Fetched 662 kB in 3s (167 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/trebuc32.exe
Get:1 http://downloads.sourceforge.net/corefonts/trebuc32.exe [357 kB]
Fetched 357 kB in 2s (148 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/verdan32.exe
Get:1 http://downloads.sourceforge.net/corefonts/verdan32.exe [352 kB]
Fetched 352 kB in 2s (157 kB/s)
ttf-mscorefonts-installer: downloading http://downloads.sourceforge.net/corefonts/webdin32.exe
Get:1 http://downloads.sourceforge.net/corefonts/webdin32.exe [185 kB]
Fetched 185 kB in 1s (131 kB/s)

These fonts were provided by Microsoft "in the interest of cross-
platform compatibility". This is no longer the case, but they are
still available from third parties.

You are free to download these fonts and use them for your own use,
but you may not redistribute them in modified form, including changes
to the file name or packaging format.

Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/andale32.exe
  extracting fontinst.inf
  extracting andale.inf
  extracting fontinst.exe
  extracting AndaleMo.TTF
  extracting ADVPACK.DLL
  extracting W95INF32.DLL
  extracting W95INF16.DLL

All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/arial32.exe
  extracting FONTINST.EXE
  extracting fontinst.inf
  extracting Ariali.TTF
  extracting Arialbd.TTF
  extracting Arialbi.TTF
  extracting Arial.TTF

All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/arialb32.exe
  extracting fontinst.exe
  extracting fontinst.inf
  extracting AriBlk.TTF

All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/comic32.exe
  extracting fontinst.inf
  extracting Comicbd.TTF
  extracting Comic.TTF
  extracting fontinst.exe

All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/courie32.exe
  extracting cour.ttf
  extracting courbd.ttf
  extracting courbi.ttf
  extracting fontinst.inf
  extracting couri.ttf
  extracting fontinst.exe

All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/georgi32.exe
  extracting fontinst.inf
  extracting Georgiaz.TTF
  extracting Georgiab.TTF
  extracting Georgiai.TTF
  extracting Georgia.TTF
  extracting fontinst.exe

All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/impact32.exe
  extracting fontinst.exe
  extracting Impact.TTF
  extracting fontinst.inf

All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/times32.exe
  extracting fontinst.inf
  extracting Times.TTF
  extracting Timesbd.TTF
  extracting Timesbi.TTF
  extracting Timesi.TTF
  extracting FONTINST.EXE

All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/trebuc32.exe
  extracting FONTINST.EXE
  extracting trebuc.ttf
  extracting Trebucbd.ttf
  extracting trebucbi.ttf
  extracting trebucit.ttf
  extracting fontinst.inf

All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/verdan32.exe
  extracting fontinst.exe
  extracting fontinst.inf
  extracting Verdanab.TTF
  extracting Verdanai.TTF
  extracting Verdanaz.TTF
  extracting Verdana.TTF

All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/webdin32.exe
  extracting fontinst.exe
  extracting Webdings.TTF
  extracting fontinst.inf
  extracting Licen.TXT

All done, no errors.
All fonts downloaded and installed.
Traceback (most recent call last):
  File "/usr/lib/update-notifier/package-data-downloader", line 260, in process_download_requests
    os.remove(f)
OSError: [Errno 2] No such file or directory: '/var/lib/update-notifier/package-data-downloads/partial/arial32.exe'
Processing triggers for fontconfig (2.11.1-0ubuntu3) ...
Setting up ttf-mscorefonts-installer (3.4+nmu1ubuntu1) ...

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ttf-mscorefonts-installer 3.4+nmu1ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-6.11-generic 3.16.0-rc7
Uname: Linux 3.16.0-6-generic x86_64
ApportVersion: 2.14.5-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Sat Aug 9 16:22:37 2014
InstallationDate: Installed on 2014-07-05 (35 days ago)
InstallationMedia: Ubuntu-GNOME 14.10 "Utopic Unicorn" - Alpha amd64 (20140624)
PackageArchitecture: all
SourcePackage: msttcorefonts
UpgradeStatus: No upgrade log present (probably fresh install)

i30817 (i30817) wrote :
description: updated
i30817 (i30817) on 2014-08-09
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in msttcorefonts (Ubuntu):
status: New → Confirmed
Cavsfan (cavsfan) wrote :

I get this exact same error on Ubuntu Mate 14.10 on a fresh install:
All fonts downloaded and installed.
Traceback (most recent call last):
  File "/usr/lib/update-notifier/package-data-downloader", line 260, in process_download_requests
    os.remove(f)
OSError: [Errno 2] No such file or directory: '/var/lib/update-notifier/package-data-downloads/partial/arial32.exe'

Cavsfan (cavsfan) wrote :

I've also tried sudo apt-get install --reinstall ttf-mscorefonts-installer and got the same error.
This is on two installations of Ubuntu Mate 14.10.

layingback (laying-back) wrote :

Same on Ubuntu Mate 14.10b1 on fresh install.

Attempt with Ubuntu Software Center failed, it hung, had to kill.

On reboot:

Failure to download extra data files

The following packages requested additional data downloads after package installation, but the data could not be downloaded or could not be processed.

ttf-mscorefonts-installer

The download will be attempted again later, or you can try the download again now. Running this command requires an active Internet connection.

Clicking Run this action now, just refreshed the error message.

Tried reinstall through synaptic, same result.

Note I did have Details window open, and was able to respond to basic old-PC style license agreement (not possible with Software Center). But still same result.

Most if not all of the fonts do appear to be installed!

eris23 (jdkatz23) wrote :

On a Xxubntu Utopic amd64 beta-1 vm:

Traceback (most recent call last):
  File "/usr/lib/update-notifier/package-data-downloader", line 260, in process_download_requests
    os.remove(f)
OSError: [Errno 2] No such file or directory: '/var/lib/update-notifier/package-data-downloads/partial/arial32.exe'

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package msttcorefonts - 3.4+nmu1ubuntu2

---------------
msttcorefonts (3.4+nmu1ubuntu2) utopic; urgency=medium

  * update-ms-fonts: Skip race between update-notifier and update-ms-fonts
    trying to delete the same files from the same locations (LP: #1354709)
 -- Adam Conrad <email address hidden> Thu, 11 Sep 2014 00:08:50 -0600

Changed in msttcorefonts (Ubuntu):
status: Confirmed → Fix Released
Adam Colligan (adam-p) wrote :

I am still experiencing this problem on 14.10, even after uninstalling and reinstalling ttf-mscorefonts-installer. Is there a step I'm missing?

Kishore (kitts) wrote :

Same here. I had never faced this issue until now on 14.10 64bit.

Ford Terrill (ford-f) wrote :

I have the exact issue with ubuntu 14.10 64-bit:
All done, no errors.
Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/webdin32.exe
  extracting fontinst.exe
  extracting Webdings.TTF
  extracting fontinst.inf
  extracting Licen.TXT

All done, no errors.
All fonts downloaded and installed.
wine-browser-installer: downloading http://download.mozilla.org/?product=firefox-22.0&os=win&lang=en-US
Get:1 http://download.mozilla.org/?product=firefox-22.0&os=win&lang=en-US [21.8 MB]
Fetched 21.8 MB in 3s (5,674 kB/s)

Silverlight is provided by Microsoft in unmodified form only, you may not redistribute the software.

Everything downloaded and installed.
Traceback (most recent call last):
  File "/usr/lib/update-notifier/package-data-downloader", line 260, in process_download_requests
    os.remove(f)
OSError: [Errno 2] No such file or directory: '/var/lib/update-notifier/package-data-downloads/partial/?product=firefox-22.0&os=win&lang=en-US'
Processing triggers for man-db (2.7.0.2-2) ...

Doug Arnold (dnarnold) wrote :

I had the same problem as comment #10 after upgrading to Ubuntu 14.10 and trying to install netflix-desktop.
Specifically this brought in the package wine-browser-installer as a dependency and the install of that
package failed with

   File "/usr/lib/update-notifier/package-data-downloader", line 260, in process_download_requests
     os.remove(f)
  OSError: [Errno 2] No such file or directory:
   '/var/lib/update-notifier/package-data-downloads/partial/?product=firefox-22.0&os=win&lang=en-US'

I fixed the problem by adding one line to "/usr/lib/update-notifier/package-data-downloader" to check with
a file exists before trying to remove it. Specifically I replaced line 260:

                         os.remove(f)

with the two lines

                         if os.path.exists(dest_file):
                            os.remove(f)

With this change I was able to install wine-browser-installer and netflix-desktop without error.

Doug Arnold (dnarnold) wrote :

I apologize for a typo in the patch submitted in the previous comment. The new lines should of course be

                         if os.path.exists(f):
                            os.remove(f)

("f" not "dest_file").

I have reported this problem and patch in a bug report on update-notifier at
https://bugs.launchpad.net/bugs/1425118

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers