package ttf-mscorefonts-installer fails to install/upgrade, left in a half configured state

Bug #1222654 reported by bobhurt on 2013-09-09
754
This bug affects 155 people
Affects Status Importance Assigned to Milestone
msttcorefonts (Ubuntu)
Undecided
Unassigned

Bug Description

There are many bugs which are very similar, although the exact details of version and error message might change, in the end they all boil down to ttf-mscorefonts-installer being in a broken state from which it's hard to recover.

ttf-mscorefonts-installer needs to be made more reliable so that a failure to accept the license doesn't cause a very-hard-to-recover-from situation.

bobhurt (bob-bobhurt) wrote :
tags: removed: need-duplicate-check

I had a similar problem, it quit the install because the tiny terminal screen from the update window from the software center didn't have enough room for the license (I saw a message about the terminal not being big enough briefly). Editing /var/lib/dpkg/status (via sudo), removing the ttf-mscorefonts-installer section entirely, and then sudo apt-get install ttf-mscorefonts-installer in a "normal-sized" terminal window.
Note that when the license agreement comes up, you have to scroll down and look at the whole thing before the < OK > button becomes activated, it took a minute or two to figure that out (sometimes I'm slow).
Can't say if the size of the terminal screen when you installed it was the root cause (not 100% it was for me, but probably was), but that may be a legitimate bug for the package, that it is expecting a terminal minimum size and quitting in a half installed state.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in msttcorefonts (Ubuntu):
status: New → Confirmed
summary: - package ttf-mscorefonts-installer 3.4+nmu1ubuntu1 failed to
- install/upgrade
+ package ttf-mscorefonts-installer fails to install/upgrade
description: updated
summary: - package ttf-mscorefonts-installer fails to install/upgrade
+ package ttf-mscorefonts-installer fails to install/upgrade, left in a
+ half configured state
Margarita Manterola (marga-9) wrote :

For people that are affected by this issue, some things that you might try to get your system back in shape:

A) sudo apt-get install --reinstall ttf-mscorefonts-installer

B) sudo apt-get remove --purge ttf-mscorefonts-installer; sudo apt-get install ttf-mscorefonts-installer

C) sudo dpkg-reconfigure ttf-mscorefonts-installer

This is an either or list. If one of them fixes the problem for you, don't try the others :). Also, if you are affected by this problem and one of these things fixes it, please report how your breakage looked like and which option fixed it.

Download full text (3.7 KiB)

Jsem absolutní laik.Plavu v tom.Sorry.

---------- Původní zpráva ----------

Od: Margarita Manterola <email address hidden>

Komu: <email address hidden>

Datum: 20. 3. 2014 17:11:00

Předmět: [Bug 1222654] Re: package ttf-mscorefonts-installer fails to
install/upgrade

"** Summary changed:

- package ttf-mscorefonts-installer 3.4+nmu1ubuntu1 failed to install/
upgrade

+ package ttf-mscorefonts-installer fails to install/upgrade

** Description changed:

- Similar to all the others. This stupid message occurs with every

- install of any app and every update, causing the process to error out.

- Canonical MUST FIX THIS THING before it makes me crazy. Find some

- public domain equivalents for those fonts. This erro showed up after I

- installed wine and had a hitch somehow, UBUNTU 13.04, then tried to

- install something else. I looked and found numerous remedies, but none

- of them worked, and now I have forgotten WHAT I tried. If I have to

- put up with this, I might as well go back to (Grrrr) Windows. DO I

- really need to say I FULLY EXPECT NO ERROR MESSAGE and I FULLY EXPECT

- that the ttf-mscorefonts-installer will complete without error and

- without harassing me with a STUPID license agreement? If I need the

- fonts for wine, OF COURSE I ACCEPT IT. So it should just alert me that

- I must abide by the agreement. Nobody reads the damned thing anyway. I

- certainly don't.

+ There are many bugs which are very similar, although the exact details

+ of version and error message might change, in the end they all boil down

+ to ttf-mscorefonts-installer being in a broken state from which it's

+ hard to recover.

- We really need a way to forcibly REINSTALL and ACCEPT THE LICENSE

- agreement (assuming that's the problem). How shall I do that?

-

- ProblemType: Package

- DistroRelease: Ubuntu 13.04

- Package: ttf-mscorefonts-installer 3.4+nmu1ubuntu1

- ProcVersionSignature: Ubuntu 3.8.0-30.44-generic 3.8.13.6

- Uname: Linux 3.8.0-30-generic x86_64

- ApportVersion: 2.9.2-0ubuntu8.3

- Architecture: amd64

- Date: Sun Sep 8 23:53:35 2013

- DuplicateSignature: package:ttf-mscorefonts-installer:3.4+nmu1ubuntu1:

- ErrorMessage:

-

- InstallationDate: Installed on 2013-06-30 (71 days ago)

- InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64
(20130424)

- MarkForUpload: True

- PackageArchitecture: all

- SourcePackage: msttcorefonts

- Title: package ttf-mscorefonts-installer 3.4+nmu1ubuntu1 failed to
install/upgrade

- UpgradeStatus: No upgrade log present (probably fresh install)

+ ttf-mscorefonts-installer needs to be made more reliable so that a

+ failure to accept the license doesn't cause a very-hard-to-recover-from

+ situation.

** Summary changed:

- package ttf-mscorefonts-installer fails to install/upgrade

+ package ttf-mscorefonts-installer fails to install/upgrade, left in a half
configured state

--

You received this bug notification because you are subscribed to a

duplicate bug report (1295188).

https://bugs.launchpad.net/bugs/1222654

Title:

package ttf-mscorefonts-installer fails to install/upgrade, left in a

half configured state

Status in “msttcorefonts” p...

Read more...

Mám Ubuntu 13.10 Má to vliv na instalci aktualizací?

---------- Původní zpráva ----------

Od: Margarita Manterola <email address hidden>

Komu: <email address hidden>

Datum: 20. 3. 2014 17:21:08

Předmět: [Bug 1222654] Re: package ttf-mscorefonts-installer fails to
install/upgrade, left in a half configured state

"For people that are affected by this issue, some things that you might

try to get your system back in shape:

A) sudo apt-get install --reinstall ttf-mscorefonts-installer

B) sudo apt-get remove --purge ttf-mscorefonts-installer; sudo apt-get

install ttf-mscorefonts-installer

C) sudo dpkg-reconfigure ttf-mscorefonts-installer

This is an either or list. If one of them fixes the problem for you,

don't try the others :). Also, if you are affected by this problem and

one of these things fixes it, please report how your breakage looked

like and which option fixed it.

--

You received this bug notification because you are subscribed to a

duplicate bug report (1295188).

https://bugs.launchpad.net/bugs/1222654

Title:

package ttf-mscorefonts-installer fails to install/upgrade, left in a

half configured state

Status in “msttcorefonts” package in Ubuntu:

Confirmed

Bug description:

There are many bugs which are very similar, although the exact details

of version and error message might change, in the end they all boil

down to ttf-mscorefonts-installer being in a broken state from which

it's hard to recover.

ttf-mscorefonts-installer needs to be made more reliable so that a

failure to accept the license doesn't cause a very-hard-to-recover-

from situation.

To manage notifications about this bug go to:

https://bugs.launchpad.net/ubuntu/+source/msttcorefonts/+bug/1222654/+
subscriptions"

In a related manner, can I suggest that when apt-get is invoked with "-y", that means that the user really really wants the installer to proceed assuming yes, and without asking questions, and has probably written an unattended shell-script, which is not allowed to require user-interaction to confirm. In other words, the "-y" explicitly includes acceptance of the EULA.
(Under no circumstances is "apt-get -y" allowed to hang, wating for interactive input).

Workaround:

echo "ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula boolean true" | debconf-set-selections
apt-get -y ttf-mscorefonts-installer

Also, the installer does not fetch tahoma. However, the following script fragment will, I add it here in case it's useful:

echo "Installing Tahoma font"
cd /tmp
which cabextract >/dev/null || apt-get -y install cabextract
[ ! -f /usr/share/fonts/truetype/msttcorefonts/tahoma.ttf -o ! -f /usr/share/fonts/truetype/msttcorefonts/tahomabd.ttf ] &&
wget http://download.microsoft.com/download/ie6sp1/finrel/6_sp1/W98NT42KMeXP/EN-US/IELPKTH.CAB &&
cabextract -F 'tahoma*ttf' IELPKTH.CAB &&
mkdir -p /usr/share/fonts/truetype/msttcorefonts/ &&
mv -f tahoma*ttf /usr/share/fonts/truetype/msttcorefonts/ &&
 chmod 644 /usr/share/fonts/truetype/msttcorefonts/tahoma* &&
fc-cache && rm -f IELPKTH.CAB && echo "Installed Tahoma"
cd -

[I wrote this script, I just tested it successfully on Trusty, and I release it into the public domain]

Ba8ry (ba8ry) wrote :

The problem I had was that ttf-fonts-installer DID install and the fonts were usable but notwithstanding this I continued to get the warning "Data files for some packages could not be downloaded" from Update Information - KDE Daemon.

I tried a removal and reinstall via Synaptic that did not fix the problem.

Margarita Manterola's <email address hidden> suggestion of a full purge and reinstall appears to have worked.

I am running Kubuntu 14.04.01

Nanko Verwaal (nanki) wrote :

I had the same problem on Ubuntu 14.04.01 LTS (incl. KDE).

I tried all three of Margaritas methods, but neither of them worked.

Then I completely removed the package from the system:
   sudo apt-get remove --purge ttf-mscorefonts-installer
and big surprise when I logged in again: -> The light bulb with the message was still there!

I found out that update-notifier is monitoring the contents of /var/lib/update-notifier/ and that the following file contains exactly the error message, update-notifier is complaining about:
    /var/lib/update-notifier/user.d/data-downloads-failed-permanently

My solution:

1. sudo mv /var/lib/update-notifier/user.d/data-downloads-failed-permanently /tmp/
2. login again and see whether you still have a bulb message
3. if you had removed the fonts package, install it again from a terminal window (don't use any GUI package installer, since they might conflict with the license agreement agreement dialog that comes with the package)

SirFreakalot (gnev) wrote :

For me it didn't work with the Ubuntu Software center as this surpresses some feedback from the Installer.
So it worked for me from the command line with simply:

   sudo apt-get install ttf-mscorefonts-installer

Then You need to conform the ms-ugly EULA, but you will have Arial etc after that :)

Kloptila (kloptila) on 2016-06-04
Changed in msttcorefonts (Ubuntu):
status: Confirmed → Fix Released
Naël (nathanael-naeri) wrote :

I can see recent reports of this bug in the bug list, or at least bugs where installation or removal of ttf-mscorefonts-installer didn't work and the package was left in a half-configured, impossible-to-remove state, which strongly points at non-printed, non-accepted EULA.

@Kloptila, you marked this bug as Fix Released, can you please give more information? Who fixed it, what's the fix, in which version, and can we SRU it?

I'm not sure it's fixed.

To post a comment you must log in.