firefox crashed visiting apple site

Bug #360756 reported by dano
4
Affects Status Importance Assigned to Milestone
mplayerplug-in (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

crashing when visiting this site
http://www.apple.com/es/findouthow/mac/

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/firefox-3.0.8/firefox
NonfreeKernelModules: nvidia
Package: firefox-3.0 3.0.8+nobinonly-0ubuntu3
ProcCmdline: /usr/lib/firefox-3.0.8/firefox
ProcEnviron:
 PATH=(custom, user)
 LANG=es_CL.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: firefox-3.0
StacktraceTop:
 memmem () from /lib/tls/i686/cmov/libc.so.6
 buildPlaylist ()
 nsPluginInstance::DestroyStream ()
 NPP_DestroyStream ()
 ?? () from /usr/lib/xulrunner-1.9.0.8/libxul.so
Title: firefox crashed with SIGSEGV in memmem()
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
dano (danoex) wrote :
Revision history for this message
ahfuji (ahfuji) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better.
I go to the website to reproduce the bug in my environment (jaunty, firefox-3.0:
Installed: 3.0.10+nobinonly-0ubuntu0.9.04.1), but I can successfully see the site
and moreover watch the flash video in the center without crash.
After upgrading firefox, could you please check again whether this bug is reproducible?

If reproducible, could you please add more information for it by looking to
https://wiki.ubuntu.com/MozillaTeam/Bugs , Thanks in advance.

Changed in firefox-3.0 (Ubuntu):
assignee: nobody → afujihara (afujihara)
status: New → Incomplete
Revision history for this message
Julius Schwartzenberg (jschwart) wrote :

This crash is reproducible with the trailer this page:
http://www.apple.com/trailers/independent/plaguetown/

You have to have the mozilla-mplayer & firefox packages installed. It's likely it crashes because of the QuickTime movie. I'm using Jaunty.
I'll try to follow the instructions on that wiki page to get more info.

Revision history for this message
Julius Schwartzenberg (jschwart) wrote :

I produced the attachment with Firefox 3.5pre4 from the firefox-3.5 packages. The crash also happens with the 3.0 version included in Jaunty.

I'm not sure whether this backtrace is actually useful. I suspect this is actually a crash in the mozilla-mplayer plug-in and it takes the whole Firefox with it because browser plug-ins still run in-process. What would be a suitable approach to find the cause of the crash in the plug-in?

The version of the plug-in included with Jaunty, seems to be the most recent one.

Revision history for this message
Julius Schwartzenberg (jschwart) wrote :

Althought the changelog doesn't mention any crash fixes, compiling the daily version of mplayerplug-in fixed the crash for me.

My package can be found here:
http://haar.student.utwente.nl/~julius/debs/jaunty/mozilla-mplayer_3.55+daily20090524-1.0ubuntu1_i386.deb

It works for me now with Firefox 3.0. (For some reason Firefox 3.5 started segfaulting on launch now.)

Revision history for this message
John Vivirito (gnomefreak) wrote :

Changed to correct package since compiling it fixed it.

affects: firefox-3.0 (Ubuntu) → mplayerplug-in (Ubuntu)
Changed in mplayerplug-in (Ubuntu):
assignee: afujihara (afujihara) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayerplug-in - 3.55-2ubuntu1

---------------
mplayerplug-in (3.55-2ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes: LP: #386705
    - debian/control:
      + add Xb-Npp-xxx tags accordingly to "firefox distro add-on support"
        spec.
      + replace build-depends on iceape-dev with libxul-dev.
      + replace iceweasel with firefox-3.0 | xulrunner.
      + replace iceape-browser with seamonkey-browser.
      + add alternative depends on mplayer-nogui (>= 1.0~rc2).
      + tighten mplayer dependency to (>= 1.0~rc2).
    - debian/mozilla-mplayer.links:
      + add firefox and xulrunner symlinks.
  * Fixes: LP: #239506 LP: #376932 LP: #360756 LP: #360222 (Hopefully).

 -- Bhavani Shankar <email address hidden> Sat, 13 Jun 2009 18:02:40 +0530

Changed in mplayerplug-in (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers