Ubuntu

firefox w/ mplayer plugin crashes on .mov file

Reported by gkornelson on 2009-04-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mplayer (Mandriva)
Unknown
Critical
mplayerplug-in (Debian)
Fix Released
Unknown
mplayerplug-in (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

Ever since installing upgrades yesterday (April 7, 2009), firefox crashes when trying to play .mov files from Apple using the mozilla-mplayer plugin. Everything works fine using the mozilla-totem plugin, so I'm not sure whether this is a firefox bug or a bug in the mplayer plugin.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: firefox-3.0 3.0.8+nobinonly-0ubuntu3
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.28-11-generic i686

gkornelson (gkornelson) wrote :
chocolateboy (chocolateboy) wrote :

This bug is also being tracked here: https://qa.mandriva.com/show_bug.cgi?id=47207

tags: added: apple apple.com mplayer-plugin quicktime
chocolateboy (chocolateboy) wrote :

The mplayer-plugin in question is: QuickTime Plug-in 7.4.5

The console output prior to crashing is:

    ADDED URL: district9-tlr1_h480.mov
    code: 23
     speed -1
    Segmentation fault

Here's another report: http://bugs.archlinux.org/task/14155

chocolateboy (chocolateboy) wrote :

More discussions:

    http://bbs.archlinux.org/viewtopic.php?id=62393
    https://lists.ubuntu.com/archives/ubuntu-users/2009-April/180943.html

The suggested workaround is to replace mozilla-mplayer with gecko-mediaplayer.

Alexander Sack (asac) on 2009-05-05
affects: firefox-3.0 (Ubuntu) → mplayer (Ubuntu)
affects: mplayer (Ubuntu) → mplayerplug-in (Ubuntu)
Changed in mplayerplug-in (Ubuntu):
status: New → Triaged
affects: mplayer (Debian) → mplayerplug-in (Debian)
Changed in mplayerplug-in (Debian):
status: Unknown → Fix Released
Changed in mplayer (Mandriva):
status: Unknown → Confirmed
Eugenia Loli-Queru (eloli) wrote :

Is this fixed for the latest version of ubuntu? Because it crashes here, and i have all the latest versions of everything. Or do I need to enable any repository that's not on by default?

chocolateboy (chocolateboy) wrote :

@Eugenia:

Until it gets fixed, you can use gecko-mediaplayer instead:

    sudo apt-get remove mozilla-mplayer
    sudo apt-get install gecko-mediaplayer

They're both in multiverse, so if you have mozilla-mplayer installed, you should be able to install gecko-mediaplayer:

See here for more info:

http://www.ubuntugeek.com/how-to-enable-the-universe-and-multiverse-repositories-in-ubuntu-804-hardy.html
https://bugs.launchpad.net/ubuntu/+source/mplayerplug-in/+bug/360222/comments/4

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayerplug-in - 3.55-2ubuntu1

---------------
mplayerplug-in (3.55-2ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes: LP: #386705
    - debian/control:
      + add Xb-Npp-xxx tags accordingly to "firefox distro add-on support"
        spec.
      + replace build-depends on iceape-dev with libxul-dev.
      + replace iceweasel with firefox-3.0 | xulrunner.
      + replace iceape-browser with seamonkey-browser.
      + add alternative depends on mplayer-nogui (>= 1.0~rc2).
      + tighten mplayer dependency to (>= 1.0~rc2).
    - debian/mozilla-mplayer.links:
      + add firefox and xulrunner symlinks.
  * Fixes: LP: #239506 LP: #376932 LP: #360756 LP: #360222 (Hopefully).

 -- Bhavani Shankar <email address hidden> Sat, 13 Jun 2009 18:02:40 +0530

Changed in mplayerplug-in (Ubuntu):
status: Triaged → Fix Released
JDHatman (jason-hatman) wrote :

Thank you cholocateboy!!

I've been trying to remedy the firefox/mplayer issue for a day now. Thank you for a solution that actually worked!

Jason Hatman

John Rose (johnaaronrose) wrote :

This bug still applies in Lucid.

Changed in mplayer (Mandriva):
importance: Unknown → Critical
Changed in mplayer (Mandriva):
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.