Apple movie trailers that require Quicktime 7 won't play

Bug #239506 reported by Michael Jeanson
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mplayerplug-in (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mozilla-mplayer

This bug is present in Hardy mozilla-mplayer 3.50-1ubuntu2

New movie trailers on the Apple website that require Quicktime 7 won't play as mozilla-mplayer advertises it self as "6.0 / 7".

You can reproduce this bug with this trailer : http://www.apple.com/trailers/paramount/indianajonesandthekingdomofthecrystalskull/medium_t3.html

It's already fixed in mplayer cvs.

A quick oneliner patch to fix this :
---
diff -urP mplayerplug-in.orig/Source/plugin-setup.cpp
mplayerplug-in/Source/plugin-setup.cpp
--- mplayerplug-in.orig/Source/plugin-setup.cpp 2007-12-01
18:23:04.000000000 -0500
+++ mplayerplug-in/Source/plugin-setup.cpp 2008-06-12
09:42:07.000000000 -0400
@@ -461,7 +461,7 @@
#endif

#ifdef QT
- *((const char **) value) = "QuickTime Plug-in 6.0 / 7";
+ *((const char **) value) = "QuickTime Plug-in 7.0";
#endif

#ifdef RM

Original bug report : https://sourceforge.net/tracker/?func=detail&atid=530623&aid=1992021&group_id=71239

Revision history for this message
chocolateboy (chocolateboy) wrote :

Confirmed on Swiftweasel 3.0 and Firefox 3.0.

Changed in mplayerplug-in:
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayerplug-in - 3.55-2ubuntu1

---------------
mplayerplug-in (3.55-2ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes: LP: #386705
    - debian/control:
      + add Xb-Npp-xxx tags accordingly to "firefox distro add-on support"
        spec.
      + replace build-depends on iceape-dev with libxul-dev.
      + replace iceweasel with firefox-3.0 | xulrunner.
      + replace iceape-browser with seamonkey-browser.
      + add alternative depends on mplayer-nogui (>= 1.0~rc2).
      + tighten mplayer dependency to (>= 1.0~rc2).
    - debian/mozilla-mplayer.links:
      + add firefox and xulrunner symlinks.
  * Fixes: LP: #239506 LP: #376932 LP: #360756 LP: #360222 (Hopefully).

 -- Bhavani Shankar <email address hidden> Sat, 13 Jun 2009 18:02:40 +0530

Changed in mplayerplug-in (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers