In Hardy, mozilla-mplayer depends on firefox-3.0 - does not accept firefox-2

Bug #228044 reported by elyon225
20
Affects Status Importance Assigned to Milestone
mplayerplug-in (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned
Intrepid
Medium
Unassigned

Bug Description

Binary package hint: mozilla-mplayer

Ubuntu Release: 8.04 (Hardy Heron)

When installing mozilla-mplayer, Firefox 3 is automatically selected and installed even though Firefox 2 is already installed. mozilla-mplayer should accept either as a dependancy (as mozilla-mplayer is compatible with both).

Revision history for this message
Alexander Sack (asac) wrote :

if our build works with ffox2 we should fix it ... further mplayer-plugin should be installed in /usr/lib/xulrunner-addons/plugins ... not sure if that is done atm

So the info we need is:

1. does the current mplayer plugin .so work with ffox 2
2. is it installed in /usr/lib/firefox-addons/plugins or /usr/lib/xulrunner-addons/plugins

Changed in mplayerplug-in:
status: New → Incomplete
importance: Undecided → Medium
Revision history for this message
Alexander Sack (asac) wrote :

If we want to SRU, we want that upload to only tackle 1.

Revision history for this message
Cesare Tirabassi (norsetto) wrote :

Yes, the plugin is compatible with firefox-2. Debdiff for hardy-proposed is attached.

Changed in mplayerplug-in:
status: Incomplete → Fix Committed
importance: Undecided → Medium
Revision history for this message
Cesare Tirabassi (norsetto) wrote :

1. firefox 2 users in hardy are "obliged" by the current mozilla-mplayer package to download firefox 3
2. The bug has been fixed in intrepid by changing the required dependency from the firefox metapackage to the explicit firefox-3.0 | firefox-2 binaries
3. Patch for hardy is attached
4. The bug can be reproduced by removing firefox 3 and installing firefox 2 and then by installing mozilla-mplayer
5. There is no regression potential, appropriate symlinks are already in place since the package was migrated to firefox 3 just recently

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayerplug-in - 3.50-1ubuntu3

---------------
mplayerplug-in (3.50-1ubuntu3) intrepid; urgency=low

  * Add support for Firefox 2 (LP: #228044):
    - debian/control:
      change Depends from firefox to firefox-3.0 | firefox-2
    - mozilla-mplayer.links:
      already contains symlinks in /usr/lib/firefox/plugins

 -- Cesare Tirabassi <email address hidden> Thu, 08 May 2008 13:37:30 +0200

Changed in mplayerplug-in:
status: Fix Committed → Fix Released
Revision history for this message
LaserJock (laserjock) wrote :

SRU ack'd, Please upload to hardy-proposed and arrange testing.

Changed in mplayerplug-in:
status: New → Confirmed
Revision history for this message
Jonathan Riddell (jr) wrote :

accepted into hardy-proposed, please test.

Revision history for this message
Cesare Tirabassi (norsetto) wrote :

To have this available in hardy-updates, we need your help in testing it.
If you would like to help, please add the following line to /etc/apt/sources.list:

  deb http://archive.ubuntu.com/ubuntu/ hardy-proposed universe

Then update and install (or upgrade) mozilla-mplayer with your preferred package manager.
Please report test results here.

The TEST CASE is very simple: If you remove firefox 3 and install firefox 2 and then try installing mozilla-mplayer, this will attempt to re-install firefox 3. With the package in hardy-proposed the installation will instead proceed without firefox 3 being required.
You can also help to test with firefox 3 to check that there is no regression. Just install or upgrade the package in hardy-proposed and check that the installation is ok and the plugin can be launched.

Many thanks in advance for your help!

Revision history for this message
xebian (jack-ammo1) wrote :

Jonathan Riddell, Pls don't forget konqueror-kde4. I posted a bug #230585 regarding this omission.

Revision history for this message
elyon225 (elyon225-public) wrote :

The package in -proposed installed flawlessly for Firefox 2 for me. I recommend adding to hardy-updates.

Revision history for this message
Cesare Tirabassi (norsetto) wrote :

We need another positive test report for this to make its way to hardy-updates. Please, anyone that can test this, do so and report here.

Revision history for this message
xebian (jack-ammo1) wrote :

It did not work for me. I only have konqueror-kde4 as my web browser. So as not to do it all over again, I strongly recommend adding konqueror-kde4 as one of the depends not just konqueror.

Revision history for this message
Nythain (nythain) wrote :

any trick to get the proposed repo to work... apt-get and synaptic still want to install from the regular repo... i would love to give that one more confirmation that it works so no one else has to go through all this

Revision history for this message
Nythain (nythain) wrote :

ok, got it... didnt realize i had to check the repo in the "update" section of synaptic... install went flawless and its runnin pretty excellent here in Firefox 2, no ff3 needed... thanks for your hard work

Revision history for this message
Cesare Tirabassi (norsetto) wrote :

Thanks to all for testing. Since we have the required quorum I'm subscribing archive to have this moved to hardy-updates.

Revision history for this message
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in mplayerplug-in:
status: Confirmed → Fix Released
Revision history for this message
Ing0R (ing0r) wrote :

mozilla-mplayer in karmic should have an alternative dependance entry for firefox-3.5.
Even better a generalized it could depend on a generalized firefox package, whihch every version of firefox could provide.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers