mplayer crashes with 32-bit cpu but not 64-bit cpu

Bug #987734 reported by sudodus on 2012-04-24
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
mplayer2 (Ubuntu)
Undecided
Unassigned

Bug Description

I am testing Lubuntu 12.04 RC in an IBM Thinkpad T41 without pae but with sse2 and a Dell Dimension 4600 with pae and sse2. The default video player Mplayer crashes in these machines, but it works *very well* in my 64-bit machines. None of these computers have sse3 (but all have sse2).

The video clip was made with my video camera and was processed with ffmpeg. It contains no sub-titles, only audio and video streams. VLC can play the file in all these computers.

The reason why I file this bug is that I am do not think it is the same as the one reporting about lack of sse3, and I wanted to show the output to the terminal window as it is now (it has changed during the beta testing phase, probably because of some debugging effort).
--
$ mplayer 00007_540-50p.mp4
MPlayer2 UNKNOWN (C) 2000-2011 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing 00007_540-50p.mp4.
Detected file format: QuickTime/MPEG-4/Motion JPEG 2000 format (libavformat)
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang und
VIDEO: [H264] 960x540 24bpp 50.000 fps 2038.9 kbps (248.9 kbyte/s)
Clip info:
 major_brand: isom
 minor_version: 512
 compatible_brands: isomiso2avc1mp41
 creation_time: 1970-01-01 00:00:00
 encoder: Lavf52.64.2
Load subtitles in .

MPlayer interrupted by signal 4 in module: read_subtitles_file
- MPlayer crashed by an 'Illegal Instruction'.
  It usually happens when you run it on a CPU different than the one it was
  compiled/optimized for.
  Verify this!
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
$

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: mplayer2 2.0-426-gc32b3ed-2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic i686
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
CasperVersion: 1.315
Date: Tue Apr 24 11:29:04 2012
LiveMediaBuild: Lubuntu 12.04 "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: mplayer2
UpgradeStatus: No upgrade log present (probably fresh install)

sudodus (nio-wiklund) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/987734

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mplayer2 (Ubuntu):
status: New → Confirmed
Julien Lavergne (gilir) wrote :

I made an update to mplayer2 package, trying to address the issue. It's available in my PPA https://launchpad.net/~gilir/+archive/updates, only for Quantal (12.10). Can someone test this package to see if the issue is still here ? Thanks.

On 2012-10-16 22:54, Julien Lavergne wrote:
> I made an update to mplayer2 package, trying to address the issue. It's
> available in my PPA https://launchpad.net/~gilir/+archive/updates, only
> for Quantal (12.10). Can someone test this package to see if the issue
> is still here ? Thanks.
>
I updated my Precise system from the standard repos a few minutes ago,
and the mplayer2 bug is still there.

I have not yet tested it in Quantal using your ppa.

By the way, will Quantal work with non-pae kernels? I have two computers
where mplayer2 does not work, one is an IBM Thinkpad without pae and one
Dell pentium 4 with pae.

Best regards
Nio

-------- Original Message --------
Subject: Re: [Bug 987734] Re: mplayer crashes with 32-bit cpu but not
64-bit cpu
Date: Wed, 17 Oct 2012 09:19:58 +0200
From: Nio Wiklund <email address hidden>
To: Bug 987734 <email address hidden>

On 2012-10-16 22:54, Julien Lavergne wrote:
> I made an update to mplayer2 package, trying to address the issue. It's
> available in my PPA https://launchpad.net/~gilir/+archive/updates, only
> for Quantal (12.10). Can someone test this package to see if the issue
> is still here ? Thanks.
>
I updated my Precise system from the standard repos a few minutes ago,
and the mplayer2 bug is still there.

I have not yet tested it in Quantal using your ppa.

Yippee, it works, Julien!

-------- Original Message --------
Subject: Fwd: Re: [Bug 987734] Re: mplayer crashes with 32-bit cpu but
not 64-bit cpu
Date: Wed, 17 Oct 2012 09:29:28 +0200
From: Nio Wiklund <email address hidden>
To: Bug 987734 <email address hidden>

-------- Original Message --------
Subject: Re: [Bug 987734] Re: mplayer crashes with 32-bit cpu but not
64-bit cpu
Date: Wed, 17 Oct 2012 09:19:58 +0200
From: Nio Wiklund <email address hidden>
To: Bug 987734 <email address hidden>

On 2012-10-16 22:54, Julien Lavergne wrote:
> I made an update to mplayer2 package, trying to address the issue. It's
> available in my PPA https://launchpad.net/~gilir/+archive/updates, only
> for Quantal (12.10). Can someone test this package to see if the issue
> is still here ? Thanks.
>
I updated my Precise system from the standard repos a few minutes ago,
and the mplayer2 bug is still there.

I have not yet tested it in Quantal using your ppa.
--------
By the way, will Quantal work with non-pae kernels? I have two computers
where mplayer2 does not work, one is an IBM Thinkpad without pae and one
Dell pentium 4 with pae.

Best regards
Nio
--------
Yippee, it works, Julien!

Now I have downloaded the daily build Lubuntu Quantal (Oct 17), made a
persistent USB drive with Unetbootin and installed your version of
mplayer2 from launchpad/gilir. It works in my Dell Dimension 4600
(pentium 4 with pae), where mplayer2 has never worked for me in Precise.
I have not done any thorough testing yet, only tested with an mp4 file
transformed by ffmpeg from an MTS file from my video camera.

Best regards
Nio alias sudodus

Lubuntu Quantal needs pae

-------- Original Message --------
Subject: Fwd: Fwd: Re: [Bug 987734] Re: mplayer crashes with 32-bit cpu
but not 64-bit cpu
Date: Wed, 17 Oct 2012 18:33:04 +0200
From: Nio Wiklund <email address hidden>
To: Bug 987734 <email address hidden>
CC: <email address hidden>

Yippee, it works, Julien!

-------- Original Message --------
Subject: Fwd: Re: [Bug 987734] Re: mplayer crashes with 32-bit cpu but
not 64-bit cpu
Date: Wed, 17 Oct 2012 09:29:28 +0200
From: Nio Wiklund <email address hidden>
To: Bug 987734 <email address hidden>

-------- Original Message --------
Subject: Re: [Bug 987734] Re: mplayer crashes with 32-bit cpu but not
64-bit cpu
Date: Wed, 17 Oct 2012 09:19:58 +0200
From: Nio Wiklund <email address hidden>
To: Bug 987734 <email address hidden>

On 2012-10-16 22:54, Julien Lavergne wrote:
> I made an update to mplayer2 package, trying to address the issue. It's
> available in my PPA https://launchpad.net/~gilir/+archive/updates, only
> for Quantal (12.10). Can someone test this package to see if the issue
> is still here ? Thanks.
>
I updated my Precise system from the standard repos a few minutes ago,
and the mplayer2 bug is still there.

I have not yet tested it in Quantal using your ppa.
--------
By the way, will Quantal work with non-pae kernels? I have two computers
where mplayer2 does not work, one is an IBM Thinkpad without pae and one
Dell pentium 4 with pae.

Best regards
Nio
--------
Yippee, it works, Julien!

Now I have downloaded the daily build Lubuntu Quantal (Oct 17), made a
persistent USB drive with Unetbootin and installed your version of
mplayer2 from launchpad/gilir. It works in my Dell Dimension 4600
(pentium 4 with pae), where mplayer2 has never worked for me in Precise.
I have not done any thorough testing yet, only tested with an mp4 file
transformed by ffmpeg from an MTS file from my video camera.

Best regards
Nio alias sudodus
--------
This morning I checked and yes, Lubuntu Quantal needs pae, so it does
not work with any of the old IBM Thinkpads without pae.

Is there any chance that the update to mplayer2 package might work with
Precise? Now or in the future? After all, Precise has LTS (at least for
Ubuntu and Xubuntu).

Best regards
Nio

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayer2 - 2.0-554-gf63dbad-1ubuntu1

---------------
mplayer2 (2.0-554-gf63dbad-1ubuntu1) raring; urgency=low

  * Enable CPU autodetection on architectures that support it,
    Closes: #627197,
    LP: #934774, #928793, #858226, #974125, #974774, #987734, #1014279
 -- Julien Lavergne <email address hidden> Mon, 10 Dec 2012 20:35:19 +0100

Changed in mplayer2 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers