i386 version of mplayer2 is compiled to require SSE2 support

Bug #858226 reported by Zeev Tarantov on 2011-09-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mplayer2 (Ubuntu)
Undecided
Unassigned

Bug Description

When parsing my config file on an i686 CPU which does not support SSE2 (namely a Pentium3 with SSE support), mplayer2 2.0-134-g84d8671-2build1 crashes with an "Illegal instruction" cvttsd2si. Output of gdb disassembly is attached.

Zeev Tarantov (zeev-tarantov) wrote :
Zeev Tarantov (zeev-tarantov) wrote :

When the package is recompiled from source package without changes, it works because GCC 4.6.1 on i386 generates x87 instructions instead of SSE2 instructions. In general, GCC 4.6 defaults to "-march=native", so if the 32bit binary was generated on a 64bit system using "gcc -m32" without specifying "-march", it defaulted to compiling a binary for a core2/athlon64 in 32bit compatibility mode, not for a 32bit only CPU which does not support SSE2. A 32bit-only Pentium4 would run such a binary, but a Pentium3 won't. I suggest specifying -march=i686 and -mfpmath=387 to disable generation of SSE instructions. Performance critical code that uses hand-coded SSE (asm or intrinsics) uses run time cpu detection anyway and should be compiled with separate flags before being linked into a "i386" binary.

According to: https://help.ubuntu.com/11.04/installation-guide/i386/hardware-supported.html , i686 with cmov is now required, so march should be set for that. I could not find the same page for ubuntu 11.10, but I hope it's the same.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mplayer2 (Ubuntu):
status: New → Confirmed
Julien Lavergne (gilir) wrote :

I made an update to mplayer2 package, trying to address the issue. It's available in my PPA https://launchpad.net/~gilir/+archive/updates, only for Quantal (12.10). Can someone test this package to see if the issue is still here ? Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayer2 - 2.0-554-gf63dbad-1ubuntu1

---------------
mplayer2 (2.0-554-gf63dbad-1ubuntu1) raring; urgency=low

  * Enable CPU autodetection on architectures that support it,
    Closes: #627197,
    LP: #934774, #928793, #858226, #974125, #974774, #987734, #1014279
 -- Julien Lavergne <email address hidden> Mon, 10 Dec 2012 20:35:19 +0100

Changed in mplayer2 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments