Impossible to play a video with gnome-mplayer

Bug #1014279 reported by Pierre Gobin on 2012-06-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mplayer2 (Ubuntu)
Undecided
Felix Scheuerl

Bug Description

On Lubuntu 12.04, it is impossible to play a video with gnome-player. When I try to open an .avi file with it, gnome-mplayer displays "loading", and "stopped", without play the video.

I tested it on three computers with Lubuntu 12.04. There is one which works fine, it uses nvidia card. On the two computers which don't work, they use intel drivers. And on these two computers, VLC plays .avi files without problem.

Gnome-mplayer worked fine on Lubuntu 11.10.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-mplayer 1.0.5-1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
Date: Sun Jun 17 13:58:11 2012
InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-mplayer
UpgradeStatus: No upgrade log present (probably fresh install)

Pierre Gobin (pierre-gobin) wrote :

i have this problem occasionally, restarting mplayer-gnome usually fixes it

On Sun, Jun 17, 2012 at 8:08 AM, Pierre Gobin
<email address hidden> wrote:
> --
> You received this bug notification because you are a member of Lubuntu
> Packages Team, which is subscribed to gnome-mplayer in Ubuntu.
> https://bugs.launchpad.net/bugs/1014279
>
> Title:
>  Impossible to play a video with gnome-mplayer
>
> Status in “gnome-mplayer” package in Ubuntu:
>  New
>
> Bug description:
>  On Lubuntu 12.04, it is impossible to play a video with gnome-player.
>  When I try to open an .avi file with it, gnome-mplayer displays
>  "loading", and "stopped", without play the video.
>
>  I tested it on three computers with Lubuntu 12.04. There is one which
>  works fine, it uses nvidia card. On the two computers which don't
>  work, they use intel drivers. And on these two computers, VLC plays
>  .avi files without problem.
>
>  Gnome-mplayer worked fine on Lubuntu 11.10.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 12.04
>  Package: gnome-mplayer 1.0.5-1
>  ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
>  Uname: Linux 3.2.0-24-generic i686
>  ApportVersion: 2.0.1-0ubuntu8
>  Architecture: i386
>  Date: Sun Jun 17 13:58:11 2012
>  InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Release i386 (20120423)
>  ProcEnviron:
>   TERM=xterm
>   PATH=(custom, no user)
>   LANG=fr_FR.UTF-8
>   SHELL=/bin/bash
>  SourcePackage: gnome-mplayer
>  UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/gnome-mplayer/+bug/1014279/+subscriptions

Pierre Gobin (pierre-gobin) wrote :

Thanks for your help. But on my computers, I have this bug permanently.

Sebastian Ramacher (s-ramacher) wrote :

What's the output of

  gnome-mplayer -v

when you try to play the file?

Pierre Gobin (pierre-gobin) wrote :

Output of "gnome-mplayer -v" :

GNOME MPlayer v1.0.5
gmtk v1.0.5
Running with GIO support
Using audio device: Système sonore par défaut
The volume on 'Système sonore par défaut' is 1,000000
Using match: type='signal',interface='com.gnome.mplayer'
Using match: type='signal',interface='org.gnome.SettingsDaemon'
Using match: type='signal',interface='org.gnome.SettingsDaemon.MediaKeys'
Proxy connections and Command connected
opening playlist
playlist detection = 0
adding file:///home/pierre/Vid%C3%A9os/Chuck/Saison%201/01%20-%20Espion%20malgr%C3%A9%20lui.avi to playlist (cancel = 0)
getting file metadata for /home/pierre/Vidéos/Chuck/Saison 1/01 - Espion malgré lui.avi
mplayer -vo null -ao null -nomsgcolor -nomsgmodule -frames 0 -noidx -identify -nocache -noidle /home/pierre/Vidéos/Chuck/Saison 1/01 - Espion malgré lui.avi
playing - file:///home/pierre/Vid%C3%A9os/Chuck/Saison%201/01%20-%20Espion%20malgr%C3%A9%20lui.avi
is playlist 0
Looking for cover art at /home/pierre/Vidéos/Chuck/Saison 1/cover.jpg
Looking for cover art at /home/pierre/Vidéos/Chuck/Saison 1/Folder.jpg
WARNING: gnome-keyring:: couldn't connect to: /tmp/keyring-Xanuj3/pkcs11: Aucun fichier ou dossier de ce type
setting up mplayer
mplayer -vo x11 -vf-add screenshot -channels 2 -af-add export=/tmp/mplayer-af_exportbsiirv:512 -quiet -slave -noidle -noconsolecontrols -nostop-xscreensaver -identify -volume 100 -softvol -msglevel all=5 -osdlevel 0 -delay 0,000000 -subdelay 0,000000 -subpos 0 -sub-fuzziness 0 -wid 0x2400028 -brightness 0 -contrast 0 -hue 0 -saturation 0 -alang Zuni,zun -slang Zuni,zun -nomsgcolor -nomsgmodule -nokeepaspect -ass -embeddedfonts -ass-font-scale 1,00 -ass-color ffffff00 /home/pierre/Vidéos/Chuck/Saison 1/01 - Espion malgré lui.avi
in media state change with state = 0

Sebastian Ramacher (s-ramacher) wrote :

On 21/06/12 12:39, Pierre Gobin wrote:
> setting up mplayer
> mplayer -vo x11 -vf-add screenshot -channels 2 -af-add export=/tmp/mplayer-af_exportbsiirv:512 -quiet -slave -noidle -noconsolecontrols -nostop-xscreensaver -identify -volume 100 -softvol -msglevel all=5 -osdlevel 0 -delay 0,000000 -subdelay 0,000000 -subpos 0 -sub-fuzziness 0 -wid 0x2400028 -brightness 0 -contrast 0 -hue 0 -saturation 0 -alang Zuni,zun -slang Zuni,zun -nomsgcolor -nomsgmodule -nokeepaspect -ass -embeddedfonts -ass-font-scale 1,00 -ass-color ffffff00 /home/pierre/Vidéos/Chuck/Saison 1/01 - Espion malgré lui.avi
> in media state change with state = 0

hmm, no mplayer output at all? This is weird.

Could you please try to run the mplayer command without the -ad-add export=...
-quiet -slave part?

Are you using mplayer or mplayer2? Could you also try it with the other one?
--
Sebastian Ramacher

Pierre Gobin (pierre-gobin) wrote :

> Could you please try to run the mplayer command without the -ad-add export=...-quiet -slave part?

Can you explain what you want me to do exactly ?

> Are you using mplayer or mplayer2? Could you also try it with the other one?

I am using mplayer2. I uninstalled it and tried with mplayer, it works.

Sebastian Ramacher (s-ramacher) wrote :

On 02/07/12 13:16, Pierre Gobin wrote:
>> Could you please try to run the mplayer command without the -ad-add
> export=...-quiet -slave part?
>
> Can you explain what you want me to do exactly ?
>
>> Are you using mplayer or mplayer2? Could you also try it with the
> other one?

I wanted you to run the following command (with mplayer2 installed):

mplayer -vo x11 -vf-add screenshot -channels 2 -noidle -noconsolecontrols
-nostop-xscreensaver -identify -volume 100 -softvol -msglevel all=5 -osdlevel 0
-delay 0,000000 -subdelay 0,000000 -subpos 0 -sub-fuzziness 0 -brightness 0
-contrast 0 -hue 0 -saturation 0 -alang Zuni,zun -slang Zuni,zun -nomsgcolor
-nomsgmodule -nokeepaspect -ass -embeddedfonts -ass-font-scale 1,00 -ass-color
ffffff00 /home/pierre/Vidéos/Chuck/Saison 1/01 - Espion malgré lui.avi

Could you please attach its output?

> I am using mplayer2. I uninstalled it and tried with mplayer, it works.

Okay, so this might be a mplayer2 issue after all.
--
Sebastian Ramacher

Pierre Gobin (pierre-gobin) wrote :

Okay, I tried to run your command, but the terminal answers "Instruction not allowed (core dumped)". I tried with sudo, and I had a crash.

So this looks like a mplayer2 issue. Reassigning.

affects: gnome-mplayer (Ubuntu) → mplayer2 (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mplayer2 (Ubuntu):
status: New → Confirmed
Luigi Calderone (lugligino) wrote :

I have a laptop Dell D600 with lubuntu 12.04 and I have the same problem (player stop). I have only to check if it's installed Mplayer or mplayer2.

Julien Lavergne (gilir) wrote :

Looks like the same than bug 858226 and many others reports on mplayer2. There is a fix on bug 858226, could you test it and report back if it's working or not ? Thanks.

erichgamba (erichgamba) wrote :

I had this problem too in Ubuntu 12.04. So, I removed mplayer2 and installed mplayer:

sudo apt-get purge mplayer2
sudo apt-get install gecko-mediaplayer

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayer2 - 2.0-554-gf63dbad-1ubuntu1

---------------
mplayer2 (2.0-554-gf63dbad-1ubuntu1) raring; urgency=low

  * Enable CPU autodetection on architectures that support it,
    Closes: #627197,
    LP: #934774, #928793, #858226, #974125, #974774, #987734, #1014279
 -- Julien Lavergne <email address hidden> Mon, 10 Dec 2012 20:35:19 +0100

Changed in mplayer2 (Ubuntu):
status: Confirmed → Fix Released
Changed in mplayer2 (Ubuntu):
assignee: nobody → Felix Scheuerl (felix-scheuerl)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers