mplayer: Symbol `ff_codec_bmp_tags' has different size in shared object, consider re-linking

Bug #878815 reported by Uqbar
106
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Medibuntu
Fix Released
Undecided
Unassigned
mplayer (Ubuntu)
Undecided
Unassigned

Bug Description

It seems it works just fine. But that's a suggestion: consider relinking!

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: mplayer 2:1.0~rc4.dfsg1+svn33713-1+medibuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19~ppa1-generic-pae-ck 3.0.4-ck1
Uname: Linux 3.0.0-12-generic-pae-ck i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
CrashDB: medibuntu
Date: Thu Oct 20 14:29:13 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: mplayer
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (5 days ago)

Revision history for this message
Uqbar (uqbar) wrote :
ilf (ilf)
Changed in medibuntu:
status: New → Confirmed
Revision history for this message
Gauvain Pocentek (gpocentek) wrote :

The rebuilt package is in the oneiric-staging, please give it a tryto confirm that the problem is gone.

Thanks.

Changed in medibuntu:
status: Confirmed → Fix Committed
Revision history for this message
ilf (ilf) wrote :

This is an mplayer package problem, not a Medibuntu problem.
oneiric-staging seems to be Medibuntu only.

affects: medibuntu → mplayer (Ubuntu)
Changed in mplayer (Ubuntu):
status: Fix Committed → New
Changed in medibuntu:
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mplayer (Ubuntu):
status: New → Confirmed
Revision history for this message
agent 8131 (agent-8131) wrote :

On my HTPC this bug seems to completely break smplayer.

Changed in medibuntu:
status: Fix Committed → Fix Released
Revision history for this message
Reinhard Tartler (siretart) wrote :

mplayer in ubuntu is not affected by this issue because it has been recompiled a long time ago.

Please consider reporting this bug to medibuntu, which is the actual supplier of the package mentioned by the original reporter.

Changed in mplayer (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Gauvain Pocentek (gpocentek) wrote :

Hi Reinhard,

mplayer in ubuntu is affected by this issue:

gauvain@jack:~$ dpkg -l mplayer | grep ^ii
ii mplayer 2:1.0~rc4.dfsg1+svn33713-1 movie player for Unix-like systems
gauvain@jack:~$ mplayer --version
mplayer: Symbol `ff_codec_bmp_tags' has different size in shared object, consider re-linking
Unknown option on the command line: --version
Error parsing option on the command line: --version
MPlayer SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team

The mplayer package comes from the universe repository.

Revision history for this message
Reinhard Tartler (siretart) wrote :

I thought that this is a purely cosmetic issue and a recompilation would
fix this, but it seems it doesn't.

clearly, this needs more investigaton then.

Changed in mplayer (Ubuntu):
status: Fix Released → Incomplete
Revision history for this message
SamiR (sami-m-rantala) wrote :

In my case mplayer no longer works at all but crashes to a nasty segmentation fault:

sami@sami-ubuntu:~$ mencoder -noautosub -oac copy -aid 4352 -ovc lavc -of mpeg -mpegopts format=dvd:tsaf -ofps 25 -vf scale=720:576,harddup -lavcopts threads=4:vcodec=mpeg2video:trell:mbd=2:sc_threshold=1000000000:cgop:vstrict=0:vrc_maxrate=8500:vrc_buf_size=1835:vbitrate=5001:keyint=12:aspect=16/9:vpass=1:vbitrate=5630:vcodec=mpeg2video:vrc_maxrate=9800:keyint=15:aspect=16/9:threads=4:vstrict=0:mbd=2:precmp=2:subcmp=2:cmp=2:dia=-10:predia=-10:cbp:mv0:vqmin=1:lmin=1:dc=10 -passlogfile /home/sami/movie/movie.log -o /home/sami/movie/movie_01_01.mpg /home/sami/video/sony_pmb/2011-11-19/20111009173759.m2ts -demuxer lavf -ofps 25 -fps 50 -x264encopts subq=6:partitions=all:8x8dct:me=umh:frameref=5:bframes=3:b_pyramid=normal:weight_b
mencoder: Symbol `ff_codec_bmp_tags' has different size in shared object, consider re-linking
MEncoder SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team
success: format: 0 data: 0x0 - 0x74e8000
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (ac3), -aid 0
[lavf] stream 2: subtitle (pgssub), -sid 0
LAVF: Program 1
VIDEO: [H264] 1920x1080 0bpp 50.000 fps 0.0 kbps ( 0.0 kbyte/s)
Segmentation fault

Could the re-linking suggestion and the segmentation fault be related?

Revision history for this message
SamiR (sami-m-rantala) wrote :

Sorry, meant to say that *mencoder* no longer works at all...

Revision history for this message
FreeMinded (pascal-planetmages) wrote :

I have this bug, too. In Kubuntu 11.10-64. Is there a recommended work around?

Revision history for this message
FreeMinded (pascal-planetmages) wrote :

Manually installing the mplayer package from Medibuntu did the trick for me.
http://packages.medibuntu.org/oneiric/mplayer.html

Revision history for this message
vldmrrr (vldmrrr) wrote :

Manually installing the mplayer package from Medibuntu did not help me - still get segmentation fault, although the original message (Symbol `ff_codec_bmp_tags' has different size in shared object, consider re-linking) has gone.

Revision history for this message
Georg Sauthoff (g-sauthoff) wrote :

Get this message still with _Ubuntu_ 11.10:

mplayer: Symbol `ff_codec_bmp_tags' has different size in shared object, consider re-linking
MPlayer SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team

$ dpkg -l mplayer
ii mplayer 2:1.0~rc4.dfsg movie player for Unix-like systems

This does not seem to have significant negative effects, though - mplayer plays all kinds of files just fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers