Distorted MP3 sound

Bug #85751 reported by Sam Bashton on 2007-02-17
110
Affects Status Importance Assigned to Milestone
MPlayer
Fix Released
Undecided
Unassigned
mplayer (Ubuntu)
High
Mario Limonciello

Bug Description

Binary package hint: mplayer

When attempting to playback files with MP3 audio in version 1.0~rc1-0ubuntu3, sound is extremely distorted.

Sound output is fine in previous version (0.99+1.0pre8-0ubuntu8).

Related branches

description: updated
wannes (wannes) wrote :

I can confirm this.

Changed in mplayer:
status: Unconfirmed → Confirmed
Emanuel Steen (kozz) wrote :

Having the same problem in mplayer 1.0~rc1-0ubuntu3.

Seems to be a problem with mp3lib since when adding the option "-ac ffmp3" the sound is correct but when using "-ac mp3" the sound becomes distorted (which is also the default).

jeroenl (jeroenl) wrote :

I can confirm this also. Mencoder is also affected. A workaround is to use -afm ffmpeg, but this does not work correctly with mencoder. Because mencoder is also affected, all utilities that depend on mencoder, like DeVeDe cannot be used.

jeroenl (jeroenl) wrote :

I've compiled mplayer from svn and copied the mplayer binary file to /usr/bin/player; thereby overwriting the binary from the feisty repos. All works fine now, incl mencoder (note: I didn't copy the mencoder binary).

Conclusion is that the mplayer binary has an bug, properly related to mp3lib.

jeroenl (jeroenl) wrote :

corr.: /usr/bin/player = /usr/bin/mplayer

TiagoCruz (tiagocruz) wrote :

Is not only for MP3, this problem affect movies .avi and .rmvb too.

This workaround works very well:
$ sudo echo "afm=ffmpeg" >> -afm ffmpeg

Ulf Karlsson (ohmega) wrote :

The workaround in the previous comment is incorrect.

Try:

$ echo "afm=ffmpeg" >> ~/.mplayer/config

TiagoCruz (tiagocruz) wrote :

Yeah Ulf, you are correctly, sorry about this...

In the true, I prefer do one global configuration, like this:
$ sudo echo "afm=ffmpeg" >> /etc/mplayer/mplayer.conf

And, speaking in "how make mplayer more friendly" maybe we should decrease the size of subtitle, because the default if very big :-)

$ sudo echo "subfont-text-scale=3" >> /etc/mplayer/mplayer.conf

Thanks a lot!

yaztromo (tromo) wrote :

This is only working partially. There are still some files which worked okay in dapper and now sound like they are being fast fowarded at 1000x in feisty. For the most part the fix is good but it isn't a final solution for me.

VincentRC (vreneco1) wrote :

I have the same problem (Feisty upgraded from Edgy). I have launched a video file from command line and this is what I get :

Playing XXXXXX.avi
AVI file format detected.
VIDEO: [XVID] 608x336 24bpp 23.976 fps 1022.7 kbps (124.8 kbyte/s)
Clip info:
 Software: Nandub v1.0rc2
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: No such file or directory.
[VO_3DFX] Unable to open /dev/3dfx.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 608 x 336 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.81:1 - prescaling to correct movie aspect.
VO: [xv] 608x336 => 608x336 Planar YV12
mpg123: Can't rewind stream by 8 bits!01 41/ 41 13% 4% 0.8% 1 0
mpg123: Can't rewind stream by 26 bits!2 42/ 42 13% 4% 0.8% 1 0
mpg123: Can't rewind stream by 22 bits!4 43/ 43 13% 4% 0.8% 1 0
mpg123: Can't rewind stream by 75 bits!8 44/ 44 13% 4% 0.8% 1 0
mpg123: Can't rewind stream by 29 bits!2 53/ 53 11% 3% 0.8% 1 0
mpg123: Can't rewind stream by 25 bits!0 72/ 72 9% 2% 0.8% 1 0
mpg123: Can't rewind stream by 59 bits!8 77/ 77 9% 2% 0.8% 1 0
mpg123: Can't rewind stream by 13 bits!3 80/ 80 9% 2% 0.8% 1 0
mpg123: Can't rewind stream by 21 bits!2 95/ 95 8% 2% 0.7% 1 0
mpg123: Can't rewind stream by 37 bits!0 101/101 8% 2% 0.7% 1 0
mpg123: Can't rewind stream by 23 bits!4 103/103 8% 1% 0.7% 1 0
mpg123: Can't rewind stream by 14 bits!3 107/107 8% 1% 0.7% 1 0
mpg123: Can't rewind stream by 23 bits!4 111/111 8% 1% 0.7% 1 0
mpg123: Can't rewind stream by 22 bits!0 113/113 8% 1% 0.7% 1 0
mpg123: Can't rewind stream by 22 bits!1 116/116 8% 1% 0.7% 1 0

Changed in mplayer:
assignee: nobody → nafallo
importance: Undecided → High
status: Confirmed → Fix Committed
Nafallo Bjälevik (nafallo) wrote :

mplayer (2:1.0~rc1-0ubuntu6) feisty; urgency=low

  * debian/rules:
    - Disable mp3lib and enable mad (LP: #85751).
  * debian/control:
    - Add libmad0-dev to Build-Deps.

Changed in mplayer:
status: Fix Committed → Fix Released
Nafallo Bjälevik (nafallo) wrote :

Please reopen this bug if the problem persists, and leave it assigned to me :-).

Phil Housley (undeconstructed) wrote :

This isn't fixed for me. Building the package suggests that configure runs with "--enable-mad --disable-mad". Just a typo maybe?

MadJo (mdejong) wrote :

For me the problem also persisted.
But after applying the workaround mentioned in this report, it worked again.

Christoph Roeder (brightdroid) wrote :

For me the isn't fixed too (mplayer-nogui 1.0~rc1-0ubuntu7) and the workaround mentioned doesn't help.

Nafallo Bjälevik (nafallo) wrote :

Phil, it's built with --enable-libmad --disable-mp3lib. Maybe you read it wrong?

MadJo, the "workaround" to use ffmpeg? Since mp3lib is disabled that should be the default now. Can you please remove the workaround and try it that's the case.

Christoph, could you follow up with output from playing a known-good .mp3 from the console please.

Thanks, /Nafallo

Olaf Maurer (gurke) wrote :

I just upgraded to 2:1.0~rc1-0ubuntu7.
Playing avi with mp3 and just mp3 works fine, but now mpeg1 is broken.

Looks like this:

Requested audio codec family [mp3] (afm=mp3lib) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[mp2 @ 0x892a858]incorrect frame size
AUDIO: 44100 Hz, 2 ch, s16le, 224.0 kbit/15.87% (ratio: 28000->176400)
Selected audio codec: [ffmp2] afm: ffmpeg (FFmpeg MPEG layer-1 and layer-2 audio decoder)
==========================================================================
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mp2 @ 0x892a858]Header missing skipping one byte.
[mp2 @ 0x892a858]Header missing skipping one byte.
[mp2 @ 0x892a858]Header missing skipping one byte.
[mp2 @ 0x892a858]Header missing skipping one byte.
[mp2 @ 0x892a858]Header missing skipping one byte.
[mp2 @ 0x892a858]Header missing skipping one byte.
[mp2 @ 0x892a858]Header missing skipping one byte.
[mp2 @ 0x892a858]Header missing skipping one byte.
[mp2 @ 0x892a858]Header missing skipping one byte.
...

and so on. Sound is extremely fast and distorted.
It works with "-ac mad".

kaiska (kaiska) wrote :

The problem persist here (mplayer-nogui 0.99+1.0pre8-0ubuntu8) but the workaround (add "afm=ffmpeg" in /etc/mplayer/mplayer.conf) do the trick.

hexion (hexium) wrote :

Today's upgrade 2:1.0~rc1-0ubuntu8 seems to have fixed the problem in my system

jeroenl (jeroenl) wrote :

I also updated to 1.0~rc1-0ubuntu8 today, but still this nasty bug is not solved.

Mplayer seems to work, but Mencoder still does not!

I have found a new workaround and that is to replace the Feisty binaries with the Edgy binaries (0.99+1.0pre8-0ubuntu8). That works great. Maybe someone else can also try this and than we can hopefully get this bug confirmed, before it is fixed.

jeroenl (jeroenl) wrote :

Please see both attachments from http://packages.ubuntu.com/edgy/

Jeroen

jeroenl (jeroenl) wrote :

This bug is still NOT solved, one day before the scheduled release date of Feisty. There is no fix released. Only mplayer ins working, but mencoder still gives the distorted sound. I still have to use the above workaround!

Changed in mplayer:
status: Fix Released → In Progress
status: In Progress → Confirmed

I'm currently using SVN version (April 14, 2007) and it works fine. I did a .deb package for people who uses DeVeDe. It's available at devede's homepage: http://www.rastersoft.com/programas/devede.html. It's a little ugly, because mplayer and mencoder are in the same package, but as a fast fix for people who needs it just now...

Michal Dekan (michal-dekan) wrote :

I got same horrible sound as wannes in first comment i used mplayer 2:1.0~rc1-0ubuntu9

Jonathan Cruz (drpfenderson) wrote :

I am having the same issue with mencode/mplayer. The .deb package from the Devede site does not work for me. Whenever I try to install Devede or k9copy (or anything else that uses those packages), it tries to uninstall the .deb versions and reinstall the Ubuntu (buggy) repo versions. Even if I install the CVS pakages through Synapic, it tries to remove them.

I had to compile Devede from source (and k9copy) to get them to work. But it would still be nice to be able to install them the normal way through the repositories.

Does anyone know when this is will be fixed in the official package for mplayer/mencoder?

Johnny Levai (digistyl3) wrote :

What I did was downloaded the mplayer cvs package from the Devede site. I extracted the files "mplayer" and "mencoder" from it, and replaced the ones in /usr/bin. It works. Thanks jeroenvrp for the hint.
Why not builg a new deb package from the latest mplayer and mencoder, upload it so we can test it, and if there are no regressions, it'll go to Feisty updates?

Johnny Levai wrote:
> Why not builg a new deb package from the latest mplayer and mencoder,
> upload it so we can test it, and if there are no regressions, it'll go
> to Feisty updates?

Um, how about no? That would be incredibly stupid, and I'd probably lose
my upload privileges if I tried it.

Johnny Levai (digistyl3) wrote :

Sorry for my incomplete sentence "upload it so we can test it". I didn't ment uploading to the Feisty repos, but somewhere so we can download it and test it. I don't know how does something get a newer vesion in the repos, but I saw something similar in the HPLIP Toolbox case: we had some bugs, so the maintainer got built a deb package from the new version, uploaded it to his own host or what was it, 12 users or so downloaded it, tested it, and reported any problems, or if it was working correctly. There were no regressions, and bugs were fixed in that release, so he made a report, and the HPLIP Toolbox was updated to the new version.

William Grant (wgrant) wrote :

Johnny Levai wrote:
> Sorry for my incomplete sentence "upload it so we can test it". I didn't
> ment uploading to the Feisty repos, but somewhere so we can download it
> and test it. I don't know how does something get a newer vesion in the
> repos, but I saw something similar in the HPLIP Toolbox case: we had
> some bugs, so the maintainer got built a deb package from the new
> version, uploaded it to his own host or what was it, 12 users or so
> downloaded it, tested it, and reported any problems, or if it was
> working correctly. There were no regressions, and bugs were fixed in
> that release, so he made a report, and the HPLIP Toolbox was updated to
> the new version.

Updates to stable releases are only done when the patch that fixed the
problem can be isolated. There's not the slightest chance that a new
upstream checkout would go anywhere near a stable release (other than
perhaps through backports).

jeroenl (jeroenl) wrote :

I don't agree. e.g. Complete new Firefox bugfix-versions (2.0.0.*) are released using the Ubuntu update mechanism. So I don't agree that this mplayer/mencoder-debacle cannot be resolved ASAP.

Yeuclid (cfraser) wrote :

As a very new Ubuntu user, I get the impression from all this that things are not as rosy as one might be led to believe. I thought the concept was collaboration and support. What I have seen with this saga is evidence of passing the buck and the sad "ignore it and it might go away" syndrome.

Why can't it just be fixed, or is the Mencoder support team just going to pretend that the problem doesn't exist?

I did think that this attempt with Ubuntu (my third) was going to be successful. Unfortunately it still seems to lag behind in multimedia support.

I will wait in hope

William Grant (wgrant) wrote :

jeroenvrp wrote:
> I don't agree. e.g. Complete new Firefox bugfix-versions (2.0.0.*) are
> released using the Ubuntu update mechanism. So I don't agree that this
> mplayer/mencoder-debacle cannot be resolved ASAP.

Bugfix-versions is the key here. An mplayer VCS checkout is NOT a bugfix
release, it would contain an enormous amount of completely unrelated new
code. This is not going to be fixed in Feisty unless somebody can
isolate the patch that fixes it. Upgrading to a new upstream checkout
has enormous potential for regressions, which we can't effectively test for.

William Grant (wgrant) wrote :

Yeuclid wrote:
> As a very new Ubuntu user, I get the impression from all this that
> things are not as rosy as one might be led to believe. I thought the
> concept was collaboration and support. What I have seen with this saga
> is evidence of passing the buck and the sad "ignore it and it might go
> away" syndrome.

It's more likely to be a case of "I've got no idea about it, but I'm a
volunteer so it's not a requirement. Maybe somebody else knows more."
syndrome. You're free to locate the fix yourself, and then it can be
fixed for everybody.

Everybody who works on mplayer within Ubuntu is a volunteer, and nobody
knows the mplayer codebase well. It's enormous, and very messy.

> Why can't it just be fixed, or is the Mencoder support team just going
> to pretend that the problem doesn't exist?

We need to have a fix in order for it to be fixed. We don't have one at
the moment.

mrklean (mrklean) wrote :

I have the same problem with the sound. I changed the conf files as mentioned above and will see if these work. I changed them both. If they work, I'll leave you know. One question...the the /etc/mplayer/mplayer.cong file.. the -ac under audio ends with a comma... in my file anyway ... is that supposed to be there.. I see it nowhere else ?? I'm not a programmer.. just asking a simple yes or no question LOL!!
Thanks ; )

mrklean (mrklean) wrote :

well, that didn't work..I'll keep on trying LOL!

mrklean (mrklean) wrote :

I have Devede 2.1.3.. I'm replacing feisty mencoder with the one from Edgy i386. I'll let you know what happens. I hope you don't mind me testing and telling what's happening. If so, leave me know ; )
Thanks

Yeuclid (cfraser) wrote :

At least somebody seems to be trying something, it's better than nobody doing anything.

Paulus (donmatteo) wrote :

Guys - please take your conversation to some other place if you have
nothing new to add to this bug report. This report is only for
discussing fixes for the bug, i.e. mostly for developers.

mrklean (mrklean) wrote :

OK...no problem. I just thought it would help to let the devs know what doesn't work for a work around!
Laters

mrklean (mrklean) wrote :

Anything happening with this bug ???

Changed in mplayer:
status: Confirmed → Fix Released
William Grant (wgrant) on 2007-08-16
Changed in mplayer:
status: New → Fix Committed
status: Fix Released → Confirmed
31 comments hidden view all 111 comments

My patch did not touched anything related to video output settings, surely
it should get a new bug report, with my possible solution mentioned above.

On 8/16/07, Raster <email address hidden> wrote:
>
> Before installing your patch I deleted all the files in /etc/mplayer and
> in ~/.mplayer, to ensure that there was no interferences between my old
> configuration and the new one.
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Fabio Pugliese Ornellas
E-Mail: <email address hidden>
gTalk: <email address hidden>
ICQ: 6516089
MSN: <email address hidden>
WWW: http://ornellas.apanela.com/

Matti Lindell (mlind) wrote :

Fabio, don't introduce dpatch, but apply your patches 'inline' and post the .diff. Ubuntu mplayer is 'maintained' using bzr (https://code.launchpad.net/~ubuntu-dev/mplayer/ubuntu) and this is why dpatch stuff was dropped since edgy (see debian/changelog).

If this issue is also in current development version (gutsy), it needs/should to be fixed before the stable version (feisty).

I am sorry, but I don't get it.

My fix is quite simple, just change a few lines in a file here and there. Any package maintainer could do it in 1/5 the time I spent to make this dpatch thing you said was dropped (I was not aware of that). I spent a few hours remembering all packing stuff, reading documentation compiling the thing many times to ensure it works, tested upgrade, clean install etc etc etc....

So, why not any mplayer package maintainer just change those few lines and make it the right Ubuntu way? I am sorry, but I can not help more that what I did. I will do it again and surely will make another thing wrong / missing. So, lets just let packagers do their part on this whole, and users / contributors (eg. myself) make ours.

Please do not take me wrong. I am not full aware of Ubuntu packing system, people / assignments and stuff. All I know is that I already gave a solution on July 11, a patch (not "correct" Ubuntu way) on August 15 , confirmation that my fix solves the issue a few hors ago and until now I have not seen anything done for real to take up or kick away my solution (except Raster's feedback). All I see is a bunch of users confirming the bug on this thread asking for solution.

So, if anyone with enough access to fix this and commit the fix to both Feisty and Gutsy decides to take action, nice to every mplayer /mencoder / dependent packages users. I will not stress myself anymore on this matter.

jeroenl (jeroenl) wrote :

Any update on this? Someone tried it in a recent Gutsy!?

gnudoc (gnudoc) wrote :

I can confirm that this bug is fixed in current gutsy (1/10/07) which uses mplayer version 2:1.0~rc1-0ubuntu11. This plays mp3 files properly, whether on the command line or via gmplayer. I have tested the following codecs: mad, mp3, and ffmp3.

Changed in mplayer:
status: Confirmed → Fix Released
jeroenl (jeroenl) wrote :

No this not about playback anymore, but about encoding (mencoder).

jeroenl (jeroenl) wrote :

I tested it again and the problem is still there :-(.

gnudoc (gnudoc) wrote :

mencoder still buggy.

Changed in mplayer:
status: Fix Released → Confirmed
Changed in mplayer:
assignee: nafallo → motumedia
Sargate Kanogan (sargate) wrote :

some workaround or something for gutsy?
at least the example config file we have to change
i have no problem with playing, only when encoding

Have a look at my previous emails, I already gave a solution.

On 10/15/07, Sargate Kanogan <email address hidden> wrote:
>
> some workaround or something for gutsy?
> at least the example config file we have to change
> i have no problem with playing, only when encoding
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Fabio Pugliese Ornellas
E-Mail: <email address hidden>
gTalk: <email address hidden>
ICQ: 6516089
MSN: <email address hidden>
WWW: http://ornellas.apanela.com/

mirak (mirak-mirak) wrote :

Yes thanks,
but unless you come on this bug tracker, you won't find a solution, because it's still not fixed in gutsy.

mirak (mirak-mirak) wrote :

it's a shame this fix you provide really solve the problem :

******************************
Insert the file /usr/share/doc/mplayer/examples/etc/codecs.conf.gz to /etc/mplayer/codecs.conf o be part of the package, as a configuration file. Also, edit it, moving the whole mad entry right before the mp3lib entry. Also, the line ac=mad, at /etc/mplayer/mplayer.conf can be commented / removed.
******************************

Fabio +1 point, Ubuntu MPlayer Team 0...

On 10/25/07, mirak <email address hidden> wrote:
>
> it's a shame this fix you provide really solve the problem :
>
> ******************************
> Insert the file /usr/share/doc/mplayer/examples/etc/codecs.conf.gz to
> /etc/mplayer/codecs.conf o be part of the package, as a configuration file.
> Also, edit it, moving the whole mad entry right before the mp3lib entry.
> Also, the line ac=mad, at /etc/mplayer/mplayer.conf can be commented /
> removed.
> ******************************
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Fabio Pugliese Ornellas
E-Mail: <email address hidden>
gTalk: <email address hidden>
ICQ: 6516089
MSN: <email address hidden>
WWW: http://ornellas.apanela.com/

Matti Lindell (mlind) wrote :

Please stop posting useless comments to this bug report. If you have a patch, you've tested it and it works, then just subscribe universe-sponsors to get a review for it. Hardy repositories are open.

jeroenl (jeroenl) wrote :

@mlind: That is very arrogant. The problem is here since Feisty and a lot of non-developers/non-packagers provided solutions and even patches (that one unfortunately was not accepted because Ubuntu changed the way they handle patches).

This bug should already be fixed 8 months ago. Please let the users do their thing (reporting bugs) and developers/packagers their thing (resolving bugs).

"Useless comment"? I´'d try to explain myself here, but jeroenvrp already
did a very good job...

I´ll complement one thing: prefer NOT to ship a buggy package, than ship it
and let Ubuntu users get disgusted by its (known, old, fixable) bugs. A
MPlayer bug IS an Ubuntu bug. Not my distribution, not my decision. Just
keep doing what Ubuntu folks believe is right.

By the way, I´d everything myself if I had the time to. Perhaps it is now
time to open a spot for new good souls to look after Ubuntu´s MPlayer
packages... I´m no expert at Ubuntu, just my user´s point of view.

I´ll now leave and pray for all users with this bug find this topic quickly
and solve their problems with no pain.

Got it?

On 10/25/07, jeroenvrp <email address hidden> wrote:
>
> @mlind: That is very arrogant. The problem is here since Feisty and a
> lot of non-developers/non-packagers provided solutions and even patches
> (that one unfortunately was not accepted because Ubuntu changed the way
> they handle patches).
>
> This bug should already be fixed 8 months ago. Please let the users do
> their thing (reporting bugs) and developers/packagers their thing
> (resolving bugs).
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Fabio Pugliese Ornellas
E-Mail: <email address hidden>
gTalk: <email address hidden>
ICQ: 6516089
MSN: <email address hidden>
WWW: http://ornellas.apanela.com/

William Grant (wgrant) wrote :

Nobody particularly wants to sift through hundreds of thousands of lines of diff, nor is obligated to. I'm currently working on upgrading our package to 1.0rc2 (along with some other big changes), which should fix this. I will post links to packages for testing in the next couple of days.

Changed in mplayer:
assignee: motumedia → fujitsu
status: Confirmed → In Progress
status: Fix Committed → Fix Released

Wiiiiiiiiiii!!!!!!!!!!!!!! Thanx buddy!

On 10/28/07, William Grant <email address hidden> wrote:
>
> Nobody particularly wants to sift through hundreds of thousands of lines
> of diff, nor is obligated to. I'm currently working on upgrading our
> package to 1.0rc2 (along with some other big changes), which should fix
> this. I will post links to packages for testing in the next couple of
> days.
>
> ** Changed in: mplayer (Ubuntu)
> Assignee: MOTU Media Team (motumedia) => William Grant (fujitsu)
> Status: Confirmed => In Progress
>
> ** Changed in: mplayer
> Status: Fix Committed => Fix Released
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Fabio Pugliese Ornellas
E-Mail: <email address hidden>
gTalk: <email address hidden>
ICQ: 6516089
MSN: <email address hidden>
WWW: http://ornellas.apanela.com/

jeroenl (jeroenl) wrote :

That is indeed good news. Thanks William!

fabioamd87 (fabioamd87) wrote :

good!

Yeuclid (cfraser) wrote :

I was one of the first to report this problem, and have used the amended
version from the Devede web site to get round it.

A few weeks ago, I installed Kubuntu 7.10 on a spare machine and downloaded
all the updates to make it into the full release version.

I decided to install Devede just to see what happened, as packages from the
repositories. To my surprise it worked and I converted the first 5 minutes
of an AVI file to DVD format without any distortion or video interference.

What is the difference and why does it work on Kubuntu and not Ubuntu.

I am confused, any ideas?

May be Debian already forces a working codec for MP3 or they have applied
the patch from CVS to fix the bug. As reported, it will be fixed on Ubuntu
8.04 (am I right?). Nothing for Gutsy though.

On 10/29/07, Yeuclid <email address hidden> wrote:
>
> I was one of the first to report this problem, and have used the amended
> version from the Devede web site to get round it.
>
> A few weeks ago, I installed Kubuntu 7.10 on a spare machine and
> downloaded
> all the updates to make it into the full release version.
>
> I decided to install Devede just to see what happened, as packages from
> the
> repositories. To my surprise it worked and I converted the first 5 minutes
> of an AVI file to DVD format without any distortion or video interference.
>
> What is the difference and why does it work on Kubuntu and not Ubuntu.
>
> I am confused, any ideas?
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Fabio Pugliese Ornellas
E-Mail: <email address hidden>
gTalk: <email address hidden>
ICQ: 6516089
MSN: <email address hidden>
WWW: http://ornellas.apanela.com/

William Grant (wgrant) wrote :

On Mon, 2007-10-29 at 23:07 +0000, Fabio Ornellas wrote:
> May be Debian already forces a working codec for MP3 or they have applied
> the patch from CVS to fix the bug. As reported, it will be fixed on Ubuntu
> 8.04 (am I right?). Nothing for Gutsy though.

Kubuntu shares the same packages as Ubuntu, so what Debian has done will
make no difference between the two. I suspect it's due to differing
audio drivers, or perhaps just general mplayer {crazi,random}ness.

Debian fixed this by going to 1.0rc2, as we will for Hardy (ie. 8.04
LTS)

jeroenl (jeroenl) wrote :

I have Kubuntu and have the bug, as everyone should already know by now.

Anyway, hopefully the new mplayer/mencoder package will be available in the Gutsy backports.

William Grant (wgrant) wrote :

On Tue, 2007-10-30 at 11:50 +0000, jeroenvrp wrote:
> I have Kubuntu and have the bug, as everyone should already know by now.
>
> Anyway, hopefully the new mplayer/mencoder package will be available in
> the Gutsy backports.

That is what I aim for, yes. Additionally, I'll also compile the 1.0rc2
testing packages for Feisty and Gutsy in the next couple of days.

Yeuclid (cfraser) wrote :

So it suggests that there is some conflict somewhere with another package I
don't have on my version of Kubuntu?

----- Original Message -----
From: "jeroenvrp"
Subject: [Bug 85751] Re: Distorted MP3 sound

I have Kubuntu and have the bug, as everyone should already know by now.

Anyway, hopefully the new mplayer/mencoder package will be available in
the Gutsy backports.

Changed in mplayer:
assignee: fujitsu → superm1
Mario Limonciello (superm1) wrote :

mplayer (2:1.0~rc2-0ubuntu1) hardy; urgency=low

  * New upstream version.
    - Packaging (LP: #150925)
    - MP3 Distortion (LP: #85751)
    - Aspect ratio fixes (LP: #103038, #153543)
    - Samba support (LP: #85052)
  * Move 01_default_config.dpatch into bzr.
  * Drop dpatch from build-depends and debian/rules
  * Add liblzo2-dev, libdvdnav-dev, libopenal-dev,
    libjack-dev, libtwolame-dev, libsvga1-dev to build dependencies.
  * debian/rules:
    - Build with radio interface support
    - Build with OpenAL, Jack audio support. (LP: #122042)
    - Let Xvid support be autodetected for proper linking.
    - Let Faac support be autodetected for proper linking.
    - Let fontconfig support be autodetected for proper linking.
    - Let LIVE555 support be autodetected for proper linking.
    - Drop DOCS/zh from dh_installdocs
    - Build with dvdnav support.
    - Adjust changelog that gets installed.
  * Add polish translation for .desktop file (LP: #93382)
  * Adjust configure script to properly link dbus-glib and pulse audio.
  * Disable joystick by default (LP: #75925)
  * Adjust configure script to call dvdnav-config properly.

 -- Mario Limonciello <email address hidden> Sat, 03 Nov 2007 09:26:21 -0400

Changed in mplayer:
status: In Progress → Fix Released
Yeuclid (cfraser) wrote :

What is the status of this fix now?

Has it made it into the 7.10 repositories yet?

How can it be used to fix the Devede problem?

----- Original Message -----
From: "Mario Limonciello" <email address hidden>
Sent: Monday, November 05, 2007 8:50 AM
Subject: [Bug 85751] Re: Distorted MP3 sound

mplayer (2:1.0~rc2-0ubuntu1) hardy; urgency=low

 -- Mario Limonciello <email address hidden> Sat, 03 Nov 2007 09:26:21
-0400

** Changed in: mplayer (Ubuntu)
       Status: In Progress => Fix Released

--
Distorted MP3 sound
https://bugs.launchpad.net/bugs/85751
You received this bug notification because you are a direct subscriber
of the bug.

I guress the official fix is only available to the next version, or at some
backport repository.

You may however, find my fix at previous messages, where I pint a simple
file at /etc fix the issue.

[]´s

On Nov 11, 2007 10:45 PM, Yeuclid <email address hidden> wrote:

> What is the status of this fix now?
>
> Has it made it into the 7.10 repositories yet?
>
> How can it be used to fix the Devede problem?
>
>
>
> ----- Original Message -----
> From: "Mario Limonciello" <email address hidden>
> Sent: Monday, November 05, 2007 8:50 AM
> Subject: [Bug 85751] Re: Distorted MP3 sound
>
>
> mplayer (2:1.0~rc2-0ubuntu1) hardy; urgency=low
>
>
> -- Mario Limonciello <email address hidden> Sat, 03 Nov 2007 09:26:21
> -0400
>
> ** Changed in: mplayer (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Fabio Pugliese Ornellas
E-Mail: <email address hidden>
gTalk: <email address hidden>
ICQ: 6516089
MSN: <email address hidden>
WWW: http://ornellas.apanela.com/

jeroenl (jeroenl) wrote :

Very good news. RC2 is in the Gutsy-backports: http://packages.ubuntu.com/cgi-bin/search_packages.pl?keywords=mencoder&searchon=names&subword=1&version=gutsy-backports&release=all and it works!

So this can be closed. Thank you all and hopefully these kind of things will not happen again.

I tested it today and yes, it works!!!!! Thanks!!!!!

Will RC2 be moved to the official repositories in the short term, or it will be available only in Backports forever?

Mario Limonciello (superm1) wrote :

It will be living in backports for feisty and gutsy. It's in the normal repositories for hardy.

Yeuclid (cfraser) wrote :

I got round this problem with the "special" Devede version on Fabio's website.

I'm not familiar with backports, how can I now install a "real, clean" version of Devede from the repositories using the new improved Mplayer?

I'm running 7.10 latest release version.

Thanks

Mario Limonciello (superm1) wrote :

https://help.ubuntu.com/community/UbuntuBackports

On Nov 27, 2007 1:30 PM, Yeuclid <email address hidden> wrote:

> I got round this problem with the "special" Devede version on Fabio's
> website.
>
> I'm not familiar with backports, how can I now install a "real, clean"
> version of Devede from the repositories using the new improved Mplayer?
>
> I'm running 7.10 latest release version.
>
> Thanks
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a bug assignee.
>

--
Mario Limonciello
<email address hidden>

Yeuclid (cfraser) wrote :

Thanks, but as a relatively beginner who wants to learn I found that answer as helpful as being pushed off a cliff and told to fly.

When will you "gurus" accept that some of us, although quite intelligent, may not have the brain power of the universe at our fingertips, as you lot seem to think you have.

Just help us out and maybe, just maybe, we'll persevere with Ubuntu and stick with it. If you are on some crusade, get people to join you, don't treat them with contempt.

Evangelists win converts, they don't totally antagonize them.

Jonathan Cruz (drpfenderson) wrote :

You need to go to your Software Sources, to the Third-Party Software
tab and add that address as a repository. Then just go to terminal
and:
sudo apt-get update
sudo apt-get upgrade

...if you have the old versions installed. If not, just:
sudo apt-get update
sudo apt-get install mplayer mencoder

Hope that helps a little more, Yeuclid.

On Nov 27, 2007 4:26 PM, Yeuclid <email address hidden> wrote:
> Thanks, but as a relatively beginner who wants to learn I found that
> answer as helpful as being pushed off a cliff and told to fly.
>
> When will you "gurus" accept that some of us, although quite
> intelligent, may not have the brain power of the universe at our
> fingertips, as you lot seem to think you have.
>
> Just help us out and maybe, just maybe, we'll persevere with Ubuntu and
> stick with it. If you are on some crusade, get people to join you, don't
> treat them with contempt.
>
> Evangelists win converts, they don't totally antagonize them.
>
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Eris Siva
http://ufocus.org
Get Firefox: http://getfirefox.com

Jonathan Cruz (drpfenderson) wrote :

Oops...I realized that I gave the insrtuctions for manually adding a repo.
You need to go to the Updates tab of Software Sources and checkmark
"Unsupported updates (gutsy-backports)" and then run the same commands
I listed in my last post.

Sorry about that!

On Nov 27, 2007 5:13 PM, Eris Siva <email address hidden> wrote:
> You need to go to your Software Sources, to the Third-Party Software
> tab and add that address as a repository. Then just go to terminal
> and:
> sudo apt-get update
> sudo apt-get upgrade
>
> ...if you have the old versions installed. If not, just:
> sudo apt-get update
> sudo apt-get install mplayer mencoder
>
> Hope that helps a little more, Yeuclid.
>
>
> On Nov 27, 2007 4:26 PM, Yeuclid <email address hidden> wrote:
> > Thanks, but as a relatively beginner who wants to learn I found that
> > answer as helpful as being pushed off a cliff and told to fly.
> >
> > When will you "gurus" accept that some of us, although quite
> > intelligent, may not have the brain power of the universe at our
> > fingertips, as you lot seem to think you have.
> >
> > Just help us out and maybe, just maybe, we'll persevere with Ubuntu and
> > stick with it. If you are on some crusade, get people to join you, don't
> > treat them with contempt.
> >
> > Evangelists win converts, they don't totally antagonize them.
> >
> >
> > --
> > Distorted MP3 sound
> > https://bugs.launchpad.net/bugs/85751
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
>
>
>
> --
> Eris Siva
> http://ufocus.org
> Get Firefox: http://getfirefox.com
>

--
Eris Siva
http://ufocus.org
Get Firefox: http://getfirefox.com

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Yeuclid escribió:

Hi:

> When will you "gurus" accept that some of us, although quite
> intelligent, may not have the brain power of the universe at our
> fingertips, as you lot seem to think you have.

Ok, let's do it "the easy way":

Go to "System->Administration->Software Sources" (I'm using ubuntu in
spanish, so is possible that the names aren't exactly that. Here you
will have to try). It will ask you the password, because is an
administration tool.

Now, in that new tool, go to the tab "Third party software", check the
option "Unsupported updates (gutsy-backports)" and close the window with
the "Close" button (don't use the X in the window bar). It will ask you
to reload the packages list: do it.

Now go to "System->Administration->Synaptic" and install the
Mplayer/Mencoder packages.

When you have finished, you can uncheck the "Unsupported updates
(gusty-backports)" option to avoid the update manager to replace other
packages. Or you can leave it and have your system with the really last
versions of the packages (remember that in Backports are always newer
versions than in the official distribution, but they aren't officially
supported.

- --
Nos leemos
           RASTER (Linux user #228804)
<email address hidden> http://www.rastersoft.com

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHTJ6iXEZvyfy1ha8RAgYGAKDDvrkaG/gu1KgQlvgFANOOzi/0TQCgnotH
/AjQ7Dda8rFx/RYWskeSo4s=
=Zqxf
-----END PGP SIGNATURE-----

Mario Limonciello (superm1) wrote :

I was very short in my answer for a reason. As much as we can all
point you at how to activate backports, there are appropriate places
to ask things like this such as launchpad answers, the forums, mailing
list, or irc.
This isn't meant to come across as pompous, but rather to avoid
putting bug spam not relevant to developers and users watching this bug.

--
Mario Limonciello
<email address hidden>
Sent from my iPod Touch

On Nov 27, 2007, at 16:48, Raster <email address hidden> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Yeuclid escribió:
>
> Hi:
>
>> When will you "gurus" accept that some of us, although quite
>> intelligent, may not have the brain power of the universe at our
>> fingertips, as you lot seem to think you have.
>
> Ok, let's do it "the easy way":
>
> Go to "System->Administration->Software Sources" (I'm using ubuntu in
> spanish, so is possible that the names aren't exactly that. Here you
> will have to try). It will ask you the password, because is an
> administration tool.
>
> Now, in that new tool, go to the tab "Third party software", check the
> option "Unsupported updates (gutsy-backports)" and close the window
> with
> the "Close" button (don't use the X in the window bar). It will ask
> you
> to reload the packages list: do it.
>
> Now go to "System->Administration->Synaptic" and install the
> Mplayer/Mencoder packages.
>
> When you have finished, you can uncheck the "Unsupported updates
> (gusty-backports)" option to avoid the update manager to replace other
> packages. Or you can leave it and have your system with the really
> last
> versions of the packages (remember that in Backports are always newer
> versions than in the official distribution, but they aren't officially
> supported.
>
> - --
> Nos leemos
> RASTER (Linux user #228804)
> <email address hidden> http://www.rastersoft.com
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.6 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
>
> iD8DBQFHTJ6iXEZvyfy1ha8RAgYGAKDDvrkaG/gu1KgQlvgFANOOzi/0TQCgnotH
> /AjQ7Dda8rFx/RYWskeSo4s=
> =Zqxf
> -----END PGP SIGNATURE-----
>
> --
> Distorted MP3 sound
> https://bugs.launchpad.net/bugs/85751
> You received this bug notification because you are a bug assignee.

Yeuclid (cfraser) wrote :

To all who responded to my earlier blow-up I thank you.

Apologies if this is not the correct place to air these issues, but I get really exasperated when those with knowledge do not appear to want to share it.

I used to be a teacher, and imparting knowledge is an ethos I strongly believe in.

I also believe in the philosophy of Ubuntu - Tolerance and Humanity........ let us ALL learn

Displaying first 40 and last 40 comments. View all 111 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers