Ubuntu

(oneiric) mplayer does not install .desktop file and does not have an icon

Reported by eros2 on 2011-09-23
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
MPlayer
New
Undecided
Unassigned
mplayer2
New
Unknown
mplayer2 (Ubuntu)
Undecided
Unassigned
mplayer (Ubuntu)
Undecided
Unassigned

Bug Description

Mplayer does not install a .desktop file and does not install an icon.

This causes:

1) In nautilus (and possibly elsewhere), you cannot set mplayer to open audio/video files.

2) In Unity's launcher and elsewhere, no icon is displayed.

See attached screenshot.

2) only happens if mplayer started without terminal window (as associated application from nautilus), if it started from terminal - launcher display question mark icon, which is ok.

Issue present on Oneiric Ocelot final.

eros2 (eros2) wrote :
eros2 (eros2) on 2011-09-23
description: updated
eros2 (eros2) on 2011-09-23
summary: - mplayer does not have icon in launcher and switcher
+ (oneiric) mplayer does not have icon in launcher and switcher

The bug is not reproduce able for me i tried but movie player's icon is present in the launcher and in the switcher.
just answer me a question
 Is your system is fully updated??

eros2 (eros2) wrote :

> Is your system is fully updated??

Yes, just updated. Unity package version is "4.16.0-0ubuntu2 (oneiric)".

To reproduce:
- install "mplayer" package (just mplayer, no gui)

- to make mplayer available to nautilus - create .desktop file in ~/.local/share/applications with content:
   [Desktop Entry]
   Encoding=UTF-8
   Version=1.0
   Type=Application
   Exec=mplayer %f
   Name=mplayer
   NoDisplay=true

This step needed as nautilus in gnome 3 lacks option "use my own command" in "open with..." window.

- in nautilus, right click video file, open in -> another application -> show another applications - find mplayer and select. (My menuitems text in Russian, so I may name it incorrectly in English.)

- when mplayer starts playing, you will see an issue.

Bilal Shahid (s9iper1) wrote :

sorry i am not be able to reprocuce this bug.i am attaching a vedio watch this and told me that i have followed the right steps because just understand ur last paragraph.so watch the vedio and let me know if i m missing some thing?

eros2 (eros2) wrote :

> sorry i am not be able to reprocuce this bug.i am attaching a vedio watch

Ah, you use "Movie Player" while I told about "mplayer" (http://www.mplayerhq.hu).
mplayer installable using "mplayer" package (sudo apt-get install mplayer).

Bilal Shahid (s9iper1) wrote :

ignore my last comment and vedio see this
so here is the result i am not be able to reproduce this bug, in vedio you can easily see that the icon is present in launcher and in swircher so
thank you for filing the bug to make ubuntu better,
marking incomplete.
soory about the last comment and vedio

Changed in unity (Ubuntu):
status: New → Incomplete
Doug McMahon (mc3man) wrote :

I can confirm that if mplayer is run in the background that it will not show as a launcher icon (.desktop), though I've never expected it to.
If you add a line to the .desktop - Terminal=true then you will get the expected results & the terminal will minimize to the launcher icon if desired, - though see below
Attached screen shows

@eros2
What I use is 2 mplayer .desktops w/ the term line & a MimeType= line, 1 for all audio/video types, 1 for playlists,
In my case I do add them to the launcher for Drag & Drop , though r. click from nautilus also works fine

(currently there may be a bug about a process running in a minimized terminal crashing compiz when it ends & the terminal exits in a minimized state

eros2 (eros2) wrote :

On out-2.ogv I see "gnome-mplayer", while I told about "mplayer". Plain mplayer without a GUI...

Bilal Shahid (s9iper1) on 2011-09-23
affects: unity (Ubuntu) → gnome-mplayer (Ubuntu)
eros2 (eros2) wrote :

> If you add a line to the .desktop - Terminal=true then you will get the expected results

Yes, but in Natty icon displayed correctly even with Terminal=false, while disappear in Oneiric.

eros2 (eros2) wrote :

Adding "Icon=totem" into .desktop file solves the issue.

Launchpad Janitor (janitor) wrote :

[Expired for gnome-mplayer (Ubuntu) because there has been no activity for 60 days.]

Changed in gnome-mplayer (Ubuntu):
status: Incomplete → Expired
TomasHnyk (sup) on 2011-11-26
affects: gnome-mplayer (Ubuntu) → mplayer (Ubuntu)
Changed in mplayer (Ubuntu):
status: Expired → Confirmed
TomasHnyk (sup) on 2011-11-26
summary: - (oneiric) mplayer does not have icon in launcher and switcher
+ (oneiric) mplayer does not install .desktop file and does not have an
+ icon
TomasHnyk (sup) on 2011-11-26
description: updated
tags: added: bitesize desktop-file icon
Changed in mplayer2 (Ubuntu):
status: New → Confirmed
TomasHnyk (sup) on 2011-12-12
no longer affects: mplayer2
affects: mplayer → mplayer2
TomasHnyk (sup) wrote :

The bug for mission icon is here: http://devel.mplayer2.org/ticket/130 (this should be actually split into teo bug reports, but I am to lazy to do that).

Changed in mplayer2:
status: Unknown → New
Changed in mplayer:
status: Unknown → New
Reinhard Tartler (siretart) wrote :

this bug has not been forwarded to mplayer. I've removed the duplicated buglink to the mplayer2 bugtracker, which is a seperate project with different developers and procedures.

Changed in mplayer:
importance: Unknown → Undecided
Doug McMahon (mc3man) wrote :

Sounds like an exceedingly poor idea to have a terminal=false line in the.desktop, have you all actually tried this?

Testing your .desktop here has 2 effects -
The icon in the launcher has no control over the mplayer instance
The cpu use is abnormally high, 99% of one cpu

Here I do use a mplayer .desktop that does control the instance & cpu is low as expected - an Ex. (excuse my icon, a green apple is ok for me
This is used both from the r. click context & as a DnD in the launcher

TomasHnyk (sup) wrote :

Doug: yes, but with terminal=true, you will get a terminal and a mplayer windows which (at least to me) is not a desirable effect. However, with terminal=false, you do not get an icon, that is true.

TomasHnyk (sup) wrote :

Doug: did you try loggin out and in after using terminal=false? Because after I logged out and in, I now get a green apple even with terminal=false.

Anyway, there is also a bug for cmd application not showing up in unity here: bug 782926.

Christian Weiske (cweiske) wrote :

It works for me with the following deskop file in ~/.local/share/applications/mplayer.desktop

[Desktop Entry]
Name=MPlayer
GenericName=Media player
Exec=mplayer %U
TryExec=mplayer
Icon=mplayer
Type=Application
Categories=AudioVideo;Player;
NoDisplay=true

I've created the icons with:

$ cd ~
$ wget http://upload.wikimedia.org/wikipedia/commons/8/81/MPlayer.svg
$ cd /usr/share/icons/hicolor
$ for i in *x*; do sudo convert -background none ~/Mplayer.svg -resize $i $i/apps/mplayer.png; done
$ sudo gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor

eros2 (eros2) wrote :

I reported not about mplayer, but about any generic app, which does not have .desktop file.

Bug #886778 is same, but fixed only for Quantal. Please fix for Precise!

Leonardo Donelli (learts92) wrote :

Bug still present in Ubuntu 13.04
I like mplayer without gui frontends: I only use his keyboard shortcuts, and the minimal window with just the titlebar is perfect (actually, a border-only window with the Unity top title bar would be even better)
But without a .desktop file, I can't open a video file with it without passing through the terminal. I can't, for example, do open with -> mplayer. And there's no icon on dash / switcher / launcher.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.