please support h264 hardware acceleration on certain intel video cards

Bug #595661 reported by Emilio on 2010-06-17
82
This bug affects 16 people
Affects Status Importance Assigned to Milestone
libdrm (Ubuntu)
Wishlist
Unassigned
Declined for Maverick by Sebastien Bacher
libva (Ubuntu)
Undecided
Unassigned
Declined for Maverick by Sebastien Bacher
linux (Ubuntu)
Wishlist
Unassigned
Declined for Maverick by Sebastien Bacher
mplayer (Ubuntu)
Undecided
Unassigned
Declined for Maverick by Sebastien Bacher

Bug Description

Ubuntu should support h264 and mpeg2 hardware decoding through the use of vaapi on Intel cards.

Here is some Intel documentation on how to achieve this, including the patches needed:
http://intellinuxgraphics.org/h264.html

The libva stack should be updated from debian to support the G45 card series to 1.0.8 or higher
Currently being tracked in https://bugs.launchpad.net/ubuntu/+source/libva/+bug/721978

codewarrior (lvr) wrote :

h264 hardware decoding is an issue with html5 on forthcoming firefox 4.

Reinhard Tartler (siretart) wrote :

AFAIUI, this requires to promote the libva package to main.

Emilio (turl) wrote :

I have packaged some stuff for Lucid in a PPA: https://launchpad.net/~turl/+archive/intelhwaccel

It contains: a patched kernel, a patched libdrm, latest libva, and a (broken) ffmpeg build, which I still don't know why, but it has got its vaapi support disabled.

Bryce Harrington (bryce) on 2010-06-20
Changed in libdrm (Ubuntu):
status: New → Confirmed
Robert Hooker (sarvatt) on 2010-07-13
Changed in libdrm (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Fix Committed
Robert Hooker (sarvatt) wrote :

Fixed in libdrm 2.4.21 in maverick.

Changed in libdrm (Ubuntu):
status: Fix Committed → Fix Released
Robert Hooker (sarvatt) wrote :

Fixed by linux 2.6.35 that is in maverick.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Wishlist
status: New → Fix Released
Kwinz (ldm) wrote :

It is not fixed for me on Ubuntu 10.10.
Linux lenovo 2.6.35-22-generic #34-Ubuntu SMP Sun Oct 10 09:26:05 UTC 2010 x86_64 GNU/Linux
I have Q45 00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

If I enter:
~/ vainfo
libva: libva version 0.31.0
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/i965_drv_video.so
libva: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

After I manually do:
sudo aptitude install i965-va-driver

I get:
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple : VAEntrypointVLD
      VAProfileMPEG2Main : VAEntrypointVLD

No h264 still!

Mike (mike-fdb) wrote :

Recent version of vaapi library is required
http://freedesktop.org/wiki/Software/vaapi (git repo available)

Robert Hooker (sarvatt) wrote :

I only closed the kernel parts as fixed because those parts were, sorry for being unclear. Note upstream still to this day only supports h264 acceleration on intel HD video chipsets and not older mobile 4 series ones.

DiabboVerdde (geoffmartin) wrote :

But something is not clear yet. Which chipsets are supported? Is the G45 (X4500HD) supported for h264 acceleration?

Vladimir Yakovlev (nagos) wrote :

I build some packages for maverick:
- xserver-xorg-video-intel-2.13.0 - from natty
- libdrm2_2.4.22 - from natty
- libva-1.0.5 - intel upstream package
and get H.264 work on Intel GMA HD (Intel Core i5)

#vainfo

libva: libva version 0.31.1
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/i965_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA API version: 0.31
vainfo: Driver version: i965 Driver 0.1
vainfo: Supported profile and entrypoints
VAProfileMPEG2Simple : VAEntrypointVLD
VAProfileMPEG2Main : VAEntrypointVLD
VAProfileH264Baseline : VAEntrypointVLD
VAProfileH264Main : VAEntrypointVLD
VAProfileH264High : VAEntrypointVLD

To get H.264 in natty you need only libva-1.0.5 (now 1.0.2).

Emilio (turl) on 2011-02-20
Changed in libva (Ubuntu):
status: New → Confirmed
Changed in mplayer (Ubuntu):
status: New → Confirmed
description: updated
Emilio (turl) on 2011-02-20
description: updated
Daniël van Eeden (dveeden) wrote :

Bugs #531692 and #595661 might be duplicates.

Adam Niedling (krychek) wrote :

Daniël: Bug #531692 is not a duplicate of this bug. That one is about video acceleration support for the video players that use gstreamer (eg Totem, not VLC) and this one is about support for the Intel video card driver.

Btw h264 decoding is still not supported with Intel 4500MHD in Ubuntu 11.10:

$ vainfo
libva: libva version 0.32.0
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/i965_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA API version: 0.32
vainfo: Driver version: i965 Driver 0.1
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple : VAEntrypointVLD
      VAProfileMPEG2Main : VAEntrypointVLD

Timo Aaltonen (tjaalton) wrote :

Fixed in precise, vainfo lists VAProfileH264* at least for Sandybridge hw.

Changed in libva (Ubuntu):
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

some further notes: VLC should support vaapi, but video output hangs after the first frame or so, audio ok. Mplayer seems to not have been built with --enable-vaapi.

Adam Niedling (krychek) wrote :

Isn't it too early to close this bug just yet? We should wait until someone confirms that h264 acceleration works with 4500MHD too.

On Mi, Jan 04, 2012 at 12:01:36 (CET), Timo Aaltonen wrote:

> Mplayer seems to not have been built with --enable-vaapi.

The mplayer package in Ubuntu does not have vaapi support. There is a
fork callled 'mplayer-vaapi', however this work has been rejected by
both mplayer and mplayer2 upstream's because of poor implementation. It
would be great if somone would re-implement that properly so that it can
be merged upstream.

Packaging the vaapi enabled mplayer fork is tracked here:
https://bugs.launchpad.net/ubuntu/+bug/517467

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Benoe (benoe77) wrote :

In latest precise development version h264 decoding is still not supported with Intel 4500MHD:

libva: VA-API version 0.32.0
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/i965_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA-API version: 0.32 (libva 1.0.15)
vainfo: Driver version: Intel i965 driver - 1.0.15
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple : VAEntrypointVLD
      VAProfileMPEG2Main : VAEntrypointVLD

i965_drv_video.so is there (installed by libva-intel-vaapi-driver), don't know what is the problem with opening it.

The included Intel driver in Precise still misses support for H.264 and the G45 chips. To solve this issue quickly, one can use these commands:
git clone git://anongit.freedesktop.org/vaapi/intel-driver intel-driver
cd intel-driver/
apt-cache show libva1|grep Version
git checkout 1.0.15 (replace 1.0.15 with the version from above when it differs)
git pull origin g45-h264
./autogen.sh
make
sudo make install

I haven't tested with playing videos yet, but this makes vainfo show three extra H264 profiles.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers