Mplayer in Ubuntu repos is compiled without support for radio:// (analog radio)

Bug #593548 reported by Konstantinos Natsakis on 2010-06-14
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mplayer (Ubuntu)
Low
Unassigned
Quantal
Low
Unassigned
mplayer2 (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: mplayer

I find Mplayer to be the best application for listening to analog radio. Unfortunately analog radio support is disabled in Ubuntu's mplayer package.

I think that all that is needed is to pass --enable-radio --enable-radio-capture to ./configure during the build.
I tested this in my PPA: https://launchpad.net/~cyfex/+archive/ppa/+builds?build_text=mplayer&build_state=all and it seems to work fine.

Is there any intentional reason the version of mplayer in the Ubuntu repos isn't compiled with it?

Reinhard Tartler (siretart) wrote :

no, there is no intentional reason, I just missed it.

will add it for the next upload to maverick. Then we can consider SRU'ing it.

Changed in mplayer (Ubuntu):
importance: Undecided → Low
status: New → Triaged
DFOXpro (dfoxpro) wrote :

Reinhard Tartler (siretart) wrote on 2010-06-14: #1

no, there is no intentional reason, I just missed it.

will add it for the next upload to maverick. Then we can consider SRU'ing it.

in Natty the problem still happen (on official reps and motus'ppa MPlayer Daily Builds):

mplayer -radio driver=v4l2:device=/dev/radio0:adevice=2.0 radio://103.9
MPlayer was compiled without Radio interface support.
MPlayer SVN-r34349-4.5.2 (C) 2000-2011 MPlayer Team

PLEASE fix it

Changed in mplayer (Ubuntu):
status: Triaged → Confirmed
Roman (m01brv) wrote :

In Oneiric mplayer is still "compiled without radio interface support"
It looks strange that apparently so easily-fixable bug lives for so long time, does compiling with radio support causes some side troubles?

Roman (m01brv) wrote :

mplayer from Medibutu is also affected

Roman (m01brv) wrote :

After installing new Ubuntu 12.04 (beta) I still get the same error... Please, do not let this issue to go to the final release...

Bryce Harrington (bryce) on 2012-05-01
Changed in mplayer (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mplayer - 2:1.0~rc4.dfsg1+svn34540-1ubuntu2

---------------
mplayer (2:1.0~rc4.dfsg1+svn34540-1ubuntu2) quantal; urgency=low

  * debian/rules: Enable radio support. Backported fix from r34656.
    (LP: #593548)
 -- Bryce Harrington <email address hidden> Thu, 19 Jul 2012 14:16:19 -0700

Changed in mplayer (Ubuntu Quantal):
status: Triaged → Fix Released
Roman (m01brv) wrote :

I found that the bug affects mplayer2 in the same manner. Please make a fix for that one too...

Adolfo Jayme (fitojb) on 2014-06-22
Changed in mplayer2 (Ubuntu Quantal):
status: New → Triaged
Changed in mplayer2 (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
no longer affects: mplayer2 (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers